- Update to 0.50.1

- Evaluate OPTIONS _after_ inclusion of bsd.port.pre.mk.
- Mark BROKEN on FreeBSD < 5.x

PR:		96989
Submitted by:	Ronald Klop <ronald@cs.vu.nl> (maintainer)
Approved by:	arved (mentor)
This commit is contained in:
Stefan Walter 2006-05-10 17:25:51 +00:00
parent d0ff435e6f
commit 5fdcfb79e7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=161963
4 changed files with 29 additions and 33 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= jmp
PORTVERSION= 0.49
PORTREVISION= 1
PORTVERSION= 0.50.1
CATEGORIES= java devel
MASTER_SITES= http://www.khelekore.org/jmp/
@ -23,21 +22,6 @@ CONFIGURE_ARGS= --with-includes="${JAVA_HOME}/include ${LOCALBASE}/include" \
USE_BISON= yes
USE_GETTEXT= yes
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --enable-noui
.else
USE_XLIB= yes
LIB_DEPENDS+= gtk-x11-2.0:${PORTSDIR}/x11-toolkits/gtk20
.endif
.if defined(WITH_DEBUG)
CFLAGS+= -DJMPDEBUG -g
.endif
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3
.endif
USE_GMAKE= yes
USE_JAVA= yes
JAVA_VERSION= 1.2+
@ -59,4 +43,25 @@ PLIST_FILES= lib/libjmp.la lib/libjmp.so lib/libjmp.so.0 \
share/locale/de/LC_MESSAGES/jmp.mo \
share/locale/sv/LC_MESSAGES/jmp.mo
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --enable-noui
.else
USE_XLIB= yes
LIB_DEPENDS+= gtk-x11-2.0:${PORTSDIR}/x11-toolkits/gtk20
.endif
.if defined(WITH_DEBUG)
CFLAGS+= -DJMPDEBUG -g
.endif
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3
.endif
.if ${OSVERSION} < 500000
BROKEN= Does not build on FreeBSD < 5.x
.endif
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (jmp-0.49.tar.gz) = c79904c75bd74e7943be3f8f1c7768ee
SHA256 (jmp-0.49.tar.gz) = b3a7897f453772ed78e53aaece115b4b67e89303b366086e02c6e241552fceb1
SIZE (jmp-0.49.tar.gz) = 628499
MD5 (jmp-0.50.1.tar.gz) = 9b2e1f0ed1bf32920166d00475c20bf2
SHA256 (jmp-0.50.1.tar.gz) = 0349367cb5de07cd468b87263d634afaccc46a273059d57942a6a540f2806047
SIZE (jmp-0.50.1.tar.gz) = 628777

View File

@ -1,7 +1,7 @@
$FreeBSD$
--- Makefile.in.orig Sat Oct 29 21:48:51 2005
+++ Makefile.in Mon Nov 21 01:20:51 2005
@@ -332 +332 @@
--- Makefile.in.orig Mon May 8 20:06:38 2006
+++ Makefile.in Mon May 8 20:07:16 2006
@@ -1044 +1044 @@
- inst=`echo $$inst | sed '$(transform)'`.$$ext; \
+ inst=$$inst.$$ext; \

View File

@ -1,9 +0,0 @@
$FreeBSD$
--- ui_gtk.c.orig Sun Feb 12 22:53:25 2006
+++ ui_gtk.c Sun Feb 12 22:52:09 2006
@@ -307,0 +308 @@
+ GtkWidget *w;
@@ -309 +310 @@
- GtkWidget *w =
+ w =