Eliminate file conflicts with devel/autoconf
Add ${PREFIX}/libexec/autoconf213/* links PR: 36071 Submitted by: Alan Eldridge <ports@geeksrus.net>
This commit is contained in:
parent
b7f1abe7be
commit
5fd894bc29
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62730
@ -11,7 +11,7 @@
|
||||
|
||||
PORTNAME= autoconf213
|
||||
PORTVERSION= 2.13.000227
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEWARE} ${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= binutils autoconf
|
||||
@ -24,14 +24,21 @@ RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
|
||||
|
||||
USE_BZIP2= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= M4=${PREFIX}/bin/gm4
|
||||
CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
|
||||
CONFIGURE_ARGS= --program-suffix=213 --datadir=${PREFIX}/share/autoconf213
|
||||
WRKSRC= ${WRKDIR}/autoconf
|
||||
|
||||
post-patch:
|
||||
@-${RM} ${WRKSRC}/*.info*
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/install-sh \
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/install-sh \
|
||||
${PREFIX}/share/autoconf213/autoconf
|
||||
@install-info ${PREFIX}/info/autoconf.info ${PREFIX}/info/dir
|
||||
@install-info ${PREFIX}/info/standards.info ${PREFIX}/info/dir
|
||||
@-${RM} -fr ${PREFIX}/libexec/autoconf213
|
||||
@${MKDIR} ${PREFIX}/libexec/autoconf213
|
||||
.for i in autoconf autoheader autoreconf autoscan autoupdate ifnames
|
||||
@${LN} -s ../../bin/${i}213 ${PREFIX}/libexec/autoconf213/${i}
|
||||
.endfor
|
||||
@install-info ${PREFIX}/info/autoconf213.info ${PREFIX}/info/dir
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,5 +1,27 @@
|
||||
--- Makefile.in.orig Tue Jan 5 08:27:16 1999
|
||||
+++ Makefile.in Sat Jan 23 23:29:33 1999
|
||||
--- Makefile.in.orig Sun Feb 27 11:18:10 2000
|
||||
+++ Makefile.in Mon Mar 18 21:10:20 2002
|
||||
@@ -68,7 +68,7 @@
|
||||
DISTFILES = AUTHORS COPYING ChangeLog ChangeLog.1 INSTALL \
|
||||
Makefile.in NEWS README TODO $(M4FILES) \
|
||||
acconfig.h acfunctions acheaders acidentifiers \
|
||||
- acmakevars acprograms autoconf.info* \
|
||||
+ acmakevars acprograms autoconf213.info* \
|
||||
autoconf.sh autoconf.texi install.texi \
|
||||
autoheader.sh autoscan.pl autoreconf.sh autoupdate.sh ifnames.sh \
|
||||
config.guess config.sub configure configure.in \
|
||||
@@ -106,10 +106,10 @@
|
||||
autoconf.m4f: autoconf.m4 acgeneral.m4 acspecific.m4 acoldnames.m4
|
||||
autoheader.m4f: autoheader.m4 acgeneral.m4 acspecific.m4 acoldnames.m4
|
||||
|
||||
-info: autoconf.info @standards_info@ INSTALL
|
||||
+info: autoconf213.info
|
||||
|
||||
# Use --no-split to avoid creating filenames > 14 chars.
|
||||
-autoconf.info: autoconf.texi install.texi
|
||||
+autoconf213.info: autoconf.texi install.texi
|
||||
$(MAKEINFO) -I$(srcdir) $(srcdir)/autoconf.texi --no-split --output=$@
|
||||
|
||||
INSTALL: install.texi
|
||||
@@ -141,7 +141,7 @@
|
||||
|
||||
install: all $(M4FILES) acconfig.h installdirs install-info
|
||||
@ -9,7 +31,7 @@
|
||||
done
|
||||
for i in $(M4FROZEN); do \
|
||||
$(INSTALL_DATA) $$i $(acdatadir)/$$i; \
|
||||
@@ -150,9 +150,9 @@
|
||||
@@ -150,16 +150,16 @@
|
||||
$(INSTALL_DATA) $(srcdir)/$$i $(acdatadir)/$$i; \
|
||||
done
|
||||
-if test -f autoscan; then \
|
||||
@ -21,3 +43,20 @@
|
||||
$(INSTALL_DATA) $(srcdir)/$$i $(acdatadir)/$$i; \
|
||||
done; \
|
||||
else :; fi
|
||||
|
||||
# Don't cd, to avoid breaking install-sh references.
|
||||
install-info: info installdirs
|
||||
- if test -f autoconf.info; then \
|
||||
+ if test -f autoconf213.info; then \
|
||||
for i in *.info*; do \
|
||||
$(INSTALL_DATA) $$i $(infodir)/$$i; \
|
||||
done; \
|
||||
@@ -174,7 +174,7 @@
|
||||
rm -f $(bindir)/`echo $$p|sed '$(transform)'`; \
|
||||
done
|
||||
rm -fr $(acdatadir)
|
||||
- cd $(infodir) && rm -f autoconf.info*
|
||||
+ cd $(infodir) && rm -f autoconf213.info*
|
||||
if test -f standards.info || test -f $(srcdir)/standards.info; \
|
||||
then cd $(infodir) && rm -f standards.info*; fi
|
||||
|
||||
|
@ -1,10 +1,24 @@
|
||||
--- autoconf.texi.orig Tue Jan 5 08:28:37 1999
|
||||
+++ autoconf.texi Sat Jan 23 23:34:43 1999
|
||||
@@ -4,6 +4,7 @@
|
||||
@settitle Autoconf
|
||||
--- autoconf.texi.orig Sun Feb 27 11:18:10 2000
|
||||
+++ autoconf.texi Mon Mar 18 21:30:10 2002
|
||||
@@ -1,9 +1,10 @@
|
||||
\input texinfo @c -*-texinfo-*-
|
||||
@c %**start of header
|
||||
-@setfilename autoconf.info
|
||||
-@settitle Autoconf
|
||||
+@setfilename autoconf213.info
|
||||
+@settitle Autoconf213
|
||||
@c For double-sided printing, uncomment:
|
||||
@c @setchapternewpage odd
|
||||
+@dircategory Programming & development tools
|
||||
@c %**end of header
|
||||
|
||||
@set EDITION 2.13
|
||||
@@ -17,7 +18,7 @@
|
||||
@ifinfo
|
||||
@format
|
||||
START-INFO-DIR-ENTRY
|
||||
-* Autoconf: (autoconf). Create source code configuration scripts.
|
||||
+* Autoconf213: (autoconf213). Create source code configuration scripts.
|
||||
END-INFO-DIR-ENTRY
|
||||
@end format
|
||||
|
||||
|
@ -4,12 +4,15 @@ bin/autoreconf213
|
||||
bin/autoscan213
|
||||
bin/autoupdate213
|
||||
bin/ifnames213
|
||||
@unexec install-info --delete %D/info/autoconf.info %D/info/dir
|
||||
@unexec install-info --delete %D/info/standards.info %D/info/dir
|
||||
info/autoconf.info
|
||||
info/standards.info
|
||||
@exec install-info %D/info/autoconf.info %D/info/dir
|
||||
@exec install-info %D/info/standards.info %D/info/dir
|
||||
@unexec install-info --delete %D/info/autoconf213.info %D/info/dir
|
||||
info/autoconf213.info
|
||||
@exec install-info %D/info/autoconf213.info %D/info/dir
|
||||
libexec/autoconf213/autoconf
|
||||
libexec/autoconf213/autoheader
|
||||
libexec/autoconf213/autoreconf
|
||||
libexec/autoconf213/autoscan
|
||||
libexec/autoconf213/autoupdate
|
||||
libexec/autoconf213/ifnames
|
||||
share/autoconf213/autoconf/acconfig.h
|
||||
share/autoconf213/autoconf/acfunctions
|
||||
share/autoconf213/autoconf/acgeneral.m4
|
||||
@ -26,5 +29,6 @@ share/autoconf213/autoconf/autoheader.m4f
|
||||
share/autoconf213/autoconf/config.guess
|
||||
share/autoconf213/autoconf/config.sub
|
||||
share/autoconf213/autoconf/install-sh
|
||||
@dirrm libexec/autoconf213
|
||||
@dirrm share/autoconf213/autoconf
|
||||
@dirrm share/autoconf213
|
||||
|
Loading…
Reference in New Issue
Block a user