- Update to 0.23

PR:		ports/66216
Submitted by:	Florent Thoumie <flz@xbsd.org> (maintainer)
This commit is contained in:
Pav Lucistnik 2004-05-03 21:01:12 +00:00
parent 45dfa30db1
commit 5fc6113543
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=108317
6 changed files with 12 additions and 74 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= grdesktop
PORTVERSION= 0.22
PORTREVISION= 1
PORTVERSION= 0.23
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -21,10 +20,13 @@ USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= libgnomeui gnomeprefix gnomehack
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-keymap-path=${LOCALBASE}/share/rdesktop/keymaps
post-patch:
@${REINPLACE_CMD} -e 's|man_MANS = grdesktop.1|man_MANS =|' ${WRKSRC}/doc/Makefile.in
@${REINPLACE_CMD} -e 's|^\(GETTEXT_PACKAGE =\).*|\1 grdesktop|' ${WRKSRC}/po/Makefile.in.in
MAN1= grdesktop.1
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (grdesktop-0.22.tar.gz) = 6fa64e007e2b26bfe96e2516c0d6ddf4
SIZE (grdesktop-0.22.tar.gz) = 428426
MD5 (grdesktop-0.23.tar.gz) = 46f8f3e2d4aa2433b8b1537fefa8a4b7
SIZE (grdesktop-0.23.tar.gz) = 299914

View File

@ -1,14 +0,0 @@
--- intl/dcigettext.c.orig Fri Oct 11 21:38:35 2002
+++ intl/dcigettext.c Mon Dec 22 10:27:28 2003
@@ -58,11 +58,6 @@
#include <stdlib.h>
#include <string.h>
-#if !HAVE_STRCHR && !defined _LIBC
-# ifndef strchr
-# define strchr index
-# endif
-#endif
#if defined HAVE_UNISTD_H || defined _LIBC
# include <unistd.h>

View File

@ -1,14 +0,0 @@
--- src/global.h.old Mon Feb 2 14:05:53 2004
+++ src/global.h Tue Feb 3 15:07:16 2004
@@ -61,9 +61,9 @@
#define MAXHOSTS 10 /* maximum hosts to store */
#define PIXDIR DATADIR"/pixmaps/grdesktop"
-#ifndef KBPATH
+
+#undef KBPATH
#define KBPATH "/usr/local/share/rdesktop/keymaps/"
-#endif
#define GCONF_BASE "/apps/grdesktop/options"

View File

@ -1,36 +0,0 @@
--- src/options.c Tue Feb 3 09:49:48 2004
+++ src/options.c.new Sun Feb 29 17:23:08 2004
@@ -20,6 +20,7 @@
*/
+#include "global.h"
#include "options.h"
void fillRdpProtocols() {
@@ -276,6 +277,9 @@
item = g_slist_nth_data(values, i);
typ = gconf_entry_get_value(item);
+ if (!typ)
+ continue ;
+
path = g_strsplit(gconf_entry_get_key(item), "/", 0);
while(path[y] != NULL)
y++;
@@ -487,6 +491,7 @@
while((entry = readdir(licence_dir)) != NULL) {
gchar *fullname = NULL;
+ gchar *hostname = &entry->d_name[strlen(prefix)];
struct stat sts;
fullname = g_strdup_printf("%s/%s", licence_path,
@@ -500,7 +505,6 @@
if(strlen(entry->d_name) <= strlen(prefix))
continue;
- gchar *hostname = &entry->d_name[strlen(prefix)];
licence_list = g_list_append(licence_list, g_strdup(hostname));
}
closedir(licence_dir);

View File

@ -1,8 +1,8 @@
bin/grdesktop
etc/gconf/gconf.xml.defaults/apps/grdesktop/options/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/grdesktop/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/grdesktop/options/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/grdesktop/options/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/grdesktop/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/grdesktop/options/%gconf.xml
etc/gconf/schemas/grdesktop.schemas
share/gnome/application-registry/grdesktop.applications
share/gnome/applications/grdesktop.desktop
@ -36,7 +36,7 @@ share/locale/fr/LC_MESSAGES/grdesktop.mo
@dirrm share/gnome/omf/grdesktop
@dirrm share/gnome/help/grdesktop/C
@dirrm share/gnome/help/grdesktop
@dirrm etc/gconf/gconf.xml.defaults/apps/grdesktop/options
@dirrm etc/gconf/gconf.xml.defaults/apps/grdesktop
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/grdesktop/options
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/grdesktop
@dirrm etc/gconf/gconf.xml.defaults/apps/grdesktop/options
@dirrm etc/gconf/gconf.xml.defaults/apps/grdesktop