- Update to 3.9
- Add kqueue to recommended backends - Fix TABs in Makefile PR: 149681 Submitted by: mm
This commit is contained in:
parent
f52f1ea904
commit
5fa73c384b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=259430
@ -5,18 +5,19 @@
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libev
|
||||
PORTVERSION= 3.8
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://dist.schmorp.de/libev/Attic/
|
||||
PORTNAME= libev
|
||||
PORTVERSION= 3.9
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://dist.schmorp.de/libev/ \
|
||||
http://dist.schmorp.de/libev/Attic/
|
||||
|
||||
MAINTAINER= vsevolod@FreeBSD.org
|
||||
COMMENT= A full-featured and high-performance event loop library
|
||||
MAINTAINER= vsevolod@FreeBSD.org
|
||||
COMMENT= A full-featured and high-performance event loop library
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
MAN3= ev.3
|
||||
MAN3= ev.3
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (libev-3.8.tar.gz) = 4897453c077056769777d43e5495ded1
|
||||
SHA256 (libev-3.8.tar.gz) = 25e353af5707bc4261276e02901ad469e1a46c589eaf5f66c5d3275c98b12294
|
||||
SIZE (libev-3.8.tar.gz) = 470250
|
||||
MD5 (libev-3.9.tar.gz) = 40fe7d56d70db83cc0c22a6a68d87a96
|
||||
SHA256 (libev-3.9.tar.gz) = 0b81cb55a8eb0a2e3d2364a397e244812dd6dd496e860ed7bf143e39e4c21c2e
|
||||
SIZE (libev-3.9.tar.gz) = 473062
|
||||
|
15
devel/libev/files/patch-ev.c
Normal file
15
devel/libev/files/patch-ev.c
Normal file
@ -0,0 +1,15 @@
|
||||
--- ev.c.orig 2010-08-16 08:33:48.667681306 +0200
|
||||
+++ ev.c 2010-08-16 08:33:51.449982136 +0200
|
||||
@@ -1470,10 +1470,12 @@
|
||||
unsigned int flags = ev_supported_backends ();
|
||||
|
||||
#ifndef __NetBSD__
|
||||
+#ifndef __FreeBSD__
|
||||
/* kqueue is borked on everything but netbsd apparently */
|
||||
/* it usually doesn't work correctly on anything but sockets and pipes */
|
||||
flags &= ~EVBACKEND_KQUEUE;
|
||||
#endif
|
||||
+#endif
|
||||
#ifdef __APPLE__
|
||||
/* only select works correctly on that "unix-certified" platform */
|
||||
flags &= ~EVBACKEND_KQUEUE; /* horribly broken, even for sockets */
|
Loading…
Reference in New Issue
Block a user