audio/py-pyaudio: Update to 0.2.12
Changelog: https://people.csail.mit.edu/hubert/pyaudio/ PR: 267923
This commit is contained in:
parent
f27f862129
commit
5fa414e007
@ -1,6 +1,5 @@
|
||||
PORTNAME= pyaudio
|
||||
PORTVERSION= 0.2.11
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.2.12
|
||||
CATEGORIES= audio python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
@ -14,8 +13,8 @@ LICENSE= MIT
|
||||
|
||||
LIB_DEPENDS= libportaudio.so:audio/portaudio
|
||||
|
||||
USES= python:3.6+ gmake
|
||||
USE_PYTHON= distutils concurrent autoplist
|
||||
USES= gmake python:3.6+
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
|
||||
MAKE_ENV= PYTHON=${PYTHON_CMD} \
|
||||
SPHINX=sphinx-build-${PYTHON_VER}
|
||||
@ -31,10 +30,12 @@ post-patch:
|
||||
${WRKSRC}/setup.py
|
||||
|
||||
post-build-DOCS-on:
|
||||
(cd ${BUILD_WRKSRC} && ${DO_MAKE_BUILD} docs)
|
||||
(cd ${BUILD_WRKSRC} && \
|
||||
${DO_MAKE_BUILD} docs)
|
||||
|
||||
post-install-DOCS-on:
|
||||
(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name .buildinfo -and ! -path *doctrees*")
|
||||
(cd ${WRKSRC}/docs && \
|
||||
${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name .buildinfo -and ! -path *doctrees*")
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_portaudio*.so
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1490086382
|
||||
SHA256 (PyAudio-0.2.11.tar.gz) = 93bfde30e0b64e63a46f2fd77e85c41fd51182a4a3413d9edfaf9ffaa26efb74
|
||||
SIZE (PyAudio-0.2.11.tar.gz) = 37428
|
||||
TIMESTAMP = 1668872490
|
||||
SHA256 (PyAudio-0.2.12.tar.gz) = 55ddf5db72bc537bba5f5dbca3ab9f0222ee5b842bda83978eab0b7b8f60fb9e
|
||||
SIZE (PyAudio-0.2.12.tar.gz) = 42944
|
||||
|
@ -1,15 +1,15 @@
|
||||
--- setup.py.orig 2015-10-19 05:48:12 UTC
|
||||
--- setup.py.orig 2022-07-19 03:53:30 UTC
|
||||
+++ setup.py
|
||||
@@ -63,6 +63,12 @@ extra_link_args = []
|
||||
scripts = []
|
||||
defines = []
|
||||
@@ -56,6 +56,12 @@ def setup_extension():
|
||||
extra_link_args = []
|
||||
defines = []
|
||||
|
||||
+if sys.platform.startswith('dragonfly') or \
|
||||
+ sys.platform.startswith('freebsd'):
|
||||
+ include_dirs = ['%%LOCALBASE%%/include/']
|
||||
+ external_libraries = []
|
||||
+ extra_link_args = ['%%LOCALBASE%%/lib/libportaudio.so']
|
||||
+ if sys.platform.startswith('dragonfly') or \
|
||||
+ sys.platform.startswith('freebsd'):
|
||||
+ include_dirs = ['%%LOCALBASE%%/include/']
|
||||
+ external_libraries = []
|
||||
+ extra_link_args = ['%%LOCALBASE%%/lib/libportaudio.so']
|
||||
+
|
||||
if sys.platform == 'darwin':
|
||||
defines += [('MACOSX', '1')]
|
||||
if mac_sysroot_path:
|
||||
if sys.platform == 'darwin':
|
||||
# Support only dynamic linking with portaudio, since the supported path
|
||||
# is to install portaudio using a package manager (e.g., Homebrew).
|
||||
|
Loading…
Reference in New Issue
Block a user