- Support CC/CFLAGS/CXXFLAGS properly

- Support install macros
- perl -> ${PERL}
- Move install path of data files from lib/ to libdata/
- Add WWW: line into pkg/DESCR
- Fix pkg/PLIST

PR:		15918
Submitted by:	KATO Tsuguru <tkato@prontomail.ne.jp>
This commit is contained in:
R. Imura 2000-01-14 17:35:24 +00:00
parent a3b7d0c16a
commit 5f76ca8d6b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24729
8 changed files with 247 additions and 106 deletions

View File

@ -23,8 +23,7 @@ CONFIGURE_ARGS= --with-gcc=yes --with-double=yes
.include <bsd.port.pre.mk>
post-patch:
@perl -pi.bak -e "s|/usr/local/plplot/lib|${PREFIX}/lib/plplot|g;" \
${WRKSRC}/src/plctrl.c
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/src/*.c
post-install:
.if ${PORTOBJFORMAT} == "elf"
@ -32,5 +31,6 @@ post-install:
.else
${LN} -sf libplplotdX.so.4.99 ${PREFIX}/lib/libplplotdX.so
.endif
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.post.mk>

View File

@ -1,19 +1,34 @@
--- configure.orig Tue Jun 6 14:58:50 1995
+++ configure Sat Sep 26 23:34:48 1998
--- configure.orig Wed Jun 7 04:58:50 1995
+++ configure Wed Jan 5 00:15:16 2000
@@ -1175,10 +1175,10 @@
# ----------------------------------------------------------------------------
if test "$with_gcc" = "yes"; then
- CC=gcc
- CXX=gcc
- OCC="gcc -traditional"
- CPP="gcc -E"
+ CC=$CC
+ CXX=$CXX
+ OCC="$CC -traditional"
+ CPP="$CC -E"
if test "$with_warn" = "yes"; then
SYS_FLAGS_C=-Wall
@@ -1472,13 +1472,13 @@
# ----------------------------------------------------------------------------
CC_FLAGS=\
-"-c $DBL_FLAG_C $DEBUG_FLAG_C $SYS_FLAGS_C $PROF_FLAG_C $OPT_FLAG_C"
+"-c $CFLAGS $DBL_FLAG_C $DEBUG_FLAG_C $SYS_FLAGS_C $PROF_FLAG_C $OPT_FLAG_C"
+"-c $DBL_FLAG_C $DEBUG_FLAG_C $SYS_FLAGS_C $PROF_FLAG_C $CFLAGS"
CXX_FLAGS=\
-"-c $DBL_FLAG_CXX $DEBUG_FLAG_CXX $SYS_FLAGS_CXX $PROF_FLAG_CXX $OPT_FLAG_CXX"
+"-c $CFLAGS $DBL_FLAG_CXX $DEBUG_FLAG_CXX $SYS_FLAGS_CXX $PROF_FLAG_CXX $OPT_FLAG_CXX"
+"-c $DBL_FLAG_CXX $DEBUG_FLAG_CXX $SYS_FLAGS_CXX $PROF_FLAG_CXX $CXXFLAGS"
F77_FLAGS=\
-"-c $DBL_FLAG_F $DEBUG_FLAG_F $SYS_FLAGS_F $PROF_FLAG_F $OPT_FLAG_F"
+"-c $FFLAGS $DBL_FLAG_F $DEBUG_FLAG_F $SYS_FLAGS_F $PROF_FLAG_F $OPT_FLAG_F"
+"-c $DBL_FLAG_F $DEBUG_FLAG_F $SYS_FLAGS_F $PROF_FLAG_F $FFLAGS"
LDC_FLAGS=\
"$PROF_FLAG_LC $SYS_FLAGS_LC $DEBUG_FLAG_LC"
@ -38,7 +53,7 @@
HP-UX-* )
SO=".sl"
SHLIB_F77FLAGS="+z"
@@ -4192,16 +4206,16 @@
@@ -4192,16 +4206,19 @@
fi
fi
if test -z "$DOC_DIR"; then
@ -55,6 +70,27 @@
if test -z "$DEMOS_DIR"; then
- DEMOS_DIR=$prefix/examples
+ DEMOS_DIR=$prefix/share/examples/plplot
+fi
+if test -z "$DATA_DIR"; then
+ DATA_DIR=$prefix/libdata/plplot
fi
cat >> confdefs.h <<EOF
@@ -4216,6 +4233,9 @@
#define TCL_DIR "$TCL_DIR"
EOF
+cat >> confdefs.h <<EOF
+#define DATA_DIR "$DATA_DIR"
+EOF
@@ -4449,6 +4469,7 @@
s%@INFO_DIR@%$INFO_DIR%g
s%@INCLUDE_DIR@%$INCLUDE_DIR%g
s%@DEMOS_DIR@%$DEMOS_DIR%g
+s%@DATA_DIR@%$DATA_DIR%g
s%@SHARED@%$SHARED%g
CEOF

View File

@ -1,22 +1,58 @@
--- cf/install.in.orig Tue Jun 6 20:13:09 1995
+++ cf/install.in Fri Oct 3 15:41:49 1997
@@ -27,15 +27,15 @@
install_lib:
-if test ! -d $(INCLUDE_DIR); then mkdir -p $(INCLUDE_DIR); fi
- -if test ! -d $(LIB_DIR); then mkdir -p $(LIB_DIR); fi
+ -if test ! -d $(LIB_DIR)/plplot; then mkdir -p $(LIB_DIR)/plplot; fi
--- cf/install.in.orig Wed Jun 7 03:13:09 1995
+++ cf/install.in Wed Jan 5 02:26:56 2000
@@ -31,19 +31,18 @@
-if test ! -d $(DOC_DIR); then mkdir -p $(DOC_DIR); fi
-if test ! -d $(BIN_DIR); then mkdir -p $(BIN_DIR); fi
-if test ! -d $(INFO_DIR); then mkdir -p $(INFO_DIR); fi
- -cd $(top_srcdir)/lib; cp *.fnt *.map $(LIB_DIR)
+ -cd $(top_srcdir)/lib; cp *.fnt *.map $(LIB_DIR)/plplot
-cp $(PLLIB_BASE)* $(LIB_DIR); \
- -cp $(PLLIB_BASE)* $(LIB_DIR); \
- for file in $(PLLIB_BASE)*; do $(RANLIB) $(LIB_DIR)/$$file; done
+ -if test ! -d $(DATA_DIR); then mkdir -p $(DATA_DIR); fi
+ -cd $(top_srcdir)/lib; ${BSD_INSTALL_DATA} *.fnt *.map $(DATA_DIR)
+ ${BSD_INSTALL_DATA} $(PLLIB_BASE)* $(LIB_DIR); \
+ for file in $(PLLIB_BASE)*.a; do $(RANLIB) $(LIB_DIR)/$$file; done
-cd $(top_srcdir); \
- cp README NEWS CHANGES Copyright COPYING.LIB FAQ ToDo \
+ cp README NEWS CHANGES FAQ ToDo \
mklinks $(DOC_DIR)
- mklinks $(DOC_DIR)
+ ${BSD_INSTALL_DATA} README NEWS CHANGES FAQ ToDo mklinks $(DOC_DIR)
-if test ! -f $(DOC_DIR)/README.local; then \
cp $(top_srcdir)/doc/README.local $(DOC_DIR); fi
- cp $(top_srcdir)/doc/README.local $(DOC_DIR); fi
- -cp $(top_srcdir)/doc/*.info $(INFO_DIR)
- -cd $(top_srcdir)/scripts; cp pl* $(BIN_DIR)
+ ${BSD_INSTALL_DATA} $(top_srcdir)/doc/README.local $(DOC_DIR); fi
+ -cd $(top_srcdir)/scripts; ${BSD_INSTALL_SCRIPT} pl* $(BIN_DIR)
-cd $(top_srcdir)/include; \
- cp plplotP.h plplot.h plxwd.h plevent.h plstrm.h pdf.h \
- $(INCLUDE_DIR)
+ ${BSD_INSTALL_DATA} plplotP.h plplot.h plxwd.h plevent.h plstrm.h \
+ pdf.h $(INCLUDE_DIR)
install_demos:
-if test ! -d $(DEMOS_DIR); then mkdir -p $(DEMOS_DIR); fi
@@ -56,11 +55,11 @@
-$(LN) $(DEMOS_DIR)/Makefile $(DEMOS_DIR)/c
-$(LN) $(DEMOS_DIR)/Makefile $(DEMOS_DIR)/f77
-$(LN) $(DEMOS_DIR)/Makefile $(DEMOS_DIR)/tk
- -cd $(top_srcdir)/examples/c; cp * $(DEMOS_DIR)/c
- -cd $(top_srcdir)/examples/f77; cp * $(DEMOS_DIR)/f77
- -cd $(top_srcdir)/examples/python; cp * $(DEMOS_DIR)/python
- -cd $(top_srcdir)/examples/tcl; cp * $(DEMOS_DIR)/tcl
- -cd $(top_srcdir)/examples/tk; cp * $(DEMOS_DIR)/tk
+ -cd $(top_srcdir)/examples/c; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/c
+ -cd $(top_srcdir)/examples/f77; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/f77
+ -cd $(top_srcdir)/examples/python; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/python
+ -cd $(top_srcdir)/examples/tcl; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/tcl
+ -cd $(top_srcdir)/examples/tk; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/tk
-$(LN) $(DEMOS_DIR)/tcl/x??.tcl $(DEMOS_DIR)/tk
install_utils:
@@ -72,8 +71,7 @@
$(LDC) $(LDC_FLAGS) pltek$O $(LIB_INSTALL) \
-o pltek$E; \
fi
- -strip plrender$E pltek$E
- -cp plrender$E pltek$E $(BIN_DIR)
+ ${BSD_INSTALL_PROGRAM} plrender$E pltek$E $(BIN_DIR)
# Remember, this is bogus...
# $(LDC) $(LDC_FLAGS) pltek$O $(LIB_INSTALL) \

View File

@ -0,0 +1,7 @@
--- cf/init.in.orig Mon May 15 16:54:21 1995
+++ cf/init.in Wed Jan 5 01:26:07 2000
@@ -58,3 +58,4 @@
INCLUDE_DIR = @INCLUDE_DIR@
TCL_DIR = @TCL_DIR@
DEMOS_DIR = @DEMOS_DIR@
+DATA_DIR = @DATA_DIR@

View File

@ -0,0 +1,49 @@
--- src/plctrl.c.orig Sat May 27 05:20:57 1995
+++ src/plctrl.c Wed Jan 5 01:50:02 2000
@@ -131,7 +131,7 @@
/* Anything else is assumed to be Unix */
#ifndef PLLIBDEV
-#define PLLIBDEV "/usr/local/plplot/lib"
+#define PLLIBDEV "%%PREFIX%%/libdata/plplot"
#endif
#endif
@@ -1153,7 +1153,7 @@
* PLPLOT_LIB_ENV = $(PLPLOT_LIB)
* current directory
* PLPLOT_HOME_ENV/lib = $(PLPLOT_HOME)/lib
- * LIB_DIR
+ * DATA_DIR
* PLLIBDEV
\*--------------------------------------------------------------------------*/
@@ -1195,12 +1195,12 @@
/**** search installed location ****/
-#if defined (LIB_DIR)
- plGetName(LIB_DIR, "", fn, &fs);
+#if defined (DATA_DIR)
+ plGetName(DATA_DIR, "", fn, &fs);
if ((file = fopen(fs, "rb")) != NULL)
goto done;
-#endif /* LIB_DIR */
+#endif /* DATA_DIR */
/**** search hardwired location ****/
@@ -1215,9 +1215,9 @@
pltext();
fprintf(stderr, "\nCannot open library file: %s\n", fn);
-#if defined (LIB_DIR)
- fprintf(stderr, "lib dir=\"" LIB_DIR "\"\n" ); /* what WAS set? */
-#endif /* LIB_DIR */
+#if defined (DATA_DIR)
+ fprintf(stderr, "lib dir=\"" DATA_DIR "\"\n" ); /* what WAS set? */
+#endif /* DATA_DIR */
plgra();
return NULL;

View File

@ -0,0 +1,11 @@
--- utils/pltek.c.orig Fri Sep 16 12:45:46 1994
+++ utils/pltek.c Tue Jan 4 20:49:26 2000
@@ -110,7 +110,7 @@
oldpage = ipage;
printf("Page %d/%d> ", ipage, npage);
- gets(ibuf);
+ fgets(ibuf, sizeof(ibuf), stdin);
c = ibuf[0];
/* User input a page number or a return */

View File

@ -11,3 +11,5 @@ a host of mathematical, musical, and other symbols. The fonts can be
scaled to any desired size. A variety of output devices are supported and
new devices can be easily added by writing a small number of device
dependent routines.
WWW: http://emma.la.asu.edu/plplot/

View File

@ -5,114 +5,112 @@ bin/pltek
include/plplot/pdf.h
include/plplot/plstrm.h
include/plplot/plevent.h
include/plplot/plxwd.h
include/plplot/plplot.h
include/plplot/plplotP.h
include/plplot/plstream.h
include/plplot/plxwd.h
lib/libplplotdX.a
lib/libplplotdX.so
lib/libplplotdX.so.4.99
lib/libplplotdX.so.4
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
lib/plplot/usaglobe.map
lib/plplot/usa.map
lib/plplot/globe.map
lib/plplot/cglobe.map
lib/plplot/plxtnd5.fnt
lib/plplot/plstnd5.fnt
share/doc/plplot/README
share/doc/plplot/ToDo
share/doc/plplot/FAQ
libdata/plplot/cglobe.map
libdata/plplot/globe.map
libdata/plplot/plstnd5.fnt
libdata/plplot/plxtnd5.fnt
libdata/plplot/usa.map
libdata/plplot/usaglobe.map
share/doc/plplot/CHANGES
share/doc/plplot/FAQ
share/doc/plplot/NEWS
share/doc/plplot/mklinks
share/doc/plplot/README
share/doc/plplot/README.local
share/doc/plplot/ToDo
share/doc/plplot/mklinks
share/examples/plplot/Makefile
share/examples/plplot/c/Makefile
share/examples/plplot/c/plcdemos.h
share/examples/plplot/c/x18c.c
share/examples/plplot/c/x17c.c
share/examples/plplot/c/x16c.c
share/examples/plplot/c/x15c.c
share/examples/plplot/c/x14c.c
share/examples/plplot/c/x13c.c
share/examples/plplot/c/x12c.c
share/examples/plplot/c/x11c.c
share/examples/plplot/c/x10c.c
share/examples/plplot/c/x09c.c
share/examples/plplot/c/x08c.c
share/examples/plplot/c/x07c.c
share/examples/plplot/c/x06c.c
share/examples/plplot/c/x05c.c
share/examples/plplot/c/x04c.c
share/examples/plplot/c/x03c.c
share/examples/plplot/c/x02c.c
share/examples/plplot/c/x01c.c
share/examples/plplot/c/tutor.c
share/examples/plplot/c/x01c.c
share/examples/plplot/c/x02c.c
share/examples/plplot/c/x03c.c
share/examples/plplot/c/x04c.c
share/examples/plplot/c/x05c.c
share/examples/plplot/c/x06c.c
share/examples/plplot/c/x07c.c
share/examples/plplot/c/x08c.c
share/examples/plplot/c/x09c.c
share/examples/plplot/c/x10c.c
share/examples/plplot/c/x11c.c
share/examples/plplot/c/x12c.c
share/examples/plplot/c/x13c.c
share/examples/plplot/c/x14c.c
share/examples/plplot/c/x15c.c
share/examples/plplot/c/x16c.c
share/examples/plplot/c/x17c.c
share/examples/plplot/c/x18c.c
share/examples/plplot/c/x19c.c
share/examples/plplot/f77/Makefile
share/examples/plplot/f77/x01f.f
share/examples/plplot/f77/x13f.f
share/examples/plplot/f77/x12f.f
share/examples/plplot/f77/x11f.f
share/examples/plplot/f77/x10f.f
share/examples/plplot/f77/x09f.f
share/examples/plplot/f77/x08f.f
share/examples/plplot/f77/x07f.f
share/examples/plplot/f77/x06f.f
share/examples/plplot/f77/x05f.f
share/examples/plplot/f77/x04f.f
share/examples/plplot/f77/x03f.f
share/examples/plplot/f77/x02f.f
share/examples/plplot/f77/x03f.f
share/examples/plplot/f77/x04f.f
share/examples/plplot/f77/x05f.f
share/examples/plplot/f77/x06f.f
share/examples/plplot/f77/x07f.f
share/examples/plplot/f77/x08f.f
share/examples/plplot/f77/x09f.f
share/examples/plplot/f77/x10f.f
share/examples/plplot/f77/x11f.f
share/examples/plplot/f77/x12f.f
share/examples/plplot/f77/x13f.f
share/examples/plplot/f77/x16f.f
share/examples/plplot/python/tutorpy
share/examples/plplot/python/x18py
share/examples/plplot/python/x17py
share/examples/plplot/python/x16py
share/examples/plplot/python/x15py
share/examples/plplot/python/x14py
share/examples/plplot/python/x13py
share/examples/plplot/python/x12py
share/examples/plplot/python/x11py
share/examples/plplot/python/x10py
share/examples/plplot/python/x09py
share/examples/plplot/python/x08py
share/examples/plplot/python/x07py
share/examples/plplot/python/x06py
share/examples/plplot/python/x05py
share/examples/plplot/python/x04py
share/examples/plplot/python/x03py
share/examples/plplot/python/x02py
share/examples/plplot/python/x01py
share/examples/plplot/python/x02py
share/examples/plplot/python/x03py
share/examples/plplot/python/x04py
share/examples/plplot/python/x05py
share/examples/plplot/python/x06py
share/examples/plplot/python/x07py
share/examples/plplot/python/x08py
share/examples/plplot/python/x09py
share/examples/plplot/python/x10py
share/examples/plplot/python/x11py
share/examples/plplot/python/x12py
share/examples/plplot/python/x13py
share/examples/plplot/python/x14py
share/examples/plplot/python/x15py
share/examples/plplot/python/x16py
share/examples/plplot/python/x17py
share/examples/plplot/python/x18py
share/examples/plplot/python/x19py
share/examples/plplot/tcl/plgrid.tcl
share/examples/plplot/tcl/x15.tcl
share/examples/plplot/tcl/x14.tcl
share/examples/plplot/tcl/x13.tcl
share/examples/plplot/tcl/x12.tcl
share/examples/plplot/tcl/x11.tcl
share/examples/plplot/tcl/x10.tcl
share/examples/plplot/tcl/x09.tcl
share/examples/plplot/tcl/x08.tcl
share/examples/plplot/tcl/x07.tcl
share/examples/plplot/tcl/x06.tcl
share/examples/plplot/tcl/x05.tcl
share/examples/plplot/tcl/x04.tcl
share/examples/plplot/tcl/x03.tcl
share/examples/plplot/tcl/x02.tcl
share/examples/plplot/tcl/x01.tcl
share/examples/plplot/tcl/tcldemos.tcl
share/examples/plplot/tcl/plot.tcl
share/examples/plplot/tcl/plot.dat
share/examples/plplot/tcl/plot.tcl
share/examples/plplot/tcl/tcldemos.tcl
share/examples/plplot/tcl/x01.tcl
share/examples/plplot/tcl/x02.tcl
share/examples/plplot/tcl/x03.tcl
share/examples/plplot/tcl/x04.tcl
share/examples/plplot/tcl/x05.tcl
share/examples/plplot/tcl/x06.tcl
share/examples/plplot/tcl/x07.tcl
share/examples/plplot/tcl/x08.tcl
share/examples/plplot/tcl/x09.tcl
share/examples/plplot/tcl/x10.tcl
share/examples/plplot/tcl/x11.tcl
share/examples/plplot/tcl/x12.tcl
share/examples/plplot/tcl/x13.tcl
share/examples/plplot/tcl/x14.tcl
share/examples/plplot/tcl/x15.tcl
share/examples/plplot/tcl/x16.tcl
share/examples/plplot/tk/Makefile
share/examples/plplot/tk/tk01
share/examples/plplot/tk/xtk02.c
share/examples/plplot/tk/xtk01.c
share/examples/plplot/tk/tkdemos.tcl
share/examples/plplot/tk/tk04
share/examples/plplot/tk/tk03
share/examples/plplot/tk/tk02
share/examples/plplot/tk/xtk04.c
share/examples/plplot/tk/tk03
share/examples/plplot/tk/tk04
share/examples/plplot/tk/tkdemos.tcl
share/examples/plplot/tk/x01.tcl
share/examples/plplot/tk/x02.tcl
share/examples/plplot/tk/x03.tcl
@ -129,13 +127,15 @@ share/examples/plplot/tk/x13.tcl
share/examples/plplot/tk/x14.tcl
share/examples/plplot/tk/x15.tcl
share/examples/plplot/tk/x16.tcl
share/examples/plplot/Makefile
@dirrm include/plplot
@dirrm lib/plplot
@dirrm share/doc/plplot
share/examples/plplot/tk/xtk01.c
share/examples/plplot/tk/xtk02.c
share/examples/plplot/tk/xtk04.c
@dirrm share/examples/plplot/tk
@dirrm share/examples/plplot/tcl
@dirrm share/examples/plplot/python
@dirrm share/examples/plplot/f77
@dirrm share/examples/plplot/c
@dirrm share/examples/plplot
@dirrm share/doc/plplot
@dirrm libdata/plplot
@dirrm include/plplot