libechonest is a collection of C++/Qt classes designed to make a developer's
life easy when trying to use the APIs provided by The Echo Nest. WWW: http://github.com/dschimdt/libechonest
This commit is contained in:
parent
c29f6bcc81
commit
5f4ec43f7e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=313551
@ -369,6 +369,7 @@
|
||||
SUBDIR += libcoverart
|
||||
SUBDIR += libdiscid
|
||||
SUBDIR += libdssialsacompat
|
||||
SUBDIR += libechonest
|
||||
SUBDIR += libfishsound
|
||||
SUBDIR += libgig
|
||||
SUBDIR += libgme
|
||||
|
29
audio/libechonest/Makefile
Normal file
29
audio/libechonest/Makefile
Normal file
@ -0,0 +1,29 @@
|
||||
# Created by: Nicola Vitale <nivit@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libechonest
|
||||
PORTVERSION= 2.0.1
|
||||
#PORTREVISION= 0
|
||||
CATEGORIES= audio
|
||||
|
||||
MAINTAINER= nivit@FreeBSD.org
|
||||
COMMENT= Collection of C++/Qt classes designed to use the APIs of The Echo Nest
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= qjson:${PORTSDIR}/devel/qjson
|
||||
|
||||
CMAKE_ARGS= -DCMAKE_COLOR_MAKEFILE:BOOL="OFF"
|
||||
|
||||
GH_ACCOUNT= dschmidt
|
||||
GH_PROJECT= ${PORTNAME}
|
||||
GH_TAGNAME= master
|
||||
GH_COMMIT= f9a55d1
|
||||
|
||||
USE_CMAKE= yes
|
||||
USE_GITHUB= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
USE_QT4= qmake_build moc_build network qtestlib rcc_build xml
|
||||
|
||||
.include <bsd.port.mk>
|
2
audio/libechonest/distinfo
Normal file
2
audio/libechonest/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (libechonest-2.0.1.tar.gz) = 7d7f76d38d7814f4e234f518a2e9c74ae48817a3c3b0ab3650def4c91d6819cb
|
||||
SIZE (libechonest-2.0.1.tar.gz) = 12075130
|
33
audio/libechonest/files/patch-CMakeLists.txt
Normal file
33
audio/libechonest/files/patch-CMakeLists.txt
Normal file
@ -0,0 +1,33 @@
|
||||
--- ./CMakeLists.txt.orig 2012-07-21 19:14:04.000000000 +0200
|
||||
+++ ./CMakeLists.txt 2013-02-13 00:12:06.000000000 +0100
|
||||
@@ -21,7 +21,7 @@
|
||||
set( ECHONEST_LIB_PATCH_VERSION "1" )
|
||||
set( ECHONEST_LIB_VERSION "${ECHONEST_LIB_MAJOR_VERSION}.${ECHONEST_LIB_MINOR_VERSION}.${ECHONEST_LIB_PATCH_VERSION}" )
|
||||
|
||||
-set( ECHONEST_LIB_VERSION_SONAME "${ECHONEST_LIB_MAJOR_VERSION}.${ECHONEST_LIB_MINOR_VERSION}")
|
||||
+set( ECHONEST_LIB_VERSION_SONAME "${ECHONEST_LIB_MAJOR_VERSION}")
|
||||
|
||||
if (CMAKE_COMPILER_IS_GNUCXX)
|
||||
ADD_DEFINITIONS( -Wall -Wundef -Wcast-align -Wchar-subscripts -Wpointer-arith
|
||||
@@ -32,9 +32,9 @@
|
||||
endif()
|
||||
|
||||
# disable -Werror on ARM since Qt containers cause a lot of alignment warnings
|
||||
- if ( NOT CMAKE_SYSTEM_PROCESSOR MATCHES "arm" )
|
||||
- add_definitions( -Werror )
|
||||
- endif()
|
||||
+ #if ( NOT CMAKE_SYSTEM_PROCESSOR MATCHES "arm" )
|
||||
+ # add_definitions( -Werror )
|
||||
+ #endif()
|
||||
|
||||
# to be added:
|
||||
# -Wshadow
|
||||
@@ -79,7 +79,7 @@
|
||||
${CMAKE_CURRENT_BINARY_DIR}/libechonest.pc
|
||||
@ONLY)
|
||||
INSTALL (FILES ${CMAKE_CURRENT_BINARY_DIR}/libechonest.pc
|
||||
- DESTINATION lib${LIB_SUFFIX}/pkgconfig)
|
||||
+ DESTINATION libdata/pkgconfig)
|
||||
ENDIF (NOT WIN32)
|
||||
|
||||
include(CPack)
|
4
audio/libechonest/pkg-descr
Normal file
4
audio/libechonest/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
libechonest is a collection of C++/Qt classes designed to make a developer's
|
||||
life easy when trying to use the APIs provided by The Echo Nest.
|
||||
|
||||
WWW: http://github.com/dschimdt/libechonest
|
21
audio/libechonest/pkg-plist
Normal file
21
audio/libechonest/pkg-plist
Normal file
@ -0,0 +1,21 @@
|
||||
@comment $FreeBSD$
|
||||
include/echonest/Artist.h
|
||||
include/echonest/ArtistTypes.h
|
||||
include/echonest/AudioSummary.h
|
||||
include/echonest/Catalog.h
|
||||
include/echonest/CatalogArtist.h
|
||||
include/echonest/CatalogItem.h
|
||||
include/echonest/CatalogSong.h
|
||||
include/echonest/CatalogUpdateEntry.h
|
||||
include/echonest/Config.h
|
||||
include/echonest/Playlist.h
|
||||
include/echonest/Song.h
|
||||
include/echonest/Track.h
|
||||
include/echonest/TypeInformation.h
|
||||
include/echonest/Util.h
|
||||
include/echonest/echonest_export.h
|
||||
lib/libechonest.so
|
||||
lib/libechonest.so.2
|
||||
lib/libechonest.so.2.0.1
|
||||
libdata/pkgconfig/libechonest.pc
|
||||
@dirrm include/echonest
|
Loading…
Reference in New Issue
Block a user