Update net-mgmt/py-pysmi to 0.0.7

PR:		217206
Submitted by:	maintainer
Approved by:	mat (mentor)
Differential Revision:	https://reviews.freebsd.org/D9667
This commit is contained in:
Kirill Ponomarev 2017-02-21 14:32:23 +00:00
parent 39bbc47899
commit 5f41c35e5b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=434530
4 changed files with 18 additions and 15 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pysmi
PORTVERSION= 0.0.6
PORTVERSION= 0.0.7
CATEGORIES= net-mgmt python
MASTER_SITES= CHEESESHOP \
SF/pysmi/pysmi/${PORTVERSION}
@ -31,10 +31,11 @@ post-patch:
${CP} ${FILESDIR}/tests__init__.py ${WRKSRC}/tests/__init__.py
${MV} ${WRKSRC}/tests ${WRKSRC}/${PORTNAME}
post-install:
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${BASEDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})

View File

@ -1,2 +1,3 @@
SHA256 (pysmi-0.0.6.tar.gz) = f04641fd88239ad6708aad9f8b24bc1606b225346bb6a7bb7253cc2103a7d9a0
SIZE (pysmi-0.0.6.tar.gz) = 55917
TIMESTAMP = 1487436747
SHA256 (pysmi-0.0.7.tar.gz) = 999f6db9e16f4cc2804263d825553dbdd188c4313ca5c1244eeb20a3c4a60116
SIZE (pysmi-0.0.7.tar.gz) = 56233

View File

@ -1,12 +1,13 @@
--- setup.py.orig 2015-11-07 19:23:39 UTC
--- setup.py.orig 2016-02-13 18:11:15 UTC
+++ setup.py
@@ -80,7 +80,8 @@ params.update( {
'pysmi.parser',
'pysmi.codegen',
'pysmi.borrower',
- 'pysmi.writer' ],
+ 'pysmi.writer',
+ 'pysmi.tests' ],
'scripts': [ os.path.join('scripts','mibdump.py') ]
} )
@@ -83,7 +83,9 @@ params.update({
'pysmi.parser',
'pysmi.codegen',
'pysmi.borrower',
- 'pysmi.writer'],
+ 'pysmi.writer',
+ 'pysmi.tests',
+ ],
'scripts': [os.path.join('scripts', 'mibdump.py')]
})

View File

@ -1,7 +1,7 @@
from unittest import SkipTest, TestSuite
def load_tests(loader, tests, pattern):
def load_tests(*args, **kwargs):
import suite
return suite.suite