Add port of celestia, another space travel simulator.
Requested by: Geoffrey Lassner, Bohdan 'Nexus' Horst, and Jud
This commit is contained in:
parent
6f05ed0c7c
commit
5f3a280ac4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=59394
@ -2,6 +2,7 @@
|
||||
#
|
||||
|
||||
SUBDIR += SETIsupport
|
||||
SUBDIR += celestia
|
||||
SUBDIR += dgpsip
|
||||
SUBDIR += ephem
|
||||
SUBDIR += fooseti
|
||||
|
99
astro/celestia/Makefile
Normal file
99
astro/celestia/Makefile
Normal file
@ -0,0 +1,99 @@
|
||||
# New ports collection makefile for: celestia
|
||||
# Date created: 2002-05-17
|
||||
# Whom: trevor
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= celestia
|
||||
PORTVERSION= 1.2.4
|
||||
CATEGORIES= astro
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= celestia
|
||||
|
||||
MAINTAINER= trevor@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
png.5:${PORTSDIR}/graphics/png \
|
||||
gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
PLIST= ${WRKDIR}/pkg-plist
|
||||
USE_GTK= yes
|
||||
USE_GMAKE= yes
|
||||
USE_MESA= yes
|
||||
USE_X_PREFIX= yes
|
||||
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX} \
|
||||
--includedir="${LOCALBASE}/include" \
|
||||
--libdir="${LOCALBASE}/lib"
|
||||
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${X11BASE}/include/GL -I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib -lm"
|
||||
|
||||
pre-patch:
|
||||
${PERL} -pi -e \
|
||||
"s:-O2::g; s:-Wall::g; s:-ffast-math::g; s:-fexpensive-optimizations::g" \
|
||||
${WRKSRC}/configure
|
||||
|
||||
pre-install:
|
||||
${ECHO_CMD} bin/celestia > ${PLIST}
|
||||
${FIND} ${WRKSRC}/data/ -name '*.???' | \
|
||||
${PERL} -pi -e "s:^${WRKSRC}/:share/celestia/:g" >> ${PLIST}
|
||||
${FIND} ${WRKSRC}/extras/ -name '*.ssc' | \
|
||||
${PERL} -pi -e "s:^${WRKSRC}/:share/celestia/:g" >> ${PLIST}
|
||||
${FIND} ${WRKSRC}/fonts/ -name '*.txf' | \
|
||||
${PERL} -pi -e "s:^${WRKSRC}/:share/celestia/:g" >> ${PLIST}
|
||||
.for ii in celestia.cfg demo.cel guide.cel start.cel
|
||||
${ECHO_CMD} share/celestia/${ii} >> ${PLIST}
|
||||
.endfor
|
||||
.if !defined(NOPORTDOCS)
|
||||
.for ii in AUTHORS COPYING ChangeLog INSTALL README TODO controls.txt
|
||||
${ECHO_CMD} share/doc/celestia/${ii} >> ${PLIST}
|
||||
.endfor
|
||||
${FIND} ${WRKSRC}/manual/ -name '*.???*' | \
|
||||
${PERL} -pi -e "s:^${WRKSRC}/:share/doc/celestia/:g" >> ${PLIST}
|
||||
.for ii in celestia/manual celestia
|
||||
${ECHO_CMD} @dirrm share/doc/${ii} >> ${PLIST}
|
||||
.endfor
|
||||
.endif
|
||||
${FIND} ${WRKSRC}/models/ -name '*.???' | \
|
||||
${PERL} -pi -e "s:^${WRKSRC}/:share/celestia/:g" >> ${PLIST}
|
||||
${FIND} ${WRKSRC}/shaders/ -name '*.vp' | \
|
||||
${PERL} -pi -e "s:^${WRKSRC}/:share/celestia/:g" >> ${PLIST}
|
||||
${FIND} ${WRKSRC}/textures/ -name '*.jpg' -o -name '*.png'| \
|
||||
${PERL} -pi -e "s:^${WRKSRC}/:share/celestia/:g" >> ${PLIST}
|
||||
.for ii in /data /extras /textures/lores /textures/medres /textures /models \
|
||||
/shaders /fonts /
|
||||
${ECHO_CMD} @dirrm share/celestia${ii} >> ${PLIST}
|
||||
.endfor
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/celestia/celestia ${PREFIX}/bin/
|
||||
.for ii in /data /extras /textures/lores /textures/medres /models /shaders \
|
||||
/fonts
|
||||
${MKDIR} ${DATADIR}${ii}
|
||||
.endfor
|
||||
${INSTALL_DATA} ${WRKSRC}/data/*.??? ${DATADIR}/data/
|
||||
${INSTALL_DATA} ${WRKSRC}/extras/*.ssc ${DATADIR}/extras/
|
||||
${INSTALL_DATA} ${WRKSRC}/fonts/*.txf ${DATADIR}/fonts/
|
||||
.for ii in celestia.cfg demo.cel guide.cel start.cel
|
||||
${INSTALL_DATA} ${WRKSRC}/${ii} ${DATADIR}/
|
||||
.endfor
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}/manual
|
||||
.for ii in AUTHORS COPYING ChangeLog INSTALL README TODO controls.txt
|
||||
${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}/
|
||||
.endfor
|
||||
${INSTALL_DATA} ${WRKSRC}/manual/*.???* ${DOCSDIR}/manual/
|
||||
.endif
|
||||
${INSTALL_DATA} ${WRKSRC}/models/*.??? ${DATADIR}/models/
|
||||
${INSTALL_DATA} ${WRKSRC}/shaders/*.vp ${DATADIR}/shaders/
|
||||
${INSTALL_DATA} ${WRKSRC}/textures/flare.jpg \
|
||||
${WRKSRC}/textures/logo.png ${DATADIR}/textures/
|
||||
${INSTALL_DATA} ${WRKSRC}/textures/lores/*.??? \
|
||||
${DATADIR}/textures/lores/
|
||||
${INSTALL_DATA} ${WRKSRC}/textures/medres/*.??? \
|
||||
${DATADIR}/textures/medres/
|
||||
|
||||
.include <bsd.port.mk>
|
2
astro/celestia/distinfo
Normal file
2
astro/celestia/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
$FreeBSD$
|
||||
MD5 (celestia-1.2.4.tar.gz) = 0378cd4507ebf4691c86a59c0825221b
|
13
astro/celestia/files/patch-src_celestia_glutmain.cpp
Normal file
13
astro/celestia/files/patch-src_celestia_glutmain.cpp
Normal file
@ -0,0 +1,13 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- src/celestia/glutmain.cpp.orig Tue Apr 30 10:36:11 2002
|
||||
+++ src/celestia/glutmain.cpp Fri May 17 17:47:50 2002
|
||||
@@ -509,7 +509,7 @@ int main(int argc, char* argv[])
|
||||
// Set the simulation starting time to the current system time
|
||||
time_t curtime=time(NULL);
|
||||
appCore->start((double) curtime / 86400.0 + (double) astro::Date(1970, 1, 1));
|
||||
- #ifdef MACOSX
|
||||
+ #if 1
|
||||
/* localtime in Darwin is is reentrant only
|
||||
equiv to Linux localtime_r()
|
||||
should probably port !MACOSX code to use this too, available since
|
1
astro/celestia/pkg-comment
Normal file
1
astro/celestia/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Scriptable space flight simulator for X
|
12
astro/celestia/pkg-descr
Normal file
12
astro/celestia/pkg-descr
Normal file
@ -0,0 +1,12 @@
|
||||
from the Web page:
|
||||
|
||||
Celestia is a free real-time space simulation that lets you experience our
|
||||
universe in three dimensions. Unlike most planetarium software, Celestia doesn't
|
||||
confine you to the surface of the Earth. You can travel throughout the solar
|
||||
system, to any of over 100,000 stars, or even beyond the galaxy. All travel in
|
||||
Celestia is seamless; the exponential zoom feature lets you explore space across
|
||||
a huge range of scales, from galaxy clusters down to spacecraft only a few
|
||||
meters across. A 'point-and-goto' interface makes it simple to navigate through
|
||||
the universe to the object you want to visit.
|
||||
|
||||
WWW: http://www.shatters.net/celestia/
|
Loading…
Reference in New Issue
Block a user