audio/zrythm: Update 0.5.097 -> 0.8.459
This commit is contained in:
parent
c0f7fcb6ec
commit
5f2cbe2374
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=536584
@ -2,10 +2,8 @@
|
||||
|
||||
PORTNAME= zrythm
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.5.097
|
||||
PORTREVISION= 2
|
||||
DISTVERSION= 0.8.459
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= https://gitlab.com/${PORTNAME}/${PORTNAME}/-/archive/${DISTVERSIONFULL}/
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Modern music production system, also known as DAW
|
||||
@ -13,12 +11,20 @@ COMMENT= Modern music production system, also known as DAW
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BUILD_DEPENDS= kf5-breeze-icons>0:x11-themes/kf5-breeze-icons
|
||||
LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
|
||||
BUILD_DEPENDS= fftw3>0:math/fftw3 \
|
||||
help2man:misc/help2man \
|
||||
kf5-breeze-icons>0:x11-themes/kf5-breeze-icons
|
||||
LIB_DEPENDS= libaudec.so:audio/libaudec \
|
||||
libavcodec.so:multimedia/ffmpeg \
|
||||
libcyaml.so:textproc/libcyaml \
|
||||
libgtop-2.0.so:devel/libgtop \
|
||||
libcgraph.so:graphics/graphviz \
|
||||
libguile-2.2.so:lang/guile2 \
|
||||
libjack.so:audio/jack \
|
||||
liblilv-0.so:audio/lilv \
|
||||
libpcre.so:devel/pcre \
|
||||
libportaudio.so:audio/portaudio \
|
||||
librubberband.so:audio/rubberband \
|
||||
libsamplerate.so:audio/libsamplerate \
|
||||
libserd-0.so:devel/serd \
|
||||
libsmf.so:audio/libsmf \
|
||||
@ -27,20 +33,22 @@ LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
|
||||
libasound.so:audio/alsa-lib \
|
||||
libsratom-0.so:audio/sratom \
|
||||
libsuil-0.so:audio/suil \
|
||||
libyaml.so:textproc/libyaml
|
||||
libyaml.so:textproc/libyaml \
|
||||
libzstd.so:archivers/zstd
|
||||
RUN_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas \
|
||||
kf5-breeze-icons>0:x11-themes/kf5-breeze-icons
|
||||
|
||||
USES= compiler:c11 gettext-tools gettext-runtime gnome libtool \
|
||||
meson pkgconfig python:3.5+,build shebangfix xorg
|
||||
#USE_GITLAB= yes # broken: doesn't require GL_COMMIT any more, see bug#242329
|
||||
#GL_SITE= https://git.zrythm.org
|
||||
SHEBANG_FILES= resources/gen-gtk-gresources-xml.py scripts/collect_translatables.sh scripts/meson_post_install.py
|
||||
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 libxml2 pango
|
||||
USES= compiler:c11 desktop-file-utils gettext-tools gettext-runtime gnome libtool \
|
||||
meson pkgconfig python:3.5+,build shared-mime-info shebangfix xorg
|
||||
USE_GITHUB= yes
|
||||
SHEBANG_FILES= scripts/collect_translatables.sh
|
||||
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 gtksourceview3 libxml2 pango
|
||||
USE_XORG= x11
|
||||
GLIB_SCHEMAS= org.zrythm.gschema.xml
|
||||
GLIB_SCHEMAS= org.zrythm.Zrythm.gschema.xml
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
BINARY_ALIAS= python3=${PYTHON_CMD}
|
||||
|
||||
post-patch: # https://git.zrythm.org/zrythm/zrythm/issues/299
|
||||
@${REINPLACE_CMD} 's|<malloc.h>|<stdlib.h>|' ${WRKSRC}/ext/midilib/src/*.c
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1575154997
|
||||
SHA256 (zrythm-v0.5.097.tar.gz) = a2a22b1e707a069a46817ea3cfef0a3b96458090134d8f31d7422ecb1f5467df
|
||||
SIZE (zrythm-v0.5.097.tar.gz) = 7076190
|
||||
TIMESTAMP = 1590456240
|
||||
SHA256 (zrythm-zrythm-v0.8.459_GH0.tar.gz) = 66ae0179332d7688a7eeb7f93840aca733379555ea05ed84ff76144fbdac6f4c
|
||||
SIZE (zrythm-zrythm-v0.8.459_GH0.tar.gz) = 13030321
|
||||
|
24
audio/zrythm/files/patch-meson.build
Normal file
24
audio/zrythm/files/patch-meson.build
Normal file
@ -0,0 +1,24 @@
|
||||
--- meson.build.orig 2020-05-15 17:53:28 UTC
|
||||
+++ meson.build
|
||||
@@ -625,8 +625,8 @@ zrythm_deps = [
|
||||
gtksource_dep,
|
||||
|
||||
# these are needed for gentoo
|
||||
- dependency('fftw3_threads', required: false),
|
||||
- dependency('fftw3f_threads', required: false),
|
||||
+ #dependency('fftw3_threads', required: false),
|
||||
+ #dependency('fftw3f_threads', required: false),
|
||||
|
||||
libm,
|
||||
]
|
||||
@@ -637,8 +637,8 @@ if os_windows
|
||||
# pkg-config
|
||||
zrythm_deps += dependency('fftw3f')
|
||||
else
|
||||
- zrythm_deps += cc.find_library('fftw3_threads')
|
||||
- zrythm_deps += cc.find_library('fftw3f_threads')
|
||||
+ #zrythm_deps += cc.find_library('fftw3_threads')
|
||||
+ #zrythm_deps += cc.find_library('fftw3f_threads')
|
||||
endif
|
||||
|
||||
if os_gnu
|
13
audio/zrythm/files/patch-src_main.c
Normal file
13
audio/zrythm/files/patch-src_main.c
Normal file
@ -0,0 +1,13 @@
|
||||
--- src/main.c.orig 2020-05-26 06:54:40 UTC
|
||||
+++ src/main.c
|
||||
@@ -505,8 +505,8 @@ main (int argc,
|
||||
|
||||
/* init fftw */
|
||||
g_message ("Making fftw planner thread safe...");
|
||||
- fftw_make_planner_thread_safe ();
|
||||
- fftwf_make_planner_thread_safe ();
|
||||
+ //fftw_make_planner_thread_safe ();
|
||||
+ //fftwf_make_planner_thread_safe ();
|
||||
|
||||
/* init audio decoder */
|
||||
g_message ("Initing audio decoder...");
|
@ -3,4 +3,4 @@ code from other projects such as Ardour and Jalv. It is built with the intention
|
||||
to provide GNU/Linux and BSD users a full-featured alternative to proprietary
|
||||
DAWs and offers a unique approach to workflow that other GNU/Linux DAWs lack.
|
||||
|
||||
WWW: https://www.zrythm.org/
|
||||
WWW: https://www.zrythm.org/en/
|
||||
|
@ -1,16 +1,116 @@
|
||||
bin/zrythm
|
||||
bin/zrythm_launch
|
||||
etc/bash_completion.d/zrythm
|
||||
share/applications/zrythm.desktop
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG-LICENSE.txt
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-Bold.ttf
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-Bold.woff
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-Bold.woff2
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-BoldItalic.ttf
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-BoldItalic.woff
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-BoldItalic.woff2
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-Italic.ttf
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-Italic.woff
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-Italic.woff2
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-Light.ttf
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-Light.woff
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-Light.woff2
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-LightItalic.ttf
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-LightItalic.woff
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-LightItalic.woff2
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-Regular.ttf
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-Regular.woff
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/DSEG14ClassicMini-Regular.woff2
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/README
|
||||
share/fonts/zrythm/DSEG14-Classic-MINI/README.md
|
||||
share/icons/hicolor/scalable/apps/zrythm.svg
|
||||
share/locale/ar/LC_MESSAGES/zrythm.mo
|
||||
share/locale/de/LC_MESSAGES/zrythm.mo
|
||||
share/locale/en_GB/LC_MESSAGES/zrythm.mo
|
||||
share/locale/es/LC_MESSAGES/zrythm.mo
|
||||
share/locale/fr/LC_MESSAGES/zrythm.mo
|
||||
share/locale/gl/LC_MESSAGES/zrythm.mo
|
||||
share/locale/hi/LC_MESSAGES/zrythm.mo
|
||||
share/locale/it/LC_MESSAGES/zrythm.mo
|
||||
share/locale/ja/LC_MESSAGES/zrythm.mo
|
||||
share/locale/ko/LC_MESSAGES/zrythm.mo
|
||||
share/locale/nb_NO/LC_MESSAGES/zrythm.mo
|
||||
share/locale/pt/LC_MESSAGES/zrythm.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/zrythm.mo
|
||||
share/locale/ru/LC_MESSAGES/zrythm.mo
|
||||
share/locale/zh/LC_MESSAGES/zrythm.mo
|
||||
%%DATADIR%%/Segment7Standard/OFL.txt
|
||||
%%DATADIR%%/Segment7Standard/Segment7Standard.otf
|
||||
share/man/man1/zrythm.1.gz
|
||||
share/mime/packages/org.zrythm.Zrythm-mime.xml
|
||||
%%DATADIR%%/samples/square_emphasis.wav
|
||||
%%DATADIR%%/samples/square_normal.wav
|
||||
%%DATADIR%%/sourceview-styles/monokai-extended-zrythm.xml
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/index.theme
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/README
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/add.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/automate.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/bus.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/cursor-move.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/cut-clip.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/dim.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/draw-cross.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/draw-line.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/edit-clear.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/edit-copy.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/edit-cut.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/edit-delete.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/edit-duplicate.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/edit-paste.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/edit-purge.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/edit-redo.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/edit-select-all.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/edit-tool.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/edit-undo.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/event-viewer.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/expose-to-jack.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/fade-in.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/fade-out.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/listen.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/media-playback-stop.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/media-playlist-repeat.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/media-record-on.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/media-record.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/media-seek-backward.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/media-seek-forward.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/mixer.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/mute.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/object-resize-left.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/object-resize-loop-left.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/object-resize-loop-right.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/object-resize-right.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/object-stretch-left.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/object-stretch-right.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/phase-invert.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/piano-roll.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/power.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/quantize-options.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/quick-quantize.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/remove.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/select-tool.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/snap-to-grid.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/solo.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/split.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/track-inspector.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/window-maximize.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/window-minimize.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/zoom-in.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/actions/zoom-out.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/apps/zrythm-splash-png.png
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/apps/zrythm-splash-png.xcf
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/apps/zrythm-splash.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/apps/zrythm.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/devices/metronome.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/devices/sd-card.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/devices/synth.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/emotes/face-smile.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/status/bars.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/status/jack-timebase-master.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/status/jack-transport-client.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/status/signal-audio.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/status/signal-cv.svg
|
||||
%%DATADIR%%/themes/icons/zrythm-dark/scalable/status/signal-midi.svg
|
||||
%%DATADIR%%/themes/zrythm-theme.css
|
||||
|
Loading…
Reference in New Issue
Block a user