math/xtensor: Update 0.21.7 -> 0.21.9

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2020-11-08 16:50:50 +00:00
parent d81a61abe4
commit 5f113c733c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=554476
4 changed files with 21 additions and 28 deletions

View File

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xtensor
DISTVERSION= 0.21.7
DISTVERSION= 0.21.9
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@ -25,7 +25,7 @@ GH_ACCOUNT= xtensor-stack
NO_BUILD= yes
NO_ARCH= yes
do-test:
do-test: # https://github.com/xtensor-stack/xtensor/issues/2220
@${RLN} ${STAGEDIR}${PREFIX}/include ${WRKSRC}/test/staged-include
@cd ${WRKSRC}/test && \
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} . && \

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1601832155
SHA256 (xtensor-stack-xtensor-0.21.7_GH0.tar.gz) = 03c517c1614fcef667150f436b387626d00c65bdd11c55a5da36e29cf849bfc0
SIZE (xtensor-stack-xtensor-0.21.7_GH0.tar.gz) = 1167740
TIMESTAMP = 1604851743
SHA256 (xtensor-stack-xtensor-0.21.9_GH0.tar.gz) = 845cd3cc4f4992be7425b5f44a015181415cdb35d10f73ddbc8d433e331dc740
SIZE (xtensor-stack-xtensor-0.21.9_GH0.tar.gz) = 1166004

View File

@ -1,47 +1,38 @@
--- test/CMakeLists.txt.orig 2019-10-02 11:22:22 UTC
--- test/CMakeLists.txt.orig 2020-11-08 16:48:28 UTC
+++ test/CMakeLists.txt
@@ -9,12 +9,13 @@
@@ -14,8 +14,8 @@ if (CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_SOURCE_DIR
cmake_minimum_required(VERSION 3.1)
-if (CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_SOURCE_DIR)
- project(xtensor-test)
+#if (CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_SOURCE_DIR)
+ #project(xtensor-test)
enable_testing()
- find_package(xtensor REQUIRED CONFIG)
- set(XTENSOR_INCLUDE_DIR ${xtensor_INCLUDE_DIRS})
-endif ()
+ #find_package(xtensor REQUIRED CONFIG)
+ #set(XTENSOR_INCLUDE_DIR ${xtensor_INCLUDE_DIRS})
+ include_directories(staged-include)
+#endif ()
endif ()
if(NOT CMAKE_BUILD_TYPE)
message(STATUS "Setting tests build type to Release")
@@ -241,7 +242,7 @@ foreach(filename IN LISTS COMMON_BASE XTENSOR_TESTS)
@@ -296,7 +296,7 @@ foreach(filename IN LISTS COMMON_BASE XTENSOR_TESTS)
add_dependencies(${targetname} gtest_main)
endif()
target_include_directories(${targetname} PRIVATE ${XTENSOR_INCLUDE_DIR})
- target_link_libraries(${targetname} PRIVATE xtensor ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
+ target_link_libraries(${targetname} PRIVATE ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
- target_link_libraries(${targetname} PRIVATE xtensor GTest::GTest GTest::Main ${CMAKE_THREAD_LIBS_INIT})
+ target_link_libraries(${targetname} PRIVATE GTest::GTest GTest::Main ${CMAKE_THREAD_LIBS_INIT})
add_custom_target(
x${targetname}
COMMAND ${targetname}
@@ -267,7 +268,7 @@ if(DOWNLOAD_GTEST OR GTEST_SRC_DIR)
@@ -326,7 +326,7 @@ if(DOWNLOAD_GTEST OR GTEST_SRC_DIR)
endif()
target_include_directories(test_xtensor_lib PRIVATE ${XTENSOR_INCLUDE_DIR})
-target_link_libraries(test_xtensor_lib PRIVATE xtensor ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries(test_xtensor_lib PRIVATE ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
-target_link_libraries(test_xtensor_lib PRIVATE xtensor GTest::GTest GTest::Main ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries(test_xtensor_lib PRIVATE GTest::GTest GTest::Main ${CMAKE_THREAD_LIBS_INIT})
add_custom_target(xtest COMMAND test_xtensor_lib DEPENDS test_xtensor_lib)
@@ -281,6 +282,6 @@ if(DOWNLOAD_GTEST OR GTEST_SRC_DIR)
add_test(NAME xtest COMMAND test_xtensor_lib)
@@ -341,5 +341,5 @@ if(DOWNLOAD_GTEST OR GTEST_SRC_DIR)
add_dependencies(test_xtensor_core_lib gtest_main)
endif()
-target_link_libraries(test_xtensor_core_lib PRIVATE xtensor ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries(test_xtensor_core_lib PRIVATE ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
-target_link_libraries(test_xtensor_core_lib PRIVATE xtensor GTest::GTest GTest::Main ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries(test_xtensor_core_lib PRIVATE GTest::GTest GTest::Main ${CMAKE_THREAD_LIBS_INIT})
add_custom_target(coverity COMMAND coverity_scan DEPENDS test_xtensor_core_lib)

View File

@ -9,6 +9,7 @@ include/xtensor/xaxis_slice_iterator.hpp
include/xtensor/xbroadcast.hpp
include/xtensor/xbuffer_adaptor.hpp
include/xtensor/xbuilder.hpp
include/xtensor/xchunked_array.hpp
include/xtensor/xcomplex.hpp
include/xtensor/xcontainer.hpp
include/xtensor/xcsv.hpp
@ -67,6 +68,7 @@ include/xtensor/xview.hpp
include/xtensor/xview_utils.hpp
include/xtensor/zarray.hpp
include/xtensor/zarray_impl.hpp
include/xtensor/zassign.hpp
include/xtensor/zdispatcher.hpp
include/xtensor/zdispatching_types.hpp
include/xtensor/zfunction.hpp