- The port was patching /usr/lib --> /usr/X11R6/lib and then replacing all
occurrences of X11BASE to PREFIX. It's a lot cleaner to remove all prefix changing patches and directly change /usr/lib to $PREFIX/lib with reinplace. PR: ports/114507 Submitted by: Pedro F. Giffuni <giffunip@tutopia.com>
This commit is contained in:
parent
79c86746c6
commit
5f1016d756
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=195947
@ -28,35 +28,27 @@ MAKE_ENV+= IMAKEINCLUDE=${IMAKEINCLUDE}
|
||||
ALL_TARGET= World
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
X11BASE2FIX= clients/olwm/screen.c clients/olwmslave/help_file.c \
|
||||
lib/libxview/help/help_file.c lib/libxview/misc/gettext.h \
|
||||
lib/libxview/textsw/txt_e_menu.c
|
||||
|
||||
MAN1= xview.1
|
||||
|
||||
X11BASE2FIX= clients/olwmslave/help_file.c lib/libxview/help/help_file.c \
|
||||
lib/libxview/misc/gettext.h lib/libxview/textsw/txt_e_menu.c
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's+/usr/X11R6+${PREFIX}+;' \
|
||||
pre-configure:
|
||||
@${REINPLACE_CMD} -e 's+/usr/local+${PREFIX}+;' \
|
||||
${WRKSRC}/config/XView.cf
|
||||
@${REINPLACE_CMD} -e "s,CcCmd cc,CcCmd ${CC}," \
|
||||
${WRKSRC}/config/XView.tmpl
|
||||
@${REINPLACE_CMD} -e 's+/usr/X11/+${X11BASE}/+g;' \
|
||||
${WRKSRC}/clients/olwm/screen.c
|
||||
@${REINPLACE_CMD} -e 's+/usr/lib+${PREFIX}/lib+g;' \
|
||||
${WRKSRC}/clients/olwmslave/help_file.c \
|
||||
${WRKSRC}/lib/libxview/help/help_file.c \
|
||||
${WRKSRC}/lib/libxview/misc/gettext.h \
|
||||
${WRKSRC}/lib/libxview/textsw/txt_e_menu.c
|
||||
${REINPLACE_CMD} -e 's+/usr/lib+${PREFIX}/lib+' \
|
||||
${X11BASE2FIX:C|^|${WRKSRC}/|}
|
||||
@${REINPLACE_CMD} -e "s,^MSG_UTIL,#MSG_UTIL," \
|
||||
${WRKSRC}/util/Imakefile
|
||||
|
||||
pre-configure:
|
||||
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|^#endif.*$$|#endif|;s|^#else.*$$|#else|;\
|
||||
s|^/\*\*/#*|XCOMM |'
|
||||
${REINPLACE_CMD} -e 's+/usr/X11R6+${X11BASE}+' \
|
||||
${X11BASE2FIX:C|^|${WRKSRC}/|}
|
||||
|
||||
post-install:
|
||||
.if !defined{NOPORTDOCS}
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- clients/olwm/screen.c.orig Tue Jun 29 00:11:56 1993
|
||||
+++ clients/olwm/screen.c Fri Oct 17 15:18:34 2003
|
||||
+++ clients/olwm/screen.c Sat Jun 30 19:34:43 2007
|
||||
@@ -111,6 +111,12 @@
|
||||
static XrmQuark stippledRubberBandsCQ;
|
||||
static XrmQuark stippledRubberBandsIQ;
|
||||
@ -21,21 +21,3 @@
|
||||
return True;
|
||||
/*NOTREACHED*/
|
||||
break;
|
||||
@@ -460,7 +467,7 @@
|
||||
* Construct bitmap search path as follows:
|
||||
* $OPENWINHOME/etc/workspace/patterns
|
||||
* $OPENWINHOME/include/X11/include/bitmaps
|
||||
- * /usr/X11/include/X11/include/bitmaps
|
||||
+ * /usr/X11R6/include/X11/include/bitmaps
|
||||
*
|
||||
* REMIND: this should be cleaned up so that it doesn't use a fixed-size
|
||||
* array.
|
||||
@@ -483,7 +490,7 @@
|
||||
(void)sprintf(bmPath, "%s/include/X11/bitmaps",owHome);
|
||||
bitmapSearchPath[i++] = MemNewString(bmPath);
|
||||
|
||||
- bitmapSearchPath[i++] = MemNewString("/usr/X11/include/X11/bitmaps");
|
||||
+ bitmapSearchPath[i++] = MemNewString("/usr/X11R6/include/X11/bitmaps");
|
||||
|
||||
bitmapSearchPath[i] = (char *)NULL;
|
||||
}
|
||||
|
@ -5,7 +5,7 @@
|
||||
*/
|
||||
#ifndef XVDestDir
|
||||
-#define XVDestDir /usr/X11/xview
|
||||
+#define XVDestDir /usr/X11R6
|
||||
+#define XVDestDir /usr/local
|
||||
#endif
|
||||
/*
|
||||
* Command to add object modules to the library.
|
||||
|
@ -1,14 +1,5 @@
|
||||
--- lib/libxview/textsw/txt_e_menu.c.orig Thu Oct 5 19:18:11 2006
|
||||
+++ lib/libxview/textsw/txt_e_menu.c Thu Oct 5 20:03:45 2006
|
||||
@@ -19,7 +19,7 @@
|
||||
* 3. $(HOME)/.text_extras_menu{.<locale>} (home dir),
|
||||
* 4. locale sensitive system default
|
||||
* ("$OPENWINHOME/lib/locale/<locale>/XView/.text_extras_menu")
|
||||
- * 4. fall back to SunView1 ("/usr/lib/.text_extras_menu")
|
||||
+ * 4. fall back to SunView1 ("/usr/X11R6/lib/.text_extras_menu")
|
||||
*
|
||||
* Always try locale specific name first, if not there, try without
|
||||
* locale name. In the #4, we will fall back to the "C" locale.
|
||||
--- lib/libxview/textsw/txt_e_menu.c.orig Tue Jun 29 00:17:42 1993
|
||||
+++ lib/libxview/textsw/txt_e_menu.c Sat Jun 30 20:13:46 2007
|
||||
@@ -76,6 +76,8 @@
|
||||
static int Nargs;
|
||||
static char *check_filename_locale();
|
||||
@ -18,7 +9,7 @@
|
||||
extern int EXTRASMENU_FILENAME_KEY;
|
||||
|
||||
Pkg_private char *
|
||||
@@ -138,15 +140,22 @@
|
||||
@@ -138,10 +140,17 @@
|
||||
|
||||
#ifdef notdef
|
||||
/* Gee, still?... We will try the old fashioned way */
|
||||
@ -36,9 +27,3 @@
|
||||
#endif
|
||||
}
|
||||
|
||||
/* Giving up, try with ancient way (SunView1) */
|
||||
- (void) sprintf(tmp, "/usr/lib/.%s", EXTRASMENU);
|
||||
+ (void) sprintf(tmp, "/usr/X11R6/lib/.%s", EXTRASMENU);
|
||||
result = xv_strsave(tmp);
|
||||
|
||||
found:
|
||||
|
Loading…
Reference in New Issue
Block a user