New port x11-wm/obconf-qt

PR: 229306
Approved by: swills (mentor)
Differential Revision: https://reviews.freebsd.org/D17261
This commit is contained in:
Jesper Schmitz Mouridsen 2018-10-15 14:55:00 +00:00
parent 62b5c15c80
commit 5f0eecd752
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=482157
7 changed files with 108 additions and 0 deletions

View File

@ -85,6 +85,7 @@
SUBDIR += nickleby
SUBDIR += obapps
SUBDIR += obconf
SUBDIR += obconf-qt
SUBDIR += obkey
SUBDIR += obmenu
SUBDIR += obpager

35
x11-wm/obconf-qt/Makefile Normal file
View File

@ -0,0 +1,35 @@
# Created by: Olivier Duchateau
# $FreeBSD$
PORTNAME= obconf-qt
PORTVERSION= 0.13.0
CATEGORIES= x11-wm
MASTER_SITES= LXQT/${PORTNAME}
MAINTAINER= jsm@FreeBSD.org
COMMENT= Qt port of preferences manager for Openbox
LICENSE= GPLv2
LIB_DEPENDS= libobt.so:x11-wm/openbox \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libImlib2.so:graphics/imlib2
USES= cmake:outsource compiler:c++11-lang gettext-runtime localbase qt:5 \
gnome lxqt pkgconfig tar:xz
USE_QT= buildtools_build qmake_build core gui linguisttools \
widgets x11extras
USE_LXQT= buildtools
USE_GNOME= glib20 pango librsvg2 gdkpixbuf2 libxml2 cairo
USE_XORG= ice sm x11 xft
PLIST_FILES= bin/obconf-qt \
share/applications/obconf-qt.desktop \
share/icons/hicolor/48x48/apps/obconf-qt.png
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1527328597
SHA256 (lxqt/obconf-qt-0.13.0.tar.xz) = cec24a319ad87c6c04459c66ad9d14f0ce9d6b0cad6eb5584376b72a6eb07fb9
SIZE (lxqt/obconf-qt-0.13.0.tar.xz) = 34348

View File

@ -0,0 +1,11 @@
--- src/CMakeLists.txt.orig 2018-05-21 17:40:12 UTC
+++ src/CMakeLists.txt
@@ -108,7 +108,7 @@ endif()
target_link_libraries(obconf-qt
${QTX_LIBRARIES}
- ${GLIB_LIBRARIES}
+ ${GLIB_LDFLAGS}
${OPENBOX_LIBRARIES}
)

View File

@ -0,0 +1,35 @@
--- src/archive.cpp.orig 2015-02-25 14:12:33 UTC
+++ src/archive.cpp
@@ -1,4 +1,5 @@
#include <QMessageBox>
+#include <QtGlobal>
#include <glib.h>
#include <string.h>
@@ -161,6 +162,7 @@ static gchar* install_theme_to(const gch
GError *e = NULL;
gchar *name = NULL;
+#if defined(Q_OS_LINUX)
argv = g_new(gchar*, 11);
argv[0] = g_strdup("tar");
argv[1] = g_strdup("-x");
@@ -173,6 +175,18 @@ static gchar* install_theme_to(const gch
argv[8] = g_strdup(to);
argv[9] = g_strdup("*/openbox-3/");
argv[10] = NULL;
+#else
+ argv = g_new(gchar*, 9);
+ argv[0] = g_strdup("tar");
+ argv[1] = g_strdup("-x");
+ argv[2] = g_strdup("-v");
+ argv[3] = g_strdup("-z");
+ argv[4] = g_strdup("-f");
+ argv[5] = g_strdup(file);
+ argv[6] = g_strdup("-C");
+ argv[7] = g_strdup(to);
+ argv[8] = NULL;
+#endif
if (!g_spawn_sync(NULL, argv, NULL, G_SPAWN_SEARCH_PATH, NULL, NULL,
&outtxt, &errtxt, &exitcode, &e))
QMessageBox::critical(NULL, QString(), QObject::tr("Unable to run the \"tar\" command: %1")

View File

@ -0,0 +1,18 @@
--- src/theme.cpp.orig 2018-09-20 14:07:09 UTC
+++ src/theme.cpp
@@ -156,10 +156,11 @@ void MainDialog::on_install_theme_clicke
}
void MainDialog::on_theme_archive_clicked() {
- QString filename = QFileDialog::getSaveFileName(this,
- tr("Choose an Openbox theme"),
- QString(),
- "Openbox theme archives (*.obt);;");
+ QFileDialog* dialog = new QFileDialog();
+ dialog->setFileMode(QFileDialog::Directory);
+ QString filename="";
+ if(dialog->exec())
+ filename= dialog->selectedFiles()[0];
if(!filename.isEmpty()) {
archive_create(filename.toLocal8Bit().constData());
}

View File

@ -0,0 +1,5 @@
ObConf-Qt is a Qt port of ObConf, a configuration editor for OpenBox.
It allows you to edit and choose theme, and to edit window manager preferences
such as mouse focus behaviour, font-settings and number of virtual desktops.
WWW: https://github.com/lxqt/obconf-qt