Fix build on -CURRENT.

This commit is contained in:
Christian Weisgerber 2002-07-26 12:14:00 +00:00
parent d8a1109fd0
commit 5ee4f82222
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=63597
4 changed files with 40 additions and 50 deletions

View File

@ -21,7 +21,7 @@ OOPSVERSION= 1.5.22
OOPSDATE= 20020519
USE_SUBMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOCONF= yes
CONFIGURE_ARGS?=--sbindir=${PREFIX}/sbin \
--sysconfdir=${PREFIX}/etc/oops \
--localstatedir=${OOPSVAR} \
@ -43,6 +43,9 @@ pre-fetch:
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
pre-configure:
@cd ${WRKSRC} && ${AUTOHEADER}
pre-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL

View File

@ -1,43 +0,0 @@
--- configure.orig Fri Feb 1 15:40:28 2002
+++ configure Mon Feb 4 13:02:11 2002
@@ -3021,9 +3021,9 @@
LIBDB_PATH="$pwd"
elif test -r "/usr/local/lib/libdb.a"; then
LIBDB_PATH="/usr/local"
-elif test -r "/usr/lib/libdb2.a"; then
- LIBDB_PATH="/usr"
- LIBDB_NAME=-ldb2
+elif test -r "/usr/local/lib/libdb4.a"; then
+ LIBDB_PATH="/usr/local"
+ LIBDB_NAME=-ldb4
elif test -r "/usr/lib/libdb.a"; then
LIBDB_PATH="/usr"
elif test -r "/usr/local/lib/libdb2.a"; then
@@ -3062,8 +3062,8 @@
fi
if test "$LIBDB_PATH" = "/usr/local"; then
- if test "$LIBDB_NAME" = "-ldb2"; then
- LIBDB_INCL="-I/usr/local/include/db2"
+ if test "$LIBDB_NAME" = "-ldb4"; then
+ LIBDB_INCL="-I/usr/local/include/db4 -I/usr/local/include"
else
LIBDB_INCL="-I/usr/local/include"
fi
@@ -4227,13 +4227,13 @@
esac
if test "X$MYSQL_PATH" != "X" ; then
- LIBS="-L$MYSQL_PATH/lib -lmysqlclient $LIBS"
+ LIBS="-L$MYSQL_PATH/lib/mysql -lmysqlclient $LIBS"
cat >>confdefs.h <<\EOF
#define HAVE_MYSQL 1
EOF
- CFLAGS="$CFLAGS -I$MYSQL_PATH/include"
- MYSQL_LIB="-L$MYSQL_PATH/lib -lmysqlclient"
+ CFLAGS="$CFLAGS -I$MYSQL_PATH/include/mysql"
+ MYSQL_LIB="-L$MYSQL_PATH/lib/mysql -lmysqlclient"
fi
if test "X$PGSQL_PATH" != "X" ; then

View File

@ -1,6 +1,18 @@
--- configure.in.orig Tue Nov 13 15:08:03 2001
+++ configure.in Tue Nov 13 15:08:49 2001
@@ -523,10 +523,10 @@
$FreeBSD$
--- configure.in.orig Wed Dec 19 13:18:40 2001
+++ configure.in Thu Jul 25 19:54:48 2002
@@ -49,7 +49,7 @@
AC_ARG_WITH(zlib,--with-zlib=[[PATH]] Which zlib library/object file to use,
with_zlib="$withval", with_zlib="")
-AC_CHECK_HEADERS(crypt.h getopt.h pthread.h stdlib.h string.h strings.h unistd.h sys/inttypes.h)
+AC_CHECK_HEADERS(crypt.h getopt.h pthread.h stdlib.h string.h strings.h unistd.h inttypes.h)
AC_CHECK_HEADERS(netinet/ip_fil.h, AC_DEFINE(HAVE_IPF))
AC_CHECK_HEADERS(netinet/ip6.h, AC_DEFINE(HAVE_IP6_H))
@@ -524,10 +524,10 @@
esac
if test "X$MYSQL_PATH" != "X" ; then

View File

@ -1,6 +1,9 @@
--- src/environment.h.orig Wed Dec 13 17:33:19 2000
+++ src/environment.h Wed Dec 13 17:33:40 2000
@@ -55,7 +55,7 @@
$FreeBSD$
--- src/environment.h.orig Wed Dec 12 16:49:39 2001
+++ src/environment.h Thu Jul 25 20:10:35 2002
@@ -67,7 +67,7 @@
#include <thread.h>
#endif
#include <pthread.h>
@ -8,3 +11,18 @@
+#if !defined(HAVE_PTHREAD_RWLOCK_INIT) && !defined(FREEBSD)
#include "rwlock.h"
#endif
@@ -119,11 +119,11 @@
#include <sys/stat.h>
#endif
-#if defined(HAVE_SYS_INTTYPES_H)
+#if defined(HAVE_INTTYPES_H)
#include <inttypes.h>
#endif
-#if !defined(HAVE_SYS_INTTYPES_H) && !defined(_STDINT_H)
+#if !defined(HAVE_INTTYPES_H) && !defined(_STDINT_H)
typedef unsigned int uintptr_t;
#endif