- Add patches to fix include guards (found by Clang).

- Modernise port Makefile a bit.
This commit is contained in:
Tijl Coosemans 2014-03-20 15:35:34 +00:00
parent 0ef672b091
commit 5ec77b4e26
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=348703
3 changed files with 26 additions and 5 deletions

View File

@ -3,19 +3,18 @@
PORTNAME= libcddb
PORTVERSION= 1.3.2
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= SF
MAINTAINER= multimedia@FreeBSD.org
COMMENT= A library to access data on a CDDB server
COMMENT= Library to access data on a CDDB server
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= pathfix pkgconfig iconv
USES= iconv libtool:oldver pathfix tar:bzip2
USE_LDCONFIG= yes
CONFIGURE_ARGS= --without-cdio
CPPFLAGS+= -DICONV_CONST="const" -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- include/cddb/cddb_log.h.orig 2005-03-11 22:29:29.000000000 +0100
+++ include/cddb/cddb_log.h 2014-03-20 16:00:15.000000000 +0100
@@ -19,7 +19,7 @@
Boston, MA 02111-1307, USA.
*/
-#ifndef CDDB_LOH_H
+#ifndef CDDB_LOG_H
#define CDDB_LOG_H
#ifdef __cplusplus

View File

@ -0,0 +1,11 @@
--- include/cddb/cddb_log_ni.h.orig 2005-03-11 22:29:29.000000000 +0100
+++ include/cddb/cddb_log_ni.h 2014-03-20 16:00:24.000000000 +0100
@@ -19,7 +19,7 @@
Boston, MA 02111-1307, USA.
*/
-#ifndef CDDB_LOH_NI_H
+#ifndef CDDB_LOG_NI_H
#define CDDB_LOG_NI_H
#ifdef __cplusplus