The 1.5.4 distfile has been removed. Use the 1.5.5 one, but add
patches to undo the changes between 1.5.4 and 1.5.5, because they do not work.
This commit is contained in:
parent
e3ec51fdd5
commit
5e54b3548d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41185
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= bin86
|
||||
PORTVERSION= 0.15.4
|
||||
PORTVERSION= 0.15.5
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.cix.co.uk/~mayday/
|
||||
|
||||
|
@ -1 +1 @@
|
||||
MD5 (bin86-0.15.4.tar.gz) = 8ac305eeb5cb0cb6ce90e7e30f7c11f0
|
||||
MD5 (bin86-0.15.5.tar.gz) = d714155efe0ee4efc98bf76fad44e769
|
||||
|
20
devel/bin86/files/patch-as_Makefile
Normal file
20
devel/bin86/files/patch-as_Makefile
Normal file
@ -0,0 +1,20 @@
|
||||
--- as/Makefile.orig Sat Jan 6 01:52:28 2001
|
||||
+++ as/Makefile Fri Jul 31 01:53:43 1998
|
||||
@@ -12,13 +12,13 @@
|
||||
all: as86 as86_encap
|
||||
|
||||
as86: $(OBJS)
|
||||
- $(CC) $(LDFLAGS) $(OBJS) -o $@
|
||||
+ $(CC) $(LDFLAGS) $(OBJS) -o as86
|
||||
|
||||
as86_encap: as86_encap.sh
|
||||
sed -e "s:%%LIBDIR%%:$(LIBDIR):" -e "s:%%BINDIR%%:$(BINDIR):" \
|
||||
- < $^ > tmp
|
||||
- @mv -f tmp $@
|
||||
- chmod +x $@
|
||||
+ < as86_encap.sh > tmp
|
||||
+ @mv -f tmp as86_encap
|
||||
+ chmod +x as86_encap
|
||||
|
||||
install: all
|
||||
install -d $(LIBDIR)
|
25
devel/bin86/files/patch-ld_Makefile
Normal file
25
devel/bin86/files/patch-ld_Makefile
Normal file
@ -0,0 +1,25 @@
|
||||
--- ld/Makefile.orig Sat Jan 6 02:02:20 2001
|
||||
+++ ld/Makefile Fri Jul 31 02:01:01 1998
|
||||
@@ -21,11 +21,11 @@
|
||||
all: ld86 objchop catimage objdump86
|
||||
|
||||
ld86: $(OBJS)
|
||||
- $(CC) $(LDFLAGS) $^ -o $@
|
||||
+ $(CC) $(LDFLAGS) $(OBJS) -o $@
|
||||
|
||||
install: ld86
|
||||
install -d $(LIBDIR)
|
||||
- install -m 755 $^ $(LIBDIR)
|
||||
+ install -m 755 ld86 $(LIBDIR)
|
||||
|
||||
clean realclean clobber:
|
||||
rm -f *.o ld86 ld86r objchop catimage objdump86
|
||||
@@ -39,7 +39,7 @@
|
||||
ln ../libc/include/ar.h .
|
||||
|
||||
writebin.o: writebin.c
|
||||
- $(CC) $(CFLAGS) $(DEFS) $(NATIVE) -c $<
|
||||
+ $(CC) $(CFLAGS) $(DEFS) $(NATIVE) -c writebin.c
|
||||
|
||||
writerel.o: writebin.c
|
||||
|
Loading…
Reference in New Issue
Block a user