benchmarks/scimark4c: repocopy from benchmarks/scimark2c
Release notes at <https://math.nist.gov/scimark2/whatsnew.html>.
This commit is contained in:
parent
522ac45a69
commit
5d8c4cc0f4
@ -87,6 +87,7 @@
|
||||
SUBDIR += rubygem-railsbench
|
||||
SUBDIR += scimark2
|
||||
SUBDIR += scimark2c
|
||||
SUBDIR += scimark4c
|
||||
SUBDIR += shellbench
|
||||
SUBDIR += siege
|
||||
SUBDIR += sipp
|
||||
|
22
benchmarks/scimark4c/Makefile
Normal file
22
benchmarks/scimark4c/Makefile
Normal file
@ -0,0 +1,22 @@
|
||||
# Created by: thierry@pompo.net
|
||||
|
||||
PORTNAME= scimark4c
|
||||
PORTVERSION= 4
|
||||
CATEGORIES= benchmarks
|
||||
MASTER_SITES= http://math.nist.gov/scimark2/
|
||||
DISTNAME= ${PORTNAME}
|
||||
|
||||
MAINTAINER= thierry@FreeBSD.org
|
||||
COMMENT= ANSI C version of the SciMark2 benchmark
|
||||
|
||||
LICENSE= PD
|
||||
|
||||
USES= zip
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME:C/4c/4/}
|
||||
PLIST_FILES= bin/scimark4
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/scimark4 ${STAGEDIR}${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
3
benchmarks/scimark4c/distinfo
Normal file
3
benchmarks/scimark4c/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1654017050
|
||||
SHA256 (scimark4c.zip) = 91c839bca629d01efe6c2fc298530efed330c5ff6aea7bee16fd2f452cb731b1
|
||||
SIZE (scimark4c.zip) = 17348
|
33
benchmarks/scimark4c/files/patch-Makefile
Normal file
33
benchmarks/scimark4c/files/patch-Makefile
Normal file
@ -0,0 +1,33 @@
|
||||
--- Makefile.orig 2018-06-22 16:46:28 UTC
|
||||
+++ Makefile
|
||||
@@ -6,19 +6,19 @@
|
||||
all: scimark4
|
||||
|
||||
|
||||
-CC = icc
|
||||
-CFLAGS = -O3 -fno-alias -parallel -par-num-threads=4
|
||||
+#CC = icc
|
||||
+#CFLAGS = -O3 -fno-alias -parallel -par-num-threads=4
|
||||
|
||||
|
||||
-CC = gcc
|
||||
-CC = cc
|
||||
-LDFLAGS =
|
||||
-CFLAGS = -O3 -funroll-all-loops -mtune=prescott
|
||||
-CFLAGS = -O3 -funroll-all-loops -Wall -pedantic -flto
|
||||
-CFLAGS = -O3 -funroll-all-loops -Wall -pedantic -flto
|
||||
-CFLAGS = -O3 -funroll-loops -Wall -pedantic -flto
|
||||
-CFLAGS = -O3 -funroll-all-loops -Wall -pedantic -ansi
|
||||
-CFLAGS = -O3 -funroll-loops -Wall -pedantic -ansi
|
||||
+#CC = gcc
|
||||
+#CC = cc
|
||||
+#LDFLAGS =
|
||||
+#CFLAGS = -O3 -funroll-all-loops -mtune=prescott
|
||||
+#CFLAGS = -O3 -funroll-all-loops -Wall -pedantic -flto
|
||||
+#CFLAGS = -O3 -funroll-all-loops -Wall -pedantic -flto
|
||||
+#CFLAGS = -O3 -funroll-loops -Wall -pedantic -flto
|
||||
+#CFLAGS = -O3 -funroll-all-loops -Wall -pedantic -ansi
|
||||
+#CFLAGS = -O3 -funroll-loops -Wall -pedantic -ansi
|
||||
|
||||
OBJS = FFT.o kernel.o Stopwatch.o Random.o SOR.o SparseCompRow.o \
|
||||
array.o MonteCarlo.o LU.o scimark4.o
|
11
benchmarks/scimark4c/files/patch-scimark4.c
Normal file
11
benchmarks/scimark4c/files/patch-scimark4.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- scimark4.c.orig 2018-07-29 20:02:32 UTC
|
||||
+++ scimark4.c
|
||||
@@ -106,7 +106,7 @@ int main(int argc, char *argv[])
|
||||
|
||||
|
||||
print_banner();
|
||||
- printf("Using %10.2f seconds min time per kenel.", min_time);
|
||||
+ printf("Using %10.2f seconds min time per kernel.", min_time);
|
||||
if (huge_flag)
|
||||
{
|
||||
printf(" Approx. problem size: %d (MB)", atoi(argv[2]));
|
10
benchmarks/scimark4c/pkg-descr
Normal file
10
benchmarks/scimark4c/pkg-descr
Normal file
@ -0,0 +1,10 @@
|
||||
This is an ANSI C version of the SciMark2 benchmark, translated from the
|
||||
original Java sources. The intent in making this benchmark available in
|
||||
C is mainly for performance comparisons.
|
||||
|
||||
Version 4.0 of the software has added check-sum counters to adequately test
|
||||
newer optimizing compilers.
|
||||
|
||||
Results of this benchmark can be sent to pozo@nist.gov.
|
||||
|
||||
WWW: https://math.nist.gov/scimark2/download_c.html
|
12
benchmarks/scimark4c/pkg-message
Normal file
12
benchmarks/scimark4c/pkg-message
Normal file
@ -0,0 +1,12 @@
|
||||
[
|
||||
{ type: install
|
||||
message: <<EOM
|
||||
Just run scimark4 or scimark4 -large
|
||||
|
||||
The first SciMark number reported is the composite score, followed by the an
|
||||
approximate Mflop rate for each kernel.
|
||||
|
||||
You may try to hack CC or CFLAGS in /etc/make.conf...
|
||||
EOM
|
||||
}
|
||||
]
|
Loading…
Reference in New Issue
Block a user