New port: You Sick Me - command line ICQ client with ICQ2000 and

recoding support.

YSM (You Sick Me) v7 is an ICQ console client. It was originally meant to
run in Linux, but it has been successfully tested in FreeBSD, Win32, BeOS,
and QNX. YSM is based on the last ICQ protocol version, v7/8.

WWW: http://ysmv7.sourceforge.net/

PR:		38650
Submitted by:	vampiro@rootshell.ru (MAINTAINER)
This commit is contained in:
Max Khon 2002-05-28 07:52:19 +00:00
parent 6480967e17
commit 5d81343d14
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=60173
19 changed files with 191 additions and 0 deletions

24
net-im/ysm/Makefile Normal file
View File

@ -0,0 +1,24 @@
# New ports collection makefile for: ysm
# Date created: May 28, 2002
# Whom: vampiro
#
# $FreeBSD$
#
PORTNAME= ysm
PORTVERSION= 7.2.7.1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://vampiro.rootshell.ru/pub/warez/
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ysmv7_2_7_1
EXTRACT_SUFX= .tgz
MAINTAINER= vampiro@rootshell.ru
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
MAN1= ysm.1
MANCOMPRESSED= yes
.include <bsd.port.mk>

1
net-im/ysm/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (ysmv7_2_7_1.tgz) = 75cca9a9c9b48374fdfbbc8469ef54af

View File

@ -0,0 +1,13 @@
--- Makefile.orig Thu Jan 1 06:00:00 1970
+++ Makefile Tue May 28 12:06:00 2002
@@ -0,0 +1,10 @@
+PROG= ysm
+CFLAGS+= -Wall -ansi -I/usr/local/include -DYSM_USE_ICONV
+LDADD+= -L/usr/local/lib -liconv
+PREFIX?= /usr/local
+BINDIR?= ${PREFIX}/bin
+SRCS= YSM_Main.c YSM_Network.c YSM_Prompt.c YSM_Setup.c \
+ YSM_ToolBox.c YSM_Slaves.c YSM_Help.c YSM_Win32.c
+MAN= docs/ysm.1
+MANDIR= ${PREFIX}/man/man
+.include <bsd.prog.mk>

View File

@ -0,0 +1,24 @@
--- YSM_ToolBox.c.orig Fri Apr 12 11:07:38 2002
+++ YSM_ToolBox.c Tue May 28 11:19:33 2002
@@ -45,6 +45,7 @@
#include "YSM.h"
/* International Languages Charset Convertion! */
#include "YSM_Iconv.h"
+#include <iconv.h>
static struct timeval tv;
@@ -428,9 +429,12 @@
bytes_in = strlen(buf_from) + 1;
bytes_out = maxlen - 1;
conv_d = iconv_open(charset_to, charset_from);
- bytes_res = iconv(conv_d, &inptr, &bytes_in, &outptr, &bytes_out);
+ if ( conv_d == (iconv_t)( -1)) { perror("iconv_open:"); return -1; }
+ else {
+ bytes_res = iconv(conv_d, (const char **)&inptr, &bytes_in, &outptr, &bytes_out);
iconv_close(conv_d);
return 0;
+ }
}
#endif

View File

@ -0,0 +1,13 @@
--- YSM_Network.c.orig Fri Apr 12 11:07:38 2002
+++ YSM_Network.c Tue May 28 11:18:47 2002
@@ -1547,8 +1547,8 @@
int log_len = 0;
#ifdef YSM_USE_ICONV
- if( YSM_Iconv( YSM_SETTING_CHARSET_TRANS,
- YSM_SETTING_CHARSET_LOCAL,
+ if( YSM_Iconv( YSM_SETTING_CHARSET_LOCAL,
+ YSM_SETTING_CHARSET_TRANS,
data,
&data_conv,
YSM_ICONV_MAXLEN) < 0 )

View File

@ -0,0 +1,11 @@
--- YSM_Setup.c.orig Fri Apr 12 11:07:38 2002
+++ YSM_Setup.c Tue May 28 11:21:08 2002
@@ -441,7 +441,7 @@
fprintf(YSM_CFGFD,"\n# TRANS_CHARSET is charset for transfering/receiving of messages");
fprintf(YSM_CFGFD,"\n# LOCAL_CHARSET is charset for displaying/inputting of messages");
- fprintf(YSM_CFGFD,"\n# Russian Generic are TRANS: CP1251 LOCAL: KOI8R\n");
+ fprintf(YSM_CFGFD,"\n# Russian Generic are TRANS: CP1251 LOCAL: KOI8-R\n");
fprintf(YSM_CFGFD,"\nCHARSET_TRANS>0");
fprintf(YSM_CFGFD,"\nCHARSET_LOCAL>0");
#endif

1
net-im/ysm/pkg-comment Normal file
View File

@ -0,0 +1 @@
Command line ICQ client with ICQ2000 and recoding support

7
net-im/ysm/pkg-descr Normal file
View File

@ -0,0 +1,7 @@
You Sick Me - command line ICQ client with ICQ2000 and recoding support
YSM (You Sick Me) v7 is an ICQ console client. It was originally meant to
run in Linux, but it has been successfully tested in FreeBSD, Win32, BeOS,
and QNX. YSM is based on the last ICQ protocol version, v7/8.
WWW: http://ysmv7.sourceforge.net/

1
net-im/ysm/pkg-plist Normal file
View File

@ -0,0 +1 @@
bin/ysm

View File

@ -556,6 +556,7 @@
SUBDIR += xwhois
SUBDIR += yaz
SUBDIR += ymessenger
SUBDIR += ysm
SUBDIR += ytalk
SUBDIR += zebra
SUBDIR += zebra-server

24
net/ysm/Makefile Normal file
View File

@ -0,0 +1,24 @@
# New ports collection makefile for: ysm
# Date created: May 28, 2002
# Whom: vampiro
#
# $FreeBSD$
#
PORTNAME= ysm
PORTVERSION= 7.2.7.1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://vampiro.rootshell.ru/pub/warez/
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ysmv7_2_7_1
EXTRACT_SUFX= .tgz
MAINTAINER= vampiro@rootshell.ru
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
MAN1= ysm.1
MANCOMPRESSED= yes
.include <bsd.port.mk>

1
net/ysm/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (ysmv7_2_7_1.tgz) = 75cca9a9c9b48374fdfbbc8469ef54af

View File

@ -0,0 +1,13 @@
--- Makefile.orig Thu Jan 1 06:00:00 1970
+++ Makefile Tue May 28 12:06:00 2002
@@ -0,0 +1,10 @@
+PROG= ysm
+CFLAGS+= -Wall -ansi -I/usr/local/include -DYSM_USE_ICONV
+LDADD+= -L/usr/local/lib -liconv
+PREFIX?= /usr/local
+BINDIR?= ${PREFIX}/bin
+SRCS= YSM_Main.c YSM_Network.c YSM_Prompt.c YSM_Setup.c \
+ YSM_ToolBox.c YSM_Slaves.c YSM_Help.c YSM_Win32.c
+MAN= docs/ysm.1
+MANDIR= ${PREFIX}/man/man
+.include <bsd.prog.mk>

24
net/ysm/files/patch-iconv Normal file
View File

@ -0,0 +1,24 @@
--- YSM_ToolBox.c.orig Fri Apr 12 11:07:38 2002
+++ YSM_ToolBox.c Tue May 28 11:19:33 2002
@@ -45,6 +45,7 @@
#include "YSM.h"
/* International Languages Charset Convertion! */
#include "YSM_Iconv.h"
+#include <iconv.h>
static struct timeval tv;
@@ -428,9 +429,12 @@
bytes_in = strlen(buf_from) + 1;
bytes_out = maxlen - 1;
conv_d = iconv_open(charset_to, charset_from);
- bytes_res = iconv(conv_d, &inptr, &bytes_in, &outptr, &bytes_out);
+ if ( conv_d == (iconv_t)( -1)) { perror("iconv_open:"); return -1; }
+ else {
+ bytes_res = iconv(conv_d, (const char **)&inptr, &bytes_in, &outptr, &bytes_out);
iconv_close(conv_d);
return 0;
+ }
}
#endif

View File

@ -0,0 +1,13 @@
--- YSM_Network.c.orig Fri Apr 12 11:07:38 2002
+++ YSM_Network.c Tue May 28 11:18:47 2002
@@ -1547,8 +1547,8 @@
int log_len = 0;
#ifdef YSM_USE_ICONV
- if( YSM_Iconv( YSM_SETTING_CHARSET_TRANS,
- YSM_SETTING_CHARSET_LOCAL,
+ if( YSM_Iconv( YSM_SETTING_CHARSET_LOCAL,
+ YSM_SETTING_CHARSET_TRANS,
data,
&data_conv,
YSM_ICONV_MAXLEN) < 0 )

11
net/ysm/files/patch-setup Normal file
View File

@ -0,0 +1,11 @@
--- YSM_Setup.c.orig Fri Apr 12 11:07:38 2002
+++ YSM_Setup.c Tue May 28 11:21:08 2002
@@ -441,7 +441,7 @@
fprintf(YSM_CFGFD,"\n# TRANS_CHARSET is charset for transfering/receiving of messages");
fprintf(YSM_CFGFD,"\n# LOCAL_CHARSET is charset for displaying/inputting of messages");
- fprintf(YSM_CFGFD,"\n# Russian Generic are TRANS: CP1251 LOCAL: KOI8R\n");
+ fprintf(YSM_CFGFD,"\n# Russian Generic are TRANS: CP1251 LOCAL: KOI8-R\n");
fprintf(YSM_CFGFD,"\nCHARSET_TRANS>0");
fprintf(YSM_CFGFD,"\nCHARSET_LOCAL>0");
#endif

1
net/ysm/pkg-comment Normal file
View File

@ -0,0 +1 @@
Command line ICQ client with ICQ2000 and recoding support

7
net/ysm/pkg-descr Normal file
View File

@ -0,0 +1,7 @@
You Sick Me - command line ICQ client with ICQ2000 and recoding support
YSM (You Sick Me) v7 is an ICQ console client. It was originally meant to
run in Linux, but it has been successfully tested in FreeBSD, Win32, BeOS,
and QNX. YSM is based on the last ICQ protocol version, v7/8.
WWW: http://ysmv7.sourceforge.net/

1
net/ysm/pkg-plist Normal file
View File

@ -0,0 +1 @@
bin/ysm