Import replay, it's another gtk-base mp3 player.

This commit is contained in:
Vanilla I. Shu 1998-10-28 16:01:04 +00:00
parent dc714fff8d
commit 5d74a881b0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=14237
9 changed files with 121 additions and 0 deletions

27
audio/replay/Makefile Normal file
View File

@ -0,0 +1,27 @@
# New ports collection makefile for: replay
# Version required: 0.56
# Date created: Oct 27 1998
# Whom: Vanilla Pooh Shu <vanilla@FreeBSD.ORG>
#
# $Id$
#
DISTNAME= replay-source-dgtk_0.56
PKGNAME= replay-0.56
CATEGORIES= audio
MASTER_SITES= http://replay.linuxpower.org/files/
MAINTAINER= Nakai@technologist.com
LIB_DEPENDS= gtk11.1:${PORTSDIR}/x11-toolkits/gtk11 \
esd.0:${PORTSDIR}/audio/esound
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-esd
CONFIGURE_ENV= LIBS="-L${PREFIX}/lib"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/replay ${PREFIX}/bin
.include <bsd.port.mk>

1
audio/replay/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (replay-source-dgtk_0.56.tar.gz) = ae348e0528f37527d5c0bf14dffee660

View File

@ -0,0 +1,11 @@
--- Makefile.in.orig Wed Oct 28 00:22:43 1998
+++ Makefile.in Wed Oct 28 00:23:24 1998
@@ -3,7 +3,7 @@
#DEBUG = -DDEBUG
# Make sure the path is correct!
-GTK-CONFIG = "gtk-config"
+GTK-CONFIG = "gtk11-config"
# ---- @OS_TYPE@/@ARCH_TYPE@ ----

View File

@ -0,0 +1,40 @@
--- audioIO_Linux.c.orig Sat Oct 24 22:22:41 1998
+++ audioIO_Linux.c Wed Oct 28 01:27:43 1998
@@ -26,7 +26,7 @@
/* optimal fragment size */
-#ifndef OS_FreeBSD
+#ifndef OS_BSD
int AUSIZ = 0;
#endif
@@ -44,7 +44,7 @@
void
audioOpen(int frequency, int stereo, int volume)
{
- #ifdef OS_FreeBSD
+ #ifdef OS_BSD
int temp;
#endif
int supportedMixers, play_format=AFMT_S16_LE;
@@ -83,7 +83,7 @@
if (volume != -1)
audioSetVolume(volume);
-#ifdef OS_FreeBSD
+#ifdef OS_BSD
temp = AUSIZ;
if (ioctl(audio_fd, SNDCTL_DSP_GETBLKSIZE, &temp) == -1)
#else
--- buffer.c.orig Wed Oct 28 01:26:57 1998
+++ buffer.c Wed Oct 28 01:27:05 1998
@@ -31,7 +31,7 @@
#include "audio.h"
#ifndef OS_SunOS
-#ifndef OS_FreeBSD
+#ifndef OS_BSD
extern int AUSIZ;
#endif
#endif

View File

@ -0,0 +1,11 @@
--- replay.c.orig Wed Oct 28 01:34:31 1998
+++ replay.c Wed Oct 28 01:34:46 1998
@@ -1163,7 +1163,7 @@
DPRINT("\tglobbing: ");
DPRINT(buffer2);
DPRINT("\n");
- if (glob(buffer2, GLOB_ERR, NULL, &match) == GLOB_NOMATCH) {
+ if (glob(buffer2, GLOB_ERR, NULL, &match) == GLOB_NOCHECK) {
DPRINT("\tmatched nothing\n");
return;
}

View File

@ -0,0 +1,12 @@
--- audioIO_esd.c.orig Wed Oct 28 21:38:30 1998
+++ audioIO_esd.c Wed Oct 28 21:39:01 1998
@@ -19,7 +19,9 @@
/* declare these static to effectively isolate the audio device */
+#ifndef OS_BSD
int AUSIZ=0;
+#endif
static int audio_fd;
/* audioOpen() */

1
audio/replay/pkg-comment Normal file
View File

@ -0,0 +1 @@
Another GTK-base mp3 player.

17
audio/replay/pkg-descr Normal file
View File

@ -0,0 +1,17 @@
Replay is an MP3 player with a GTK interface. It is based on amp. It
has the following features as of today:
- Cool GTK interface.
- Theme support.
- Plays layer 3 and layer 2 files.
- Playlists (load/edit/save).
- Y2K compliant. ;)
- Can save to WAV.
- Stereo/mono playing.
- Fully controllable from command line, with options and signals.
- Double click in playlist to jump to that track.
- Seeking within a track.
- Display playing time/number of files/size for whole playlist.
-Pooh
vanilla@FreeBSD.ORG

1
audio/replay/pkg-plist Normal file
View File

@ -0,0 +1 @@
bin/replay