Update to upstream release 1.9.2
Detailed maintainer log: - Update to mutt 1.9.2 - Bring ats date-conditional back as a local patch file - Due to the patch not having versioning an update can break the port if the hash of the file changes - Update greeting patch to 1.9.1 PR: 224374 Submitted by: dereks@lifeofadishwasher.com (maintainer) Differential Revision: https://reviews.freebsd.org/D13509
This commit is contained in:
parent
b611b96f0b
commit
5d30a915d6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=456559
@ -2,8 +2,8 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= mutt
|
||||
PORTVERSION= 1.9.1
|
||||
PORTREVISION?= 1
|
||||
PORTVERSION= 1.9.2
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES+= mail ipv6
|
||||
MASTER_SITES= ftp://ftp.mutt.org/pub/mutt/ \
|
||||
ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/ \
|
||||
@ -17,10 +17,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
||||
PATCH_SITES+= http://www.mutt.org.ua/download/mutt-${VVV_PATCH_VERSION}/:vvv \
|
||||
http://www2.mutt.org.ua/download/mutt-${VVV_PATCH_VERSION}/:vvv \
|
||||
https://github.com/aschrab/mutt/compare/dev-base...feature/:ats \
|
||||
http://vc.org.ua/mutt/:vc
|
||||
PATCH_DIST_STRIP= -p1
|
||||
PATCHFILES= date-conditional.diff:ats
|
||||
|
||||
MAINTAINER?= dereks@lifeofadishwasher.com
|
||||
COMMENT?= Small but powerful text based program for read/writing e-mail
|
||||
@ -204,8 +202,8 @@ DOCS_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-doc-ref
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
# un/comment as each VERSION is created for PORTVERSION
|
||||
#VVV_PATCH_VERSION= 1.8.3
|
||||
GREETING_PATCH_VERSION= 1.9.0
|
||||
VVV_PATCH_VERSION= 1.9.1
|
||||
GREETING_PATCH_VERSION= 1.9.1
|
||||
|
||||
.if !defined(VVV_PATCH_VERSION)
|
||||
VVV_PATCH_VERSION= ${PORTVERSION}
|
||||
|
@ -1,10 +1,8 @@
|
||||
TIMESTAMP = 1506285098
|
||||
SHA256 (mutt/mutt-1.9.1.tar.gz) = 749b83a96373c6e2101ebe8c4b9a651735e02c478edb750750a5146a15d91bb1
|
||||
SIZE (mutt/mutt-1.9.1.tar.gz) = 4193868
|
||||
SHA256 (mutt/date-conditional.diff) = 8936c5fe7a2a62a68f2a8d001c7a6dddf138c48186a338482b6639507ba9133e
|
||||
SIZE (mutt/date-conditional.diff) = 2023
|
||||
SHA256 (mutt/mutt-1.9.0.vc.greeting) = b4ac804c24a07c7eb8330ebfdc94cdbf6fd7a4671badfb32fb611df09c008317
|
||||
SIZE (mutt/mutt-1.9.0.vc.greeting) = 4534
|
||||
TIMESTAMP = 1513396241
|
||||
SHA256 (mutt/mutt-1.9.2.tar.gz) = a2e152a352bbf02d222d54074199d9c53821c19f700c4cb85f78fa85faed7896
|
||||
SIZE (mutt/mutt-1.9.2.tar.gz) = 4195627
|
||||
SHA256 (mutt/mutt-1.9.1.vc.greeting) = b4ac804c24a07c7eb8330ebfdc94cdbf6fd7a4671badfb32fb611df09c008317
|
||||
SIZE (mutt/mutt-1.9.1.vc.greeting) = 4534
|
||||
SHA256 (mutt/patch-1.9.1.vvv.nntp.gz) = f7098b713dfcbb2a4a6e5edaf536eb99be6d92fad073d5d3ac436b0191c7c892
|
||||
SIZE (mutt/patch-1.9.1.vvv.nntp.gz) = 60687
|
||||
SHA256 (mutt/patch-1.9.1.vvv.initials.gz) = 4673ca438fb673dfee09c6b8b8f9e8e78af06056f1b515c6030b0533dae847e5
|
||||
|
97
mail/mutt/files/patch-date-conditional
Normal file
97
mail/mutt/files/patch-date-conditional
Normal file
@ -0,0 +1,97 @@
|
||||
--- PATCHES.orig 2017-12-03 03:10:17 UTC
|
||||
+++ PATCHES
|
||||
@@ -0,0 +1 @@
|
||||
+patch-1.5.0.ats.date_conditional.1
|
||||
--- hdrline.c.orig 2017-12-03 03:10:17 UTC
|
||||
+++ hdrline.c
|
||||
@@ -428,6 +428,53 @@ hdr_format_str (char *dest,
|
||||
const char *cp;
|
||||
struct tm *tm;
|
||||
time_t T;
|
||||
+ int i = 0, invert = 0;
|
||||
+
|
||||
+ if (optional && (op == '[' || op == '(')) {
|
||||
+ char *is;
|
||||
+ T = time(NULL);
|
||||
+ T -= (op == '(') ? hdr->received : hdr->date_sent;
|
||||
+
|
||||
+ is = (char *)prefix;
|
||||
+ if( *is == '>' ) {
|
||||
+ invert = 1;
|
||||
+ ++is;
|
||||
+ }
|
||||
+
|
||||
+ while( *is && *is != '?' ) {
|
||||
+ int t = strtol (is, &is, 10);
|
||||
+ switch (*(is++)) {
|
||||
+ case '?':
|
||||
+ break;
|
||||
+ case 'y':
|
||||
+ t *= 365 * 24 * 60 * 60;
|
||||
+ break;
|
||||
+ case 'M':
|
||||
+ t *= 30 * 24 * 60 * 60;
|
||||
+ break;
|
||||
+ case 'w':
|
||||
+ t *= 7 * 24 * 60 * 60;
|
||||
+ break;
|
||||
+ case 'd':
|
||||
+ t *= 24 * 60 * 60;
|
||||
+ break;
|
||||
+ case 'h':
|
||||
+ t *= 60 * 60;
|
||||
+ break;
|
||||
+ case 'm':
|
||||
+ t *= 60;
|
||||
+ break;
|
||||
+ }
|
||||
+ i += t;
|
||||
+ }
|
||||
+
|
||||
+ if (i < 0)
|
||||
+ i *= -1;
|
||||
+
|
||||
+ if( (T > i || T < -1*i) ^ invert )
|
||||
+ optional = 0;
|
||||
+ break;
|
||||
+ }
|
||||
|
||||
p = dest;
|
||||
|
||||
--- muttlib.c.orig 2017-12-03 03:10:17 UTC
|
||||
+++ muttlib.c
|
||||
@@ -1335,7 +1335,16 @@ void mutt_FormatString (char *dest, /*
|
||||
if (*src == '?')
|
||||
{
|
||||
flags |= MUTT_FORMAT_OPTIONAL;
|
||||
- src++;
|
||||
+ ch = *(++src); /* save the character to switch on */
|
||||
+ cp = prefix;
|
||||
+ ++src;
|
||||
+ count = 0;
|
||||
+ while (count < sizeof (prefix) && *src != '?')
|
||||
+ {
|
||||
+ *cp++ = *src++;
|
||||
+ count++;
|
||||
+ }
|
||||
+ *cp = 0;
|
||||
}
|
||||
else
|
||||
{
|
||||
@@ -1351,12 +1360,12 @@ void mutt_FormatString (char *dest, /*
|
||||
count++;
|
||||
}
|
||||
*cp = 0;
|
||||
- }
|
||||
|
||||
- if (!*src)
|
||||
- break; /* bad format */
|
||||
+ if (!*src)
|
||||
+ break; /* bad format */
|
||||
|
||||
- ch = *src++; /* save the character to switch on */
|
||||
+ ch = *src++; /* save the character to switch on */
|
||||
+ }
|
||||
|
||||
if (flags & MUTT_FORMAT_OPTIONAL)
|
||||
{
|
Loading…
Reference in New Issue
Block a user