- Update MASTER_SITES and WWW: in pkg-descr.

- Regenerate patches.

PR:	244652
This commit is contained in:
Hiroki Sato 2020-03-07 03:05:37 +00:00
parent e577dfd89d
commit 5d2f6e9583
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=527917
5 changed files with 40 additions and 19 deletions

View File

@ -4,13 +4,11 @@
PORTNAME= icbirc
PORTVERSION= 2.1
CATEGORIES= irc
MASTER_SITES= http://www.benzedrine.cx/
MASTER_SITES= http://www.benzedrine.ch/
MAINTAINER= hrs@FreeBSD.org
COMMENT= Proxy IRC client and ICB server
BROKEN= unfetchable
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${FILESDIR}/COPYING
@ -19,7 +17,4 @@ MAKE_ENV= BINDIR="${PREFIX}/bin" MANDIR="${PREFIX}/man/man"
PLIST_FILES= bin/icbirc \
man/man8/icbirc.8.gz
post-patch:
${REINPLACE_CMD} -e '/^static const char rcsid/d' ${WRKSRC}/*.c
.include <bsd.port.mk>

View File

@ -1,14 +1,16 @@
--- icb.c.orig 2015-08-21 19:01:12 UTC
+++ icb.c
@@ -30,7 +30,6 @@
@@ -30,7 +30,9 @@
*
*/
-static const char rcsid[] = "$Id: icb.c,v 1.3 2015/08/21 19:01:12 dhartmei Exp $";
+#if 0
static const char rcsid[] = "$Id: icb.c,v 1.3 2015/08/21 19:01:12 dhartmei Exp $";
+#endif
#include <stdio.h>
#include <stdlib.h>
@@ -40,8 +39,8 @@ static const char rcsid[] = "$Id: icb.c,
@@ -40,8 +42,8 @@ static const char rcsid[] = "$Id: icb.c,v 1.3 2015/08/
extern int sync_write(int, const char *, int);
@ -19,7 +21,7 @@
static void icb_ico(int, const char *);
static void icb_iwl(int, const char *, const char *, long,
long, const char *, const char *);
@@ -109,7 +108,7 @@ static unsigned off;
@@ -109,7 +111,7 @@ static unsigned off;
*/
void
@ -28,7 +30,7 @@
{
while (**s && strchr(skip, **s) != NULL)
(*s)++;
@@ -164,7 +163,7 @@ icb_recv(const char *buf, unsigned len,
@@ -164,7 +166,7 @@ icb_recv(const char *buf, unsigned len, int fd, int se
}
static unsigned char
@ -37,7 +39,7 @@
{
unsigned char i = 0, j = 0, k = 0;
@@ -190,10 +189,10 @@ icb_args(const char *data, unsigned char
@@ -190,10 +192,10 @@ icb_args(const char *data, unsigned char len, char arg
}
static void
@ -50,7 +52,7 @@
unsigned char i, j;
char s[8192];
@@ -269,7 +268,7 @@ icb_cmd(const char *cmd, unsigned char l
@@ -269,7 +271,7 @@ icb_cmd(const char *cmd, unsigned char len, int fd, in
char old_nick[256], new_nick[256];
scan(&a, old_nick, sizeof(old_nick), " ", " ");
@ -59,7 +61,7 @@
return;
a += 21;
scan(&a, new_nick, sizeof(new_nick), " ", " ");
@@ -283,7 +282,7 @@ icb_cmd(const char *cmd, unsigned char l
@@ -283,7 +285,7 @@ icb_cmd(const char *cmd, unsigned char len, int fd, in
char nick[256], topic[256];
scan(&a, nick, sizeof(nick), " ", " ");
@ -68,7 +70,7 @@
return;
a += 23;
scan(&a, topic, sizeof(topic), "", "\"");
@@ -294,13 +293,13 @@ icb_cmd(const char *cmd, unsigned char l
@@ -294,13 +296,13 @@ icb_cmd(const char *cmd, unsigned char len, int fd, in
char old_mod[256], new_mod[256];
scan(&a, old_mod, sizeof(old_mod), " ", " ");
@ -84,7 +86,7 @@
snprintf(s, sizeof(s),
":%s MODE %s +o %s\r\n",
icb_hostid, irc_channel, old_mod);
@@ -312,7 +311,7 @@ icb_cmd(const char *cmd, unsigned char l
@@ -312,7 +314,7 @@ icb_cmd(const char *cmd, unsigned char len, int fd, in
char nick[256];
scan(&a, nick, sizeof(nick), " ", " ");
@ -93,7 +95,7 @@
return;
snprintf(s, sizeof(s), ":%s KICK %s %s :booted\r\n",
icb_moderator, irc_channel, nick);
@@ -523,7 +522,7 @@ icb_send_openmsg(int fd, const char *msg
@@ -523,7 +525,7 @@ icb_send_openmsg(int fd, const char *msg)
cmd[off++] = 0;
cmd[0] = off - 1;
/* cmd[0] <= MAX_MSG_SIZE */
@ -102,7 +104,7 @@
}
}
@@ -548,7 +547,7 @@ icb_send_privmsg(int fd, const char *nic
@@ -548,7 +550,7 @@ icb_send_privmsg(int fd, const char *nick, const char
cmd[off++] = 0;
cmd[0] = off - 1;
/* cmd[0] <= MAX_MSG_SIZE */

View File

@ -0,0 +1,12 @@
--- icbirc.c.orig 2016-04-25 08:17:01 UTC
+++ icbirc.c
@@ -30,7 +30,9 @@
*
*/
+#if 0
static const char rcsid[] = "$Id: icbirc.c,v 1.3 2016/04/25 08:17:01 dhartmei Exp $";
+#endif
#include <sys/types.h>
#include <sys/socket.h>

View File

@ -0,0 +1,12 @@
--- irc.c.orig 2015-08-20 17:29:16 UTC
+++ irc.c
@@ -30,7 +30,9 @@
*
*/
+#if 0
static const char rcsid[] = "$Id: irc.c,v 1.2 2015/08/20 17:29:16 dhartmei Exp $";
+#endif
#include <stdarg.h>
#include <stdio.h>

View File

@ -6,4 +6,4 @@ Commands from the IRC client are translated to ICB commands and forwarded
to the ICB server. Messages from the ICB server are translated to IRC
messages and forwarded to the IRC client.
WWW: http://www.benzedrine.cx/icbirc.html
WWW: http://www.benzedrine.ch/icbirc.html