A simple X-based text editor which is based on libXpm instead of

gtk+/qt/motif/etc.

PR:		14467
Submitted by:	Chris D. Faulhaber <jedgar@fxp.org>
This commit is contained in:
Chris Piazza 1999-11-14 02:08:28 +00:00
parent c82ac0c27d
commit 5d0e746f08
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=23075
9 changed files with 131 additions and 0 deletions

34
editors/xenon/Makefile Normal file
View File

@ -0,0 +1,34 @@
# New ports collection makefile for: xenon
# Version required: 0.6.4
# Date created: 22 October 1999
# Whom: Chris D. Faulhaber <jedgar@fxp.org>
#
# $FreeBSD$
#
DISTNAME= xenon-0.6.4
CATEGORIES= editors
MASTER_SITES= ftp://ftp.proximity.com.au/pub/xenon/
MAINTAINER= jedgar@fxp.org
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
USE_X_PREFIX= yes
USE_GMAKE= yes
MAN1= xe.1
pre-patch:
@${CP} ${WRKSRC}/makefiles/Makefile.Linux ${WRKSRC}/makefiles/Makefile.FreeBSD
do-configure:
@cd ${WRKSRC}; ${LN} -sf makefiles/Makefile.FreeBSD Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/xe ${PREFIX}/bin
@${INSTALL_MAN} ${WRKSRC}/xe.1 ${PREFIX}/man/man1
@${MKDIR} ${PREFIX}/share/examples/xe
@${INSTALL_DATA} ${WRKSRC}/xerc ${PREFIX}/share/examples/xe/sample.xerc
.include <bsd.port.mk>

1
editors/xenon/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (xenon-0.6.4.tar.gz) = 8607509ecc1c618769fcc57c7daa408f

View File

@ -0,0 +1,26 @@
--- Xe.C.orig Fri Oct 22 00:20:19 1999
+++ Xe.C Fri Oct 22 18:45:53 1999
@@ -41,9 +41,11 @@
// Home directory lookup function.
//
+#ifndef __FreeBSD__
extern "C" {
extern char* cuserid(char*);
}
+#endif
void
getHomeDir(char* pathname)
@@ -57,8 +59,10 @@
// $$$ cuserid _should_ be in unistd.h, but egcs
// complains that it isn't declared
- username = (char*)cuserid(NULL);
+#ifndef __FreeBSD__
+ username = (char*)cuserid(NULL)
if (username == 0)
+#endif
username = getlogin();
if (username)

View File

@ -0,0 +1,25 @@
--- makefiles/Makefile.FreeBSD.orig Fri Oct 22 00:20:20 1999
+++ makefiles/Makefile.FreeBSD Fri Oct 22 18:36:19 1999
@@ -6,18 +6,18 @@
include makefiles/Makefile.common
-CC = c++
+CC = $(CXX)
#CC = /usr/local/bin/c++
-OPTIMIZER = -O2
+#OPTIMIZER = -O2
#ARCH = -b i586-pc-linux-gnulibc1
ARCH =
# For making a dso, add -fPIC
-CCFLAGS = $(OPTIMIZER) -pipe -Wall -fno-exceptions
+CCFLAGS = $(CXXFLAGS)
-INCLUDES = -I$(XEINC)
+INCLUDES = -I$(XEINC) -I/usr/X11R6/include
LIBS = -L/usr/X11R6/lib -lXpm -lX11
backup:

View File

@ -0,0 +1,10 @@
--- KrPool.C.orig Fri Oct 22 00:20:19 1999
+++ KrPool.C Fri Oct 22 18:47:08 1999
@@ -3,7 +3,6 @@
#include <stdlib.h>
#include <assert.h>
#include <limits.h>
-#include <malloc.h>
#include <Kr/KrPool.h>
const uint KrPool::BUFLEN;

View File

@ -0,0 +1,11 @@
--- XeApp.C.orig Fri Oct 22 00:20:19 1999
+++ XeApp.C Fri Oct 22 18:42:42 1999
@@ -165,7 +165,7 @@
#endif
gLocalIPAddr = 0;
- if (getsockname(ConnectionNumber(gDisplay), &saddr, &len) != -1)
+ if (getsockname(ConnectionNumber(gDisplay), &saddr, (int *)&len) != -1)
if (saddr.sa_family == AF_INET)
gLocalIPAddr = ntohl(((sockaddr_in*)&saddr)->sin_addr.s_addr);

View File

@ -0,0 +1 @@
Simple X-based text editor

20
editors/xenon/pkg-descr Normal file
View File

@ -0,0 +1,20 @@
Xenon is a simple X-based text editor which is very handy for things like
editing source code, system configuration files, scripts and whatever else
is an ASCII text file.
Features include:
* Speed, simplicity and low memory use.
* Search, substring or regular expression
* Unlimited undo/redo.
* Display of line numbers, jump to line number
* Some X resource configuration: mostly command keys, some colours
* Man page!
* Some error dialogs.
* Multiple files in separate windows.
* Open multiple files from the command line
* Run Once (only one process per uid and X connection IP number)
WWW: http://www.proximity.com.au/~ben/xenon.html
- Chris D. Faulhaber
jedgar@fxp.org

3
editors/xenon/pkg-plist Normal file
View File

@ -0,0 +1,3 @@
bin/xe
share/examples/xe/sample.xerc
@dirrm share/examples/xe