Remove medusa. This port is broken and no longer used.

Approved by:	portmgr (implicit)
This commit is contained in:
Joe Marcus Clarke 2003-11-27 18:54:43 +00:00
parent 44aa399f08
commit 5cfdaafe08
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=94807
14 changed files with 0 additions and 249 deletions

View File

@ -187,7 +187,6 @@
SUBDIR += lxsplit
SUBDIR += maint
SUBDIR += manck
SUBDIR += medusa
SUBDIR += memgrep
SUBDIR += memtest
SUBDIR += metalog

View File

@ -1,32 +0,0 @@
# New ports collection makefile for: medusa
# Date created: 17th August 2000
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= medusa
PORTVERSION= 0.5.1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/medusa/0.5
DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME filesystem indexer
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gnomehier gnomevfs
USE_LIBTOOL= yes
CONFIGURE_ARGS= --enable-shared --enable-static
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
MAN1= medusa-config.1 medusa-idled.1 msearch.1
MAN5= medusa.conf.5 medusa-file-index-stoplist.5
MAN7= medusa-search-uri.7
MAN8= medusa-searchd.8
.include <bsd.port.mk>

View File

@ -1 +0,0 @@
MD5 (gnome/medusa-0.5.1.tar.bz2) = 5f0b6ca0db367eda482760c922051e62

View File

@ -1,39 +0,0 @@
--- libmedusa-internal/medusa-io-handler.c.orig Fri Oct 6 18:20:52 2000
+++ libmedusa-internal/medusa-io-handler.c Fri Nov 3 11:37:17 2000
@@ -254,2 +254,5 @@
written before returning the FILE * */
+#ifdef __FreeBSD__
+#define O_SYNC 0
+#endif
file_descriptor = open (file_name, O_RDWR | O_CREAT | O_SYNC, S_IRUSR | S_IWUSR);
--- libmedusa/medusa-index-progress.c.orig Thu Feb 22 06:58:11 2001
+++ libmedusa/medusa-index-progress.c Fri Mar 2 13:40:31 2001
@@ -56,3 +56,5 @@
#elif HAVE_STATFS
+#ifndef __FreeBSD__
# include <sys/statfs.h>
+#endif
#else
@@ -90,2 +92,5 @@
unlink (INDEX_PROGRESS_FILE_NAME);
+#ifdef __FreeBSD__
+#define O_SYNC 0
+#endif
}
--- libmedusa/medusa-unindexed-search.c.orig Wed Sep 20 14:03:58 2000
+++ libmedusa/medusa-unindexed-search.c Fri Nov 3 11:38:30 2000
@@ -1068,2 +1068,5 @@
{
+#ifdef __FreeBSD__
+#define O_SYNC 0
+#endif
return open (file_name, O_CREAT | O_WRONLY, S_IRUSR | S_IWUSR | O_SYNC);
--- libmedusa/medusa-service-private.c.orig Thu Sep 14 23:59:29 2000
+++ libmedusa/medusa-service-private.c Fri Nov 3 11:41:51 2000
@@ -32,5 +32,5 @@
#include <strings.h>
+#include <sys/types.h>
#include <sys/socket.h>
#include <sys/stat.h>
-#include <sys/types.h>
#include <sys/un.h>

View File

@ -1,14 +0,0 @@
--- libmedusa-internal/medusa-text-index-mime-module.c.orig Fri Jul 14 21:54:26 2000
+++ libmedusa-internal/medusa-text-index-mime-module.c Thu Aug 17 10:06:12 2000
@@ -32,7 +32,11 @@
#include <glib.h>
#include <ctype.h>
#include <string.h>
+#ifdef __FreeBSD__
+#include <gnuregex.h>
+#else
#include <regex.h>
+#endif
struct MedusaTextIndexMimeModule {
/* These lists should be short */

View File

@ -1,27 +0,0 @@
--- medusa-idled/medusa-idled-client.c.orig Fri Jan 12 18:23:43 2001
+++ medusa-idled/medusa-idled-client.c Mon Jan 29 13:36:20 2001
@@ -33,5 +33,5 @@
#include <string.h>
+#include <sys/types.h>
#include <sys/socket.h>
#include <sys/time.h>
-#include <sys/types.h>
#include <sys/un.h>
--- indexer/medusa-file-index-daemon.c.orig Thu Feb 22 06:58:10 2001
+++ indexer/medusa-file-index-daemon.c Fri Mar 2 13:46:16 2001
@@ -44,3 +44,8 @@
#include <sys/un.h>
+#ifdef __FreeBSD__
+#include <sys/param.h>
+#include <sys/mount.h>
+#else
#include <sys/vfs.h>
+#endif
@@ -49,3 +54,5 @@
#elif defined(HAVE_STATFS)
+#ifndef __FreeBSD__
#include <sys/statfs.h>
+#endif
#endif /* HAVE_STATVFS */

View File

@ -1,14 +0,0 @@
$FreeBSD$
--- Makefile.in.orig Tue Jan 15 19:38:13 2002
+++ Makefile.in Tue Jan 15 19:42:04 2002
@@ -125,7 +125,7 @@
NULL =
-SUBDIRS = libmedusa medusa-idled libmedusa-internal indexer msearch search-service gnome-vfs-module doc index-configuration tests
+SUBDIRS = libmedusa medusa-idled libmedusa-internal indexer msearch search-service gnome-vfs-module doc
bin_SCRIPTS = medusa-config

View File

@ -1,28 +0,0 @@
--- search-service/medusa-file-search-daemon.c.orig Wed Feb 21 01:33:37 2001
+++ search-service/medusa-file-search-daemon.c Fri Mar 2 16:11:21 2001
@@ -204,2 +204,17 @@
+#ifdef __FreeBSD__
+#include <sys/wait.h>
+
+static void
+grim_reaper(int signo)
+{
+ pid_t pid;
+ int stat;
+
+ while ((pid = waitpid(-1, &stat, WNOHANG)) > 0)
+ ;
+ return;
+}
+#endif
+
int main (int argc, char *argv[])
@@ -273,3 +288,7 @@
in the Unix Environment", page 280) */
+#ifdef __FreeBSD__
+ signal (SIGCHLD, grim_reaper);
+#else
signal (SIGCLD, SIG_IGN);
+#endif

View File

@ -1,14 +0,0 @@
$FreeBSD$
--- indexer/Makefile.in 2002/01/15 17:39:48 1.1
+++ indexer/Makefile.in 2002/01/15 17:40:37
@@ -133,7 +133,7 @@
DEFS = $(NULL)
-INCLUDES = -I$(top_srcdir) -I$(top_builddir) $(GLIB_CFLAGS) $(XML_CFLAGS) $(VFS_CFLAGS) $(NULL)
+INCLUDES = -I$(top_srcdir) -I$(top_builddir) $(GLIB_CFLAGS) $(XML_CFLAGS) $(GNOME_CFLAGS) $(VFS_CFLAGS) $(NULL)
medusa_indexd_LDADD = $(top_builddir)/libmedusa/libmedusa.la $(top_builddir)/libmedusa-internal/libmedusa-index.la $(VFS_LIBS) $(GLIB_LIBS) $(GNOME_LIBS) $(OAF_LIBS) $(XML_LIBS) $(NULL)

View File

@ -1,13 +0,0 @@
$FreeBSD$
--- libmedusa/medusa-file-info-utilities.h 2001/10/05 15:43:42 1.1
+++ libmedusa/medusa-file-info-utilities.h 2001/10/05 15:44:00
@@ -29,6 +29,7 @@
#ifndef MEDUSA_FILE_INFO_UTILITIES_H
#define MEDUSA_FILE_INFO_UTILITIES_H
+#include <sys/types.h>
#include <glib.h>
#include <time.h>

View File

@ -1,16 +0,0 @@
--- medusa-idled/medusa-idled.c.orig Fri Nov 15 02:08:09 2002
+++ medusa-idled/medusa-idled.c Fri Nov 15 02:08:21 2002
@@ -32,11 +32,11 @@
#include <signal.h>
#include <stdio.h>
#include <stdlib.h>
+#include <sys/types.h>
+#include <sys/time.h>
#include <sys/resource.h>
#include <sys/socket.h>
#include <sys/stat.h>
-#include <sys/time.h>
-#include <sys/types.h>
#include <sys/un.h>
#include <time.h>
#include <unistd.h>

View File

@ -1,14 +0,0 @@
$FreeBSD$
--- search-service/Makefile.in 2002/01/15 17:41:01 1.1
+++ search-service/Makefile.in 2002/01/15 17:41:18
@@ -133,7 +133,7 @@
noinst_HEADERS = medusa-authenticate.h medusa-file-search-parse-transmission.h $(NULL)
-INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/libmedusa-internal -I$(top_srcdir)/libmedusa $(GLIB_CFLAGS) $(VFS_CFLAGS) $(NULL)
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/libmedusa-internal -I$(top_srcdir)/libmedusa $(GLIB_CFLAGS) $(GNOME_CFLAGS) $(VFS_CFLAGS) $(NULL)
medusa_searchd_LDADD = $(top_builddir)/libmedusa/libmedusa.la $(top_builddir)/libmedusa-internal/libmedusa-index.la $(VFS_LIBS) $(GLIB_LIBS) $(GNOME_LIBS) $(OAF_LIBS) $(XML_LIBS) $(NULL)

View File

@ -1,4 +0,0 @@
Medusa is software that allows you to quickly search your system for
particular types of files, using an index.
WWW: http://www.gnome.org/

View File

@ -1,32 +0,0 @@
bin/medusa-config
bin/medusa-idled
bin/medusa-indexd
bin/medusa-searchd
bin/msearch
etc/vfs/modules/search-methods.conf
include/libmedusa/medusa-file-info-utilities.h
include/libmedusa/medusa-idled-client.h
include/libmedusa/medusa-index-progress.h
include/libmedusa/medusa-index-service-private.h
include/libmedusa/medusa-index-service.h
include/libmedusa/medusa-indexed-search.h
include/libmedusa/medusa-lock-file-paths.h
include/libmedusa/medusa-lock.h
include/libmedusa/medusa-log.h
include/libmedusa/medusa-search-service-private.h
include/libmedusa/medusa-search-service.h
include/libmedusa/medusa-service-private.h
include/libmedusa/medusa-stdio-extensions.h
include/libmedusa/medusa-string.h
include/libmedusa/medusa-system-state.h
include/libmedusa/medusa-unindexed-search.h
include/libmedusa/medusa-unsearched-locations.h
include/libmedusa/medusa-utils.h
lib/libmedusa-index.a
lib/libmedusa-index.so
lib/libmedusa-index.so.0
lib/libmedusa.a
lib/libmedusa.so
lib/libmedusa.so.0
lib/vfs/modules/libvfs-search.so
@dirrm include/libmedusa