MFH: r548374 r548375

Update to 2.0.20

Changes:	https://github.com/jasper-software/jasper/blob/master/NEWS
PR:		248912
Exp-run by:	antoine
Security:	6842ac7e-d250-11ea-b9b7-08002728f74c

Fix build with jasper 2.0.20

Approved by:	ports-secteam (joneum)
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2020-09-12 21:19:44 +00:00
parent 19894276fc
commit 5cf9456670
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q3/; revision=548423
10 changed files with 122 additions and 36 deletions

View File

@ -0,0 +1,28 @@
Obtained from: https://github.com/OSGeo/gdal/commit/e236eeaed1be45a4af457565085e3db1f2fc489f
--- frmts/jpeg2000/jpeg2000_vsil_io.cpp.orig 2020-05-04 09:21:31 UTC
+++ frmts/jpeg2000/jpeg2000_vsil_io.cpp
@@ -94,13 +94,23 @@ typedef struct {
* File stream object.
\******************************************************************************/
+// PRIjas_seqent macro is defined since Jasper 2.0.17
+
+#ifndef PRIjas_seqent
static int JPEG2000_VSIL_read(jas_stream_obj_t *obj, char *buf, int cnt)
+#else
+static int JPEG2000_VSIL_read(jas_stream_obj_t *obj, char *buf, unsigned cnt)
+#endif
{
jas_stream_VSIFL_t *fileobj = JAS_CAST(jas_stream_VSIFL_t *, obj);
return static_cast<int>(VSIFReadL(buf, 1, cnt, fileobj->fp));
}
+#ifndef PRIjas_seqent
static int JPEG2000_VSIL_write(jas_stream_obj_t *obj, char *buf, int cnt)
+#else
+static int JPEG2000_VSIL_write(jas_stream_obj_t *obj, const char *buf, unsigned int cnt)
+#endif
{
jas_stream_VSIFL_t *fileobj = JAS_CAST(jas_stream_VSIFL_t *, obj);
return static_cast<int>(VSIFWriteL(buf, 1, cnt, fileobj->fp));

View File

@ -0,0 +1,22 @@
Obtained from: https://github.com/OSGeo/gdal/commit/ab72c4893e6d14d488dfed25745d79f11bee45b9
--- frmts/jpeg2000/jpeg2000dataset.cpp.orig 2020-05-04 09:21:31 UTC
+++ frmts/jpeg2000/jpeg2000dataset.cpp
@@ -484,7 +484,7 @@ int JPEG2000Dataset::DecodeImage()
/* the JP2 boxes match the ones of the code stream */
if (nBands != 0)
{
- if (nBands != jas_image_numcmpts( psImage ))
+ if (nBands != static_cast<int>(jas_image_numcmpts( psImage )))
{
CPLError(CE_Failure, CPLE_AppDefined,
"The number of components indicated in the IHDR box (%d) mismatch "
@@ -595,7 +595,7 @@ GDALDataset *JPEG2000Dataset::Open( GDALOpenInfo * poO
{
int iFormat;
- char *pszFormatName = nullptr;
+ const char *pszFormatName = nullptr;
if (!Identify(poOpenInfo))
return nullptr;

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= jasper
PORTVERSION= 2.0.16
PORTREVISION= 1
PORTVERSION= 2.0.20
DISTVERSIONPREFIX= version-
CATEGORIES= graphics
@ -15,28 +14,24 @@ LICENSE_NAME= JasPer License Version 2.0
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
OPTIONS_DEFINE= OPENGL DOCS
OPTIONS_DEFAULT= OPENGL
OPTIONS_SUB= yes
USE_LDCONFIG= yes
USES= cmake jpeg localbase
USE_GITHUB= yes
GH_ACCOUNT= mdadams
OPENGL_CMAKE_BOOL= JAS_ENABLE_OPENGL
OPENGL_USES= gl xorg
OPENGL_USE= GL=gl,glu,glut XORG=x11,xext,xi,xmu
CMAKE_ARGS= -DJAS_ENABLE_JPEG=true \
-DJAS_ENABLE_AUTOMATIC_DEPENDENCIES=false \
-DCMAKE_SKIP_RPATH=true
CMAKE_OFF= JAS_ENABLE_AUTOMATIC_DEPENDENCIES
CMAKE_ON= JAS_ENABLE_LIBJPEG
USE_LDCONFIG= yes
DOCSDIR= ${PREFIX}/share/doc/JasPer
post-install-DOCS-off:
rm -rf ${STAGEDIR}${DOCSDIR}
USE_GITHUB= yes
GH_ACCOUNT= jasper-software
OPTIONS_DEFINE= OPENGL DOCS
OPTIONS_DEFAULT=OPENGL
OPTIONS_SUB= yes
DOCS_CMAKE_BOOL= JAS_ENABLE_DOC
OPENGL_CMAKE_BOOL= JAS_ENABLE_OPENGL
OPENGL_USE= GL=gl,glu,glut XORG=x11,xext,xi,xmu
OPENGL_USES= gl xorg
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1577441210
SHA256 (mdadams-jasper-version-2.0.16_GH0.tar.gz) = f1d8b90f231184d99968f361884e2054a1714fdbbd9944ba1ae4ebdcc9bbfdb1
SIZE (mdadams-jasper-version-2.0.16_GH0.tar.gz) = 1311944
TIMESTAMP = 1599329835
SHA256 (jasper-software-jasper-version-2.0.20_GH0.tar.gz) = d55843ce52afa9bfe90f30118329578501040f30d48a027459a68a962695e506
SIZE (jasper-software-jasper-version-2.0.20_GH0.tar.gz) = 1318727

View File

@ -1,12 +0,0 @@
--- CMakeLists.txt.orig 2019-03-12 18:04:35 UTC
+++ CMakeLists.txt
@@ -267,8 +267,8 @@ message("JAS_HAVE_LIBJPEG: ${JAS_HAVE_LIBJPEG}")
# Check for the OpenGL and GLUT libraries.
################################################################################
-find_package(OpenGL ${JAS_REQUIRED})
message("JAS_ENABLE_OPENGL: ${JAS_ENABLE_OPENGL}")
+find_package(OpenGL ${JAS_OPENGL_REQUIRED})
message("OpenGL library found: ${OPENGL_FOUND}")
if (JAS_ENABLE_OPENGL AND OPENGL_FOUND)
set(JAS_HAVE_OPENGL 0)

View File

@ -0,0 +1,11 @@
--- build/cmake/modules/JasOpenGL.cmake.orig 2020-09-05 14:52:22 UTC
+++ build/cmake/modules/JasOpenGL.cmake
@@ -4,7 +4,7 @@
if (JAS_ENABLE_OPENGL)
set(OpenGL_GL_PREFERENCE GLVND)
- find_package(OpenGL ${JAS_REQUIRED})
+ find_package(OpenGL ${JAS_OPENGL_REQUIRED})
message("OpenGL library found: ${OPENGL_FOUND}")
else()
set(OPENGL_FOUND false)

View File

@ -3,9 +3,10 @@ bin/imginfo
bin/jasper
%%OPENGL%%bin/jiv
include/jasper/jas_cm.h
include/jasper/jas_compiler.h
include/jasper/jas_config.h
include/jasper/jas_dll.h
include/jasper/jas_debug.h
include/jasper/jas_dll.h
include/jasper/jas_fix.h
include/jasper/jas_getopt.h
include/jasper/jas_icc.h

View File

@ -0,0 +1,20 @@
--- modules/imgcodecs/src/grfmt_jpeg2000.cpp.orig 2018-02-23 08:38:33 UTC
+++ modules/imgcodecs/src/grfmt_jpeg2000.cpp
@@ -337,7 +337,7 @@ bool Jpeg2KDecoder::readComponent8u( uchar *data, voi
for( y = 0; y < yend - ystart; )
{
- jas_seqent_t* pix_row = &jas_matrix_get( buffer, y / ystep, 0 );
+ jas_seqent_t* pix_row = jas_matrix_getref( buffer, y / ystep, 0 );
uchar* dst = data + (y - yoffset) * step - xoffset;
if( xstep == 1 )
@@ -401,7 +401,7 @@ bool Jpeg2KDecoder::readComponent16u( unsigned short
for( y = 0; y < yend - ystart; )
{
- jas_seqent_t* pix_row = &jas_matrix_get( buffer, y / ystep, 0 );
+ jas_seqent_t* pix_row = jas_matrix_getref( buffer, y / ystep, 0 );
ushort* dst = data + (y - yoffset) * step - xoffset;
if( xstep == 1 )

View File

@ -0,0 +1,10 @@
--- src/plugins/imageformats/jp2/qjp2handler.cpp.orig 2020-04-27 07:24:21 UTC
+++ src/plugins/imageformats/jp2/qjp2handler.cpp
@@ -44,6 +44,7 @@
#include "qvariant.h"
#include "qcolor.h"
+#include <math.h>
#include <jasper/jasper.h>
QT_BEGIN_NAMESPACE

View File

@ -0,0 +1,11 @@
--- xvjp2k.c.orig 2007-05-14 01:04:37 UTC
+++ xvjp2k.c
@@ -76,7 +76,7 @@ static const char *fbasename, /* File's base name, fo
*/
int jas_getdbglevel(void) {return 0;}
int jas_setdbglevel(int n) {return 0;}
-int jas_memdump(FILE *fp,void *data,size_t len) {return 0;}
+int jas_memdump(FILE *fp,const void *data,size_t len) {return 0;}
int jas_eprintf(const char *fmt,...) /* Handle JasPer Library message */
{