The EDGE project is a programming project to develop a DOOM style engine aimed

at the Total Conversion developer, but still able to play the original DOOM
games. This project started with the DOOM source released by id software.

Note that it currently does not support playing the original MIDI music, but
supports OGG Vorbis audio files.

For Total Conversions using Edge see:
http://www.wadsinprogress.info/

For high resolution textures see:
http://forums.yaa.dk/viewtopic.php?f=32&t=69

WWW:	http://edge.sourceforge.net/
This commit is contained in:
Alejandro Pulver 2007-12-17 17:53:59 +00:00
parent e824eca3a7
commit 5cf1286163
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=203937
11 changed files with 144 additions and 0 deletions

View File

@ -178,6 +178,7 @@
SUBDIR += dungeoncrawl
SUBDIR += easysok
SUBDIR += eboard
SUBDIR += edge
SUBDIR += editss
SUBDIR += eduke32
SUBDIR += egl

41
games/edge/Makefile Normal file
View File

@ -0,0 +1,41 @@
# New ports collection makefile for: edge
# Date created: 2007-11-30
# Whom: alepulver
#
# $FreeBSD$
#
PORTNAME= edge
PORTVERSION= 1.29
CATEGORIES= games
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${PORTNAME}-${PORTVERSION}-linux${EXTRACT_SUFX}
MAINTAINER= alepulver@FreeBSD.org
COMMENT= DOOM style engine aimed at the Total Conversion developer
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
vorbis.4:${PORTSDIR}/audio/libvorbis
USE_SCONS= yes
USE_SDL= sdl
SCONS_ARGS= release=true
post-patch:
@${REINPLACE_CMD} -e 's|%%DMDIR%%|${DMDIR}|;' ${WRKSRC}/src/e_main.cc
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gledge32 ${PREFIX}/bin/${PORTNAME}
${INSTALL_DATA} ${WRKDIR}/edge.wad ${DMDIR}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/*.txt ${DOCSDIR}
.endif
.include "${.CURDIR}/../doom-data/Makefile.include"
.include <bsd.port.mk>

6
games/edge/distinfo Normal file
View File

@ -0,0 +1,6 @@
MD5 (edge-1.29-source.tar.gz) = 81b64f079763e84f48ce62f4d28efdab
SHA256 (edge-1.29-source.tar.gz) = 9ddf455dc2706a6d0efbe22da7a2fb0871a986af85d87c3b48cd5e9239f086a1
SIZE (edge-1.29-source.tar.gz) = 5513212
MD5 (edge-1.29-linux.tar.gz) = f734d354873bddb62a058cf9d91d995e
SHA256 (edge-1.29-linux.tar.gz) = 59f5447fc0f6b8d0bb947f764035f02005f481cd08abf1e219d1555888c7b15f
SIZE (edge-1.29-linux.tar.gz) = 1918394

View File

@ -0,0 +1,17 @@
--- ./SConstruct.orig Wed Jun 6 10:07:47 2007
+++ ./SConstruct Wed Dec 5 23:19:09 2007
@@ -27,6 +27,14 @@
if build_info['cross']:
base_env.Tool('crossmingw', toolpath=['build'])
+# Respect CC, CXX, CCFLAGS, CPPPATH and LIBPATH command-line parameters.
+for key in ['CC', 'CXX']:
+ if key in ARGUMENTS:
+ base_env[key] = ARGUMENTS[key]
+for key in ['CCFLAGS', 'CPPPATH', 'LIBPATH']:
+ if key in ARGUMENTS:
+ base_env[key] = Split(ARGUMENTS[key])
+
# warnings
base_env.Append(CCFLAGS = ['-Wall'])

View File

@ -0,0 +1,14 @@
--- ./epi/endianess.h.orig Sat Oct 14 05:10:38 2006
+++ ./epi/endianess.h Wed Dec 5 23:19:09 2007
@@ -41,7 +41,11 @@
// The macros used to swap values. Try to use superfast macros on systems
// that support them, otherwise use C++ inline functions.
#ifdef LINUX
+#ifdef __FreeBSD__
+#include <sys/endian.h>
+#else
#include <endian.h>
+#endif
#ifdef __arch__swab16
#define EPI_Swap16 __arch__swab16
#endif

View File

@ -0,0 +1,10 @@
--- ./epi/filesystem_linux.cc.orig Sat Oct 14 05:10:39 2006
+++ ./epi/filesystem_linux.cc Wed Dec 5 23:19:09 2007
@@ -29,6 +29,7 @@
#include <sys/stat.h>
#include <sys/types.h>
#include <unistd.h>
+#include <limits.h> // for PATH_MAX
#define MAX_MODE_CHARS 3

View File

@ -0,0 +1,11 @@
--- ./src/e_main.cc.orig Thu Jun 21 00:04:22 2007
+++ ./src/e_main.cc Wed Dec 5 23:35:20 2007
@@ -1110,6 +1110,8 @@
if (s && epi::the_filesystem->IsDir(s))
iwad_dir.Set(s);
+ else
+ iwad_dir.Set("%%DMDIR%%");
}
// Should the IWAD directory not be set by now, then we

View File

@ -0,0 +1,14 @@
--- ./src/unx_net.cc.orig Sat Nov 25 05:25:10 2006
+++ ./src/unx_net.cc Wed Dec 5 23:19:09 2007
@@ -36,7 +36,11 @@
#define htons htons_FUCK
#include <arpa/inet.h>
+#ifdef __FreeBSD__
+#include <net/if.h>
+#else
#include <linux/netdevice.h>
+#endif
// possible: <linux/if.h>
// <linux/sockios.h>

View File

@ -0,0 +1,11 @@
--- ./src/unx_sysinc.h.orig Mon May 28 00:01:49 2007
+++ ./src/unx_sysinc.h Wed Dec 5 23:19:09 2007
@@ -23,7 +23,7 @@
#include <sys/ioctl.h>
-#ifndef MACOSX
+#ifdef __linux__
#include <linux/cdrom.h>
#endif

14
games/edge/pkg-descr Normal file
View File

@ -0,0 +1,14 @@
The EDGE project is a programming project to develop a DOOM style engine aimed
at the Total Conversion developer, but still able to play the original DOOM
games. This project started with the DOOM source released by id software.
Note that it currently does not support playing the original MIDI music, but
supports OGG Vorbis audio files.
For Total Conversions using Edge see:
http://www.wadsinprogress.info/
For high resolution textures see:
http://forums.yaa.dk/viewtopic.php?f=32&t=69
WWW: http://edge.sourceforge.net/

5
games/edge/pkg-plist Normal file
View File

@ -0,0 +1,5 @@
bin/edge
%%DMDIR%%/edge.wad
%%PORTDOCS%%%%DOCSDIR%%/Changelog-129.txt
%%PORTDOCS%%%%DOCSDIR%%/Edge-Readme.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%