Upgrade to version xwpe-1.5.9a

This commit is contained in:
David E. O'Brien 1998-05-09 18:52:44 +00:00
parent b2ce31c70a
commit 5cef148deb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=10928
7 changed files with 198 additions and 63 deletions

View File

@ -4,21 +4,18 @@
# Date created: Fri Jan 24, 1997
# Whom: David O'Brien (obrien@FreeBSD.org)
#
# $Id: Makefile,v 1.3 1997/04/22 10:50:10 obrien Exp $
# $Id: Makefile,v 1.4 1998/02/21 05:14:09 steve Exp $
#
DISTNAME= xwpe-1.4.2
DISTNAME= xwpe-1.5.9a
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
ftp://ftp.uni-hannover.de/pub/mirror/linux-distrib/apps/editors/X/
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://www.rpi.edu/~payned/xwpe/ \
ftp://identical.stu.rpi.edu/pub/linux/xwpe/
MASTER_SITE_SUBDIR= apps/editors/X
EXTRACT_SUFX= .tgz
PATCH_SITES= http://www.rpi.edu/~payned/xwpe/
PATCHFILES= xwpe-cosmetic.patch xwpe-grep.patch \
xwpe-naming.patch xwpe-xchanges.patch
MAINTAINER= obrien@NUXI.com
MAINTAINER= obrien@FreeBSD.org
# LD_LIBRARY_PATH is to deal with a braindead libX11.a search in configure
# (once again author assumes too many Linux'isms)
@ -28,9 +25,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= LD_LIBRARY_PATH="${X11BASE}/lib"
USE_GMAKE= yes
ALL_TARGET=
.if defined(GERMAN_LANG)
INSTALL_TARGET= install_german
.endif
MAN1= xwpe.1
post-install:
@ -38,13 +32,5 @@ post-install:
@(cd ${PREFIX}/man/man1 ; \
for mp in xwe.1 wpe.1 we.1 ; \
do ${RM} -f $$mp ; ln -sf xwpe.1.gz $$mp.gz ; done )
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/xwpe
.if defined(GERMAN_LANG)
${INSTALL_DATA} ${WRKSRC}/xwpe_gr.doc ${PREFIX}/share/doc/xwpe/xwpe.doc
.else
${INSTALL_DATA} ${WRKSRC}/xwpe_eng.doc ${PREFIX}/share/doc/xwpe/xwpe.doc
.endif
.endif
.include <bsd.port.mk>

View File

@ -1,5 +1 @@
MD5 (xwpe-1.4.2.tgz) = 16b2873c2b0739e07702825df51d7977
MD5 (xwpe-cosmetic.patch) = b1052642dbb53a14aede6f196f27ba78
MD5 (xwpe-grep.patch) = 675bf95ce224c5ffc0581108d57ed397
MD5 (xwpe-naming.patch) = 5f00d260d437c747d0502fc3adc983c2
MD5 (xwpe-xchanges.patch) = dea57465cc294ce96abfd80bfdf54756
MD5 (xwpe-1.5.9a.tgz) = 1607a758ed9c45fd9725f233e263c56d

View File

@ -1,27 +1,28 @@
--- Makefile.in.orig Fri Apr 7 05:23:04 1995
+++ Makefile.in Tue Jan 28 20:59:36 1997
@@ -8,9 +8,12 @@
--- Makefile.in.orig Wed May 6 11:03:13 1998
+++ Makefile.in Fri May 8 10:10:38 1998
@@ -1,6 +1,6 @@
#C-Compiler (gcc if exist):
CC= @CC@
-CFLAGS= @CFLAGS@ @X_CFLAGS@
+CFLAGS= @CFLAGS@ -DLIBRARY_DIR=\"$(XWPELIBDIR)\" -DINFO_DIR=\"$(INFODIR)\" -DX_INC=\"$(X_INC)\"@X_CFLAGS@
#CFLAGS= @CFLAGS@ @EXTRA_CFLAGS@ @X_CFLAGS@
#Source Directory:
@@ -9,13 +9,16 @@
#Destination Directory
prefix=/usr/local
prefix=@prefix@
DESTDIR= $(prefix)/bin
-LIBDIR= $(prefix)/lib
-WPELIBDIR= $(LIBDIR)/wpe
+LIBSUFX= share
+LIBDIR= $(prefix)/$(LIBSUFX)
+WPELIBSUFX= $(LIBSUFX)/wpe
+WPELIBDIR= $(prefix)/$(WPELIBSUFX)
+LIBDIR= $(prefix)/share
XWPELIBDIR= $(LIBDIR)/xwpe
MANDIR= $(prefix)/man
+INFO_FILE= $(prefix)/info
+INFODIR= $(prefix)/info
LIBS=@LIBS@
LIBS=@X_LIBS@ @X_PRE_LIBS@ @LIBS@ @X_EXTRA_LIBS@
DEFS=@DEFS@
@@ -104,7 +107,8 @@
ELIBFLAGS= $(LSYSV) $(LXWINDOW) $(TLIB) $(LPOSIX) $(XWINLIB) $(LNET) $(EXTLIBS)
-ACFLAGS= $(CFLAGS) $(DEFS) $(ECFLAGS) -D"DESTDIR=\"$(DESTDIR)\""
+ACFLAGS= $(CFLAGS) $(DEFS) $(ECFLAGS) -D"DESTDIR=\"$(DESTDIR)\"" \
+ -D"WPE_LIB_DIR=\"$(WPELIBSUFX)\"" -D"INFO_FILE=\"$(prefix)/info\""
LIBFLAGS= $(LIBS) $(ELIBFLAGS)
INSTALL= cp
+
+X_INC= @X_INC@
# In case configure fails a description of many of the compilation options
# are provided below so that administrators can determine the proper flags.

View File

@ -1,24 +1,29 @@
--- we_prog.c.orig Fri Apr 7 05:32:42 1995
+++ we_prog.c Mon Jan 27 04:16:00 1997
@@ -22,6 +22,9 @@
--- we_prog.c.orig Wed May 6 11:03:14 1998
+++ we_prog.c Fri May 8 10:09:49 1998
@@ -15,6 +15,9 @@
#include <sys/stat.h>
#include <sys/wait.h>
#include <signal.h>
+#if (defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__bsdi__))
+#if (defined(__unix__) || defined(unix)) && !defined(USG)
+#include <sys/param.h>
+#endif
#define NSTR ""
@@ -1120,7 +1123,11 @@
e_prog.project = e_make_string(e_prog.project, "project.prj");
e_prog.exedir = e_make_string(e_prog.exedir, ".");
e_prog.sys_include = e_make_string(e_prog.sys_include,
+#if (defined(BSD) && (BSD >= 199306) && defined(__i386__))
+ "/usr/include:/usr/X11R6/include:/usr/local/include");
int e_run_sh(FENSTER *f);
int e_make_library(char *library, char *ofile, FENSTER *f);
@@ -944,7 +947,15 @@
e_prog.exedir = WpeStringMake(".");
if (e_prog.sys_include) FREE(e_prog.sys_include);
e_prog.sys_include = WpeStringMake(
- "/usr/include:/usr/5include:/usr/include/X11");
+#if (defined(BSD) && (BSD >= 199306)) || (defined(sun) && defined(__svr4__))
+ "/usr/include:/usr/local/include"
+#else
"/usr/include:/usr/5include:/usr/include/X11");
+ "/usr/include:/usr/5include"
+#endif
+#if !defined(NO_XWINDOWS)
+ ":"X_INC
+#endif
+ );
if(e_prog.comp == NULL)
e_prog.comp = MALLOC(e_prog.num * sizeof(struct e_s_prog *));
else

119
devel/xwpe/files/patch-08 Normal file
View File

@ -0,0 +1,119 @@
--- configure.orig Wed May 6 11:03:15 1998
+++ configure Fri May 8 10:28:36 1998
@@ -1374,63 +1374,63 @@
set dummy lpr; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
echo "configure:1377: checking for $ac_word" >&5
-if eval "test \"`echo '$''{'ac_cv_prog_PRINTER'+set}'`\" = set"; then
+if eval "test \"`echo '$''{'ac_cv_prog_PNTR'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
- if test -n "$PRINTER"; then
- ac_cv_prog_PRINTER="$PRINTER" # Let the user override the test.
+ if test -n "$PNTR"; then
+ ac_cv_prog_PNTR="$PNTR" # Let the user override the test.
else
IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:"
for ac_dir in $PATH; do
test -z "$ac_dir" && ac_dir=.
if test -f $ac_dir/$ac_word; then
- ac_cv_prog_PRINTER="lpr"
+ ac_cv_prog_PNTR="lpr"
break
fi
done
IFS="$ac_save_ifs"
fi
fi
-PRINTER="$ac_cv_prog_PRINTER"
-if test -n "$PRINTER"; then
- echo "$ac_t""$PRINTER" 1>&6
+PNTR="$ac_cv_prog_PNTR"
+if test -n "$PNTR"; then
+ echo "$ac_t""$PNTR" 1>&6
else
echo "$ac_t""no" 1>&6
fi
-if test -z "${PRINTER}"; then
+if test -z "${PNTR}"; then
# Extract the first word of "lp", so it can be a program name with args.
set dummy lp; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
echo "configure:1406: checking for $ac_word" >&5
-if eval "test \"`echo '$''{'ac_cv_prog_PRINTER'+set}'`\" = set"; then
+if eval "test \"`echo '$''{'ac_cv_prog_PNTR'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
- if test -n "$PRINTER"; then
- ac_cv_prog_PRINTER="$PRINTER" # Let the user override the test.
+ if test -n "$PNTR"; then
+ ac_cv_prog_PNTR="$PNTR" # Let the user override the test.
else
IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:"
for ac_dir in $PATH; do
test -z "$ac_dir" && ac_dir=.
if test -f $ac_dir/$ac_word; then
- ac_cv_prog_PRINTER="lp"
+ ac_cv_prog_PNTR="lp"
break
fi
done
IFS="$ac_save_ifs"
fi
fi
-PRINTER="$ac_cv_prog_PRINTER"
-if test -n "$PRINTER"; then
- echo "$ac_t""$PRINTER" 1>&6
+PNTR="$ac_cv_prog_PNTR"
+if test -n "$PNTR"; then
+ echo "$ac_t""$PNTR" 1>&6
else
echo "$ac_t""no" 1>&6
fi
fi
-if test -n "${PRINTER}"; then
+if test -n "${PNTR}"; then
cat >> confdefs.h <<EOF
-#define PRNTCMD "$PRINTER"
+#define PRNTCMD "lpr"
EOF
else
@@ -1559,6 +1559,8 @@
\
/usr/openwin/include \
/usr/openwin/share/include \
+ /usr/dt/include \
+ /usr/dt/share/include \
; \
do
if test -r "$ac_dir/$x_direct_test_include"; then
@@ -1680,10 +1682,14 @@
#define X_DISPLAY_MISSING 1
EOF
- X_CFLAGS= X_PRE_LIBS= X_LIBS= X_EXTRA_LIBS=
+ X_INC= X_CFLAGS= X_PRE_LIBS= X_LIBS= X_EXTRA_LIBS=
else
if test -n "$x_includes"; then
X_CFLAGS="$X_CFLAGS -I$x_includes"
+ if [ X"$X_INC" != X ]; then
+ X_INC="${X_INC}:"
+ fi
+ X_INC="${X_INC}$x_includes"
fi
# It would also be nice to do this for all -L options, not just this one.
@@ -2454,8 +2460,9 @@
s%@CPP@%$CPP%g
s%@RANLIB@%$RANLIB%g
s%@XDB@%$XDB%g
-s%@PRINTER@%$PRINTER%g
+s%@PNTR@%$PNTR%g
s%@X_CFLAGS@%$X_CFLAGS%g
+s%@X_INC@%$X_INC%g
s%@X_PRE_LIBS@%$X_PRE_LIBS%g
s%@X_LIBS@%$X_LIBS%g
s%@X_EXTRA_LIBS@%$X_EXTRA_LIBS%g

28
devel/xwpe/files/patch-09 Normal file
View File

@ -0,0 +1,28 @@
--- we_fl_unix.c.orig Wed May 6 11:03:13 1998
+++ we_fl_unix.c Fri May 8 10:25:34 1998
@@ -14,6 +14,10 @@
#include <sys/stat.h>
#include <errno.h>
+#if (defined(__unix__) || defined(unix)) && !defined(USG)
+#include <sys/param.h>
+#endif
+
struct dirfile *e_make_win_list(FENSTER *f);
int e_s_sys_ini(void);
int e_s_sys_end(void);
@@ -1929,7 +1933,13 @@
dout->name = NULL;
manpath[0] = '\0';
if (getenv("MANPATH")) strcpy(manpath, getenv("MANPATH"));
- if (manpath[0] == '\0') strcpy(manpath, "/usr/man:/usr/local/man");
+ if (manpath[0] == '\0') strcpy(manpath,
+#if (defined(BSD) && (BSD >= 199306)) || (defined(sun) && defined(__svr4__))
+ "/usr/share/man:/usr/local/man");
+#else
+ "/usr/man:/usr/local/man");
+#endif
+
while (manpath[i])
{
for (n = 0; (subpath[n] = manpath[i]) && manpath[i] != PTHD; i++, n++);

View File

@ -1,11 +1,11 @@
bin/we
bin/wpe
bin/xwe
bin/xwpe
bin/wpe
man/man1/xwpe.1.gz
man/man1/xwe.1.gz
man/man1/wpe.1.gz
man/man1/we.1.gz
@unexec /bin/rm -rf %D/share/wpe
share/wpe
@unexec /bin/rm -rf %D/share/doc/xwpe
share/doc/xwpe
share/wpe/help.key
share/wpe/help.xwpe
share/wpe/syntax_def