add inti 1.2
A set of C++ classes for developing GNOME and GTK+ applications
This commit is contained in:
parent
8252891e5d
commit
5ce21404cd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=104594
@ -89,6 +89,7 @@
|
||||
SUBDIR += hs-gtk2hs
|
||||
SUBDIR += hs-port
|
||||
SUBDIR += icegradient
|
||||
SUBDIR += inti
|
||||
SUBDIR += itk
|
||||
SUBDIR += iwidgets
|
||||
SUBDIR += jx
|
||||
|
55
x11-toolkits/inti/Makefile
Normal file
55
x11-toolkits/inti/Makefile
Normal file
@ -0,0 +1,55 @@
|
||||
# ex:ts=8
|
||||
# Ports collection makefile for: intk
|
||||
# Date created: Mar 19, 2004
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= inti
|
||||
PORTVERSION= 1.2
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= inti
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A set of C++ classes for developing GNOME and GTK+ applications
|
||||
|
||||
USE_GNOME= glib20 gtk20 atk pango gnomehack gnomeprefix
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
PLIST_FILES= bin/inti-demo \
|
||||
lib/libinti-1.0.so lib/libinti-1.0.so.9 \
|
||||
lib/inti-1.0/include/inti-config.h \
|
||||
libdata/pkgconfig/inti-1.0.pc
|
||||
PLIST_DIRS= lib/inti-1.0/include lib/inti-1.0
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
PORTDOCS= *
|
||||
.endif
|
||||
|
||||
post-configure:
|
||||
@${TOUCH} ${WRKSRC}/inti-config.h.in
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${CP} -R ${WRKSRC}/docs/ ${DOCSDIR}
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
@${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
|
||||
@${FIND} ${EXAMPLESDIR} -type f | \
|
||||
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
|
||||
@${FIND} ${EXAMPLESDIR} -type d | ${SORT} -r | \
|
||||
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
|
||||
.endif
|
||||
@${FIND} ${PREFIX}/include/inti-1.0 -type f | \
|
||||
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
|
||||
@${FIND} ${PREFIX}/include/inti-1.0 -type d | ${SORT} -r | \
|
||||
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
|
||||
@${FIND} ${PREFIX}/share/gnome/inti -type f | \
|
||||
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
|
||||
@${FIND} ${PREFIX}/share/gnome/inti -type d | ${SORT} -r | \
|
||||
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
|
||||
|
||||
.include <bsd.port.mk>
|
2
x11-toolkits/inti/distinfo
Normal file
2
x11-toolkits/inti/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (inti-1.2.tar.gz) = 4a634949517e5bf3141e9b306fa42e72
|
||||
SIZE (inti-1.2.tar.gz) = 4966470
|
15
x11-toolkits/inti/files/patch-ltmain.sh
Normal file
15
x11-toolkits/inti/files/patch-ltmain.sh
Normal file
@ -0,0 +1,15 @@
|
||||
--- ltmain.sh.orig Fri Mar 19 14:14:27 2004
|
||||
+++ ltmain.sh Fri Mar 19 14:14:40 2004
|
||||
@@ -5425,10 +5425,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false ; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
14
x11-toolkits/inti/pkg-descr
Normal file
14
x11-toolkits/inti/pkg-descr
Normal file
@ -0,0 +1,14 @@
|
||||
Inti is a set of integrated C++ foundation classes for developing GTK+
|
||||
applications on UNIX-like systems.
|
||||
|
||||
Inti combines the power of GTK+ and the power of C++ into a state-of-the-art
|
||||
GUI toolkit that makes developing applications easy, intuitive and efficient.
|
||||
There are more than 330 classes that wrap most of the objects found in the
|
||||
ATK, GDK, GDK-PIXBUF, GLib, GTK and Pango libraries. It has its own system
|
||||
of signals and slots which make using native GTK signals or creating your own
|
||||
signals easy. There is a standard string compatible UTF-8 string class, a full
|
||||
set of simple example programs, a GNU Autotools test project, a C++ version of
|
||||
the GTK+ demonstration program, extensive reference documentation and a
|
||||
tutorial.
|
||||
|
||||
WWW: http://inti.sourceforge.net/
|
Loading…
Reference in New Issue
Block a user