math/xtensor: Update to 0.15.5

Testcases all pass now.
Added ${MAKE_ENV}/${MAKE_ARGS}.
This commit is contained in:
Yuri Victorovich 2018-03-14 02:14:19 +00:00
parent 1e797751be
commit 5cd4062671
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=464446
4 changed files with 26 additions and 15 deletions

View File

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xtensor
DISTVERSION= 0.15.4
DISTVERSION= 0.15.5
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@ -22,11 +22,11 @@ NO_ARCH= yes
post-install:
cd ${WRKSRC}/xtl/include && ${COPYTREE_SHARE} xtl ${STAGEDIR}${PREFIX}/include
do-test: # 1 test is known to fail: https://github.com/QuantStack/xtensor/issues/674
do-test:
@${RLN} ${STAGEDIR}${PREFIX}/include ${WRKSRC}/test/staged-include
@cd ${WRKSRC}/test && \
${CMAKE_BIN} ${CMAKE_ARGS} . && \
${MAKE_CMD} && \
${MAKE_CMD} xtest
${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} && \
${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} xtest
.include <bsd.port.mk>

View File

@ -1,5 +1,5 @@
TIMESTAMP = 1520842745
SHA256 (QuantStack-xtensor-0.15.4_GH0.tar.gz) = 1383d34d79c4c579d577a502b145b458f74e1d76749d31a893beec5c6799098c
SIZE (QuantStack-xtensor-0.15.4_GH0.tar.gz) = 702792
TIMESTAMP = 1520992858
SHA256 (QuantStack-xtensor-0.15.5_GH0.tar.gz) = 1618ed8d6a4627323408115a9d85ad91390bb7fc1ee2299da84f28f9786214cf
SIZE (QuantStack-xtensor-0.15.5_GH0.tar.gz) = 706459
SHA256 (QuantStack-xtl-0.4.4_GH0.tar.gz) = 2e24ae1e990b36c21134ee8b2017e4d8f1aa760ba0e62e57c9de8f6339052f7f
SIZE (QuantStack-xtl-0.4.4_GH0.tar.gz) = 80592

View File

@ -1,13 +1,14 @@
--- CMakeLists.txt.orig 2018-03-12 08:10:41 UTC
--- CMakeLists.txt.orig 2018-03-13 17:28:19 UTC
+++ CMakeLists.txt
@@ -28,8 +28,8 @@ message(STATUS "Building xtensor v${${PR
@@ -28,8 +28,9 @@ message(STATUS "Building xtensor v${${PR
# Dependencies
# ============
-find_package(xtl 0.4 REQUIRED)
-find_package(xtl 0.4.1 REQUIRED)
-message(STATUS "Found xtl: ${xtl_INCLUDE_DIRS}/xtl")
+#find_package(xtl 0.4 REQUIRED)
+#find_package(xtl 0.4.1 REQUIRED)
+message(STATUS "Found xtl: xtl/include")
+
# Build
# =====

View File

@ -1,6 +1,6 @@
--- test/CMakeLists.txt.orig 2018-02-16 23:52:29 UTC
--- test/CMakeLists.txt.orig 2018-03-13 17:07:19 UTC
+++ test/CMakeLists.txt
@@ -8,12 +8,12 @@
@@ -8,12 +8,13 @@
cmake_minimum_required(VERSION 3.1)
@ -13,17 +13,27 @@
- set(XTENSOR_INCLUDE_DIR ${xtensor_INCLUDE_DIRS})
-endif ()
+ #find_package(xtensor REQUIRED CONFIG)
+ #set(XTENSOR_INCLUDE_DIR ${xtensor_INCLUDE_DIRS})
+ include_directories(staged-include)
+#endif ()
message(STATUS "Forcing tests build type to Release")
set(CMAKE_BUILD_TYPE Release CACHE STRING "Choose the type of build." FORCE)
@@ -156,7 +156,7 @@ add_executable(${XTENSOR_TARGET} ${XTENS
@@ -158,7 +158,7 @@ endforeach()
foreach(filename IN LISTS XTENSOR_TESTS)
string(REPLACE ".cpp" "" targetname ${filename})
add_executable(${targetname} ${COMMON_BASE} ${filename} ${XTENSOR_HEADERS})
- target_link_libraries(${targetname} xtensor ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
+ target_link_libraries(${targetname} ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
if(DOWNLOAD_GTEST OR GTEST_SRC_DIR)
add_dependencies(${targetname} gtest_main)
endif()
@@ -169,7 +169,7 @@ add_executable(${XTENSOR_TARGET} ${COMMO
if(DOWNLOAD_GTEST OR GTEST_SRC_DIR)
add_dependencies(${XTENSOR_TARGET} gtest_main)
endif()
-target_link_libraries(${XTENSOR_TARGET} xtensor ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries(${XTENSOR_TARGET} ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
add_custom_target(xtest COMMAND test_xtensor DEPENDS ${XTENSOR_TARGET})
add_custom_target(xtest COMMAND ${XTENSOR_TARGET} DEPENDS ${XTENSOR_TARGET})