upgrade to 1.0.5

This commit is contained in:
Ying-Chieh Liao 2001-02-11 16:25:24 +00:00
parent c82fc94311
commit 5cbbdd62a0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38206
12 changed files with 74 additions and 114 deletions

View File

@ -7,7 +7,7 @@
#
PORTNAME= logtool
PORTVERSION= 1.0.4
PORTVERSION= 1.0.5
CATEGORIES= sysutils
MASTER_SITES= http://users.digitex.net/~max/logtool/
@ -15,24 +15,19 @@ MAINTAINER= ijliao@FreeBSD.org
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
HAS_CONFIGURE= yes
CONFIGURE_ARGS= default
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=/usr/local --sysconfdir=/usr/local/etc/logtool
ALL_TARGET= build
post-patch:
.for file in logtool/Makefile logtail/Makefile
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/${file}
.endfor
.for file in logtool/config.h conf/logtool.conf
@${PERL} -pi -e "s|/etc|${PREFIX}/etc|g" ${WRKSRC}/${file}
.endfor
MAN1: logtool.1
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/logtool.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "===> Installing logtool docs in ${PREFIX}/share/doc/logtool"
@${MKDIR} ${PREFIX}/share/doc/logtool && ${CHMOD} a+rx ${PREFIX}/share/doc/logtool
@${CP} -R ${WRKSRC}/doc/* ${PREFIX}/share/doc/logtool
@${CP} -R ${WRKSRC}/doc/examples ${WRKSRC}/doc/logtool.txt ${PREFIX}/share/doc/logtool
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (logtool-1.0.4.tar.gz) = 6a4da8458f48a4ee787b1c68051daa11
MD5 (logtool-1.0.5.tar.gz) = 5fb5376725bfccb0bec31fbb054d92ef

View File

@ -1,32 +0,0 @@
--- logtool/Makefile.orig Wed Jan 10 08:27:16 2001
+++ logtool/Makefile Sun Jan 28 22:36:49 2001
@@ -9,8 +9,8 @@
csv.o html.o raw.o logtool.o main.o
SRC = logtool.c
# These options affect where logtool gets installed
-PREFIX = /usr
-ETCDIR = /etc/logtool
+PREFIX = %%PREFIX%%
+ETCDIR = %%PREFIX%%/etc/logtool
CC = gcc
INSTALL = /usr/bin/install
@@ -18,7 +18,8 @@
# INSTALL = /usr/ucb/install
# For RedHat (and most other) Linux'es, this should be ideal
-CFLAGS= -Wall -O3 -ansi -pedantic -Werror # -DDEBUG -g # uncomment this for debugging stuff's
+CFLAGS+= -I/usr/local/include -Wall -ansi -pedantic -Werror # -DDEBUG -g # uncomment this for debugging stuff's
+LIBS= -L/usr/local/lib -lgnugetopt
# For portability to non-linux'es/non-standard-linux'es, try this
# CFLAGS = -Wall
@@ -28,7 +29,7 @@
### The main build stuff
logtool: logtool.o $(OBJS)
- $(CC) $(ADDCFLAGS) -o $(PROG) $(OBJS)
+ $(CC) $(ADDCFLAGS) -o $(PROG) $(OBJS) ${LIBS}
@echo "strip $(PROG)"
@strip $(PROG)

View File

@ -1,13 +0,0 @@
--- logtail/Makefile.orig Mon Dec 25 19:24:25 2000
+++ logtail/Makefile Sun Jan 28 22:40:44 2001
@@ -1,8 +1,8 @@
SRC= logtail.c
PROG= logtail
CC= gcc
-CFLAGS= -Wall -Werror -O3 -ansi -pedantic
-PREFIX=/usr
+CFLAGS+= -Wall -Werror -ansi -pedantic
+PREFIX=%%PREFIX%%
default:
$(CC) $(CFLAGS) -o $(PROG) $(SRC)

View File

@ -0,0 +1,11 @@
--- configure.orig Mon Feb 12 00:10:54 2001
+++ configure Mon Feb 12 00:11:16 2001
@@ -745,7 +745,7 @@
fi
if test -n "$GCC"; then
- CFLAGS="-O3 -Wall -Werror -ansi -pedantic"
+ CFLAGS="-ansi -pedantic"
fi

View File

@ -0,0 +1,19 @@
--- logtool/Makefile.in.orig Sun Feb 11 23:50:38 2001
+++ logtool/Makefile.in Sun Feb 11 23:54:02 2001
@@ -16,6 +16,7 @@
CC = @CC@
INSTALL = @installprog@
CFLAGS= @CFLAGS@ @DEFS@ @LIBS@
+LIBS= -L/usr/local/lib -lgnugetopt
### The stuff below is (I hope) no longer needed now that we us autoconf/configure and friends
# Solaris users should probably use the following instead (thanks Christoph Krempe <ck@ub.fu-berlin.de>)
@@ -30,7 +31,7 @@
### The main build stuff
logtool: logtool.o $(OBJS)
- $(CC) $(ADDCFLAGS) -o $(PROG) $(OBJS)
+ $(CC) $(ADDCFLAGS) -o $(PROG) $(OBJS) ${LIBS}
@echo "strip $(PROG)"
@strip $(PROG)

View File

@ -7,7 +7,7 @@
#
PORTNAME= logtool
PORTVERSION= 1.0.4
PORTVERSION= 1.0.5
CATEGORIES= sysutils
MASTER_SITES= http://users.digitex.net/~max/logtool/
@ -15,24 +15,19 @@ MAINTAINER= ijliao@FreeBSD.org
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
HAS_CONFIGURE= yes
CONFIGURE_ARGS= default
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=/usr/local --sysconfdir=/usr/local/etc/logtool
ALL_TARGET= build
post-patch:
.for file in logtool/Makefile logtail/Makefile
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/${file}
.endfor
.for file in logtool/config.h conf/logtool.conf
@${PERL} -pi -e "s|/etc|${PREFIX}/etc|g" ${WRKSRC}/${file}
.endfor
MAN1: logtool.1
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/logtool.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "===> Installing logtool docs in ${PREFIX}/share/doc/logtool"
@${MKDIR} ${PREFIX}/share/doc/logtool && ${CHMOD} a+rx ${PREFIX}/share/doc/logtool
@${CP} -R ${WRKSRC}/doc/* ${PREFIX}/share/doc/logtool
@${CP} -R ${WRKSRC}/doc/examples ${WRKSRC}/doc/logtool.txt ${PREFIX}/share/doc/logtool
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (logtool-1.0.4.tar.gz) = 6a4da8458f48a4ee787b1c68051daa11
MD5 (logtool-1.0.5.tar.gz) = 5fb5376725bfccb0bec31fbb054d92ef

View File

@ -1,32 +0,0 @@
--- logtool/Makefile.orig Wed Jan 10 08:27:16 2001
+++ logtool/Makefile Sun Jan 28 22:36:49 2001
@@ -9,8 +9,8 @@
csv.o html.o raw.o logtool.o main.o
SRC = logtool.c
# These options affect where logtool gets installed
-PREFIX = /usr
-ETCDIR = /etc/logtool
+PREFIX = %%PREFIX%%
+ETCDIR = %%PREFIX%%/etc/logtool
CC = gcc
INSTALL = /usr/bin/install
@@ -18,7 +18,8 @@
# INSTALL = /usr/ucb/install
# For RedHat (and most other) Linux'es, this should be ideal
-CFLAGS= -Wall -O3 -ansi -pedantic -Werror # -DDEBUG -g # uncomment this for debugging stuff's
+CFLAGS+= -I/usr/local/include -Wall -ansi -pedantic -Werror # -DDEBUG -g # uncomment this for debugging stuff's
+LIBS= -L/usr/local/lib -lgnugetopt
# For portability to non-linux'es/non-standard-linux'es, try this
# CFLAGS = -Wall
@@ -28,7 +29,7 @@
### The main build stuff
logtool: logtool.o $(OBJS)
- $(CC) $(ADDCFLAGS) -o $(PROG) $(OBJS)
+ $(CC) $(ADDCFLAGS) -o $(PROG) $(OBJS) ${LIBS}
@echo "strip $(PROG)"
@strip $(PROG)

View File

@ -1,13 +0,0 @@
--- logtail/Makefile.orig Mon Dec 25 19:24:25 2000
+++ logtail/Makefile Sun Jan 28 22:40:44 2001
@@ -1,8 +1,8 @@
SRC= logtail.c
PROG= logtail
CC= gcc
-CFLAGS= -Wall -Werror -O3 -ansi -pedantic
-PREFIX=/usr
+CFLAGS+= -Wall -Werror -ansi -pedantic
+PREFIX=%%PREFIX%%
default:
$(CC) $(CFLAGS) -o $(PROG) $(SRC)

View File

@ -0,0 +1,11 @@
--- configure.orig Mon Feb 12 00:10:54 2001
+++ configure Mon Feb 12 00:11:16 2001
@@ -745,7 +745,7 @@
fi
if test -n "$GCC"; then
- CFLAGS="-O3 -Wall -Werror -ansi -pedantic"
+ CFLAGS="-ansi -pedantic"
fi

View File

@ -0,0 +1,19 @@
--- logtool/Makefile.in.orig Sun Feb 11 23:50:38 2001
+++ logtool/Makefile.in Sun Feb 11 23:54:02 2001
@@ -16,6 +16,7 @@
CC = @CC@
INSTALL = @installprog@
CFLAGS= @CFLAGS@ @DEFS@ @LIBS@
+LIBS= -L/usr/local/lib -lgnugetopt
### The stuff below is (I hope) no longer needed now that we us autoconf/configure and friends
# Solaris users should probably use the following instead (thanks Christoph Krempe <ck@ub.fu-berlin.de>)
@@ -30,7 +31,7 @@
### The main build stuff
logtool: logtool.o $(OBJS)
- $(CC) $(ADDCFLAGS) -o $(PROG) $(OBJS)
+ $(CC) $(ADDCFLAGS) -o $(PROG) $(OBJS) ${LIBS}
@echo "strip $(PROG)"
@strip $(PROG)