- Update to 0.27.5
- Disable mythlogserver as recommended from upstream - Remove own distfile mirror and trust in githubs codeload - Pet portlint (whitespace) PR: 204647 Submitted by: lucylangthorne55@gmail.com
This commit is contained in:
parent
accc712833
commit
5c8fd6dfac
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=405878
@ -2,10 +2,8 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= mythtv
|
||||
PORTVERSION= 0.27.0.20140121
|
||||
PORTREVISION= 7
|
||||
PORTVERSION= 0.27.5.20150616
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://people.freebsd.org/~decke/distfiles/
|
||||
|
||||
MAINTAINER= decke@FreeBSD.org
|
||||
COMMENT= MythTV is a homebrew PVR project
|
||||
@ -23,7 +21,7 @@ CONFLICTS= mythtv-frontend-[0-9]*
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= MythTV
|
||||
GH_TAGNAME= 5a5e1cd
|
||||
GH_TAGNAME= ad97d24
|
||||
|
||||
WRKSRC_SUBDIR= ${PORTNAME}
|
||||
|
||||
@ -52,11 +50,12 @@ MAKE_ENV= QTDIR="${QT_PREFIX}" \
|
||||
CPPFLAGS+= ${QTCPPFLAGS}
|
||||
CONFIGURE_ENV+= QMAKESPEC="${QMAKESPEC}" MOC="${MOC}" \
|
||||
QTDIR="${QT_PREFIX}"
|
||||
CONFIGURE_ENV+= PKG_CONFIG_PATH="${LOCALBASE}/libdata/pkgconfig"
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
CONFIGURE_ARGS= --prefix="${PREFIX}" --cc="${CC}" --cxx="${CXX}" --dvb-path="${LOCALBASE}/include" \
|
||||
--libxml2-path="${LOCALBASE}/include/libxml2" --enable-v4l2 --enable-ivtv --enable-xv \
|
||||
--disable-audio-alsa --disable-indev=alsa --disable-outdev=alsa
|
||||
--disable-audio-alsa --disable-indev=alsa --disable-outdev=alsa --disable-mythlogserver
|
||||
|
||||
QMAKESPEC?= ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++
|
||||
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (MythTV-mythtv-0.27.0.20140121-5a5e1cd_GH0.tar.gz) = c4dfed56e96e73537be4f5915b14843ae238d0fc0d1b41d653bb86b9bcb08158
|
||||
SIZE (MythTV-mythtv-0.27.0.20140121-5a5e1cd_GH0.tar.gz) = 85931272
|
||||
SHA256 (MythTV-mythtv-0.27.5.20150616-ad97d24_GH0.tar.gz) = 9e3b0782e7627fdbb91641ac39e2c39d3fc01ee1a57152c74df9c9116e966238
|
||||
SIZE (MythTV-mythtv-0.27.5.20150616-ad97d24_GH0.tar.gz) = 85651303
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- external/zeromq/doc/Makefile.in.orig 2012-10-02 12:30:24.000000000 +0200
|
||||
+++ external/zeromq/doc/Makefile.in 2012-10-20 16:56:13.777947694 +0200
|
||||
@@ -476,7 +476,7 @@
|
||||
|
||||
install-info-am:
|
||||
|
||||
-install-man: install-man3 install-man7
|
||||
+install-man:
|
||||
|
||||
install-pdf: install-pdf-am
|
||||
|
@ -0,0 +1,10 @@
|
||||
--- external/zeromq/src/Makefile.am.orig 2015-11-16 14:31:23.735432710 +0000
|
||||
+++ external/zeromq/src/Makefile.am 2015-11-16 14:28:48.465433398 +0000
|
||||
@@ -1,6 +1,6 @@
|
||||
lib_LTLIBRARIES = libmythzmq.la
|
||||
|
||||
-pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfigdir = $(PKG_CONFIG_PATH)
|
||||
pkgconfig_DATA = libmythzmq.pc
|
||||
|
||||
include_HEADERS = ../include/zmq.h ../include/zmq.hpp ../include/zmq_utils.h
|
@ -1,20 +0,0 @@
|
||||
--- libs/libmythbase/logging.cpp.orig 2013-09-18 20:06:08.000000000 +0000
|
||||
+++ libs/libmythbase/logging.cpp 2013-10-18 14:57:43.000000000 +0000
|
||||
@@ -859,7 +859,7 @@
|
||||
#ifndef _WIN32
|
||||
if (logPropagateOpts.facility >= 0)
|
||||
{
|
||||
- CODE *syslogname;
|
||||
+ const CODE *syslogname;
|
||||
|
||||
for (syslogname = &facilitynames[0];
|
||||
(syslogname->c_name &&
|
||||
@@ -996,7 +996,7 @@
|
||||
"Windows does not support syslog, disabling" );
|
||||
return( -2 );
|
||||
#else
|
||||
- CODE *name;
|
||||
+ const CODE *name;
|
||||
int i;
|
||||
QByteArray ba = facility.toLocal8Bit();
|
||||
char *string = (char *)ba.constData();
|
@ -1,10 +0,0 @@
|
||||
--- libs/libmythbase/mythmiscutil.h.orig 2013-09-18 20:06:08.000000000 +0000
|
||||
+++ libs/libmythbase/mythmiscutil.h 2013-10-18 12:23:08.000000000 +0000
|
||||
@@ -2,6 +2,7 @@
|
||||
#define MYTHMISCUTIL_H_
|
||||
|
||||
#include <stdint.h>
|
||||
+#include <time.h>
|
||||
|
||||
#include <algorithm>
|
||||
using namespace std;
|
@ -1,10 +0,0 @@
|
||||
--- libs/libmythbase/mythsystemlegacy.h.orig 2013-09-18 20:06:08.000000000 +0000
|
||||
+++ libs/libmythbase/mythsystemlegacy.h 2013-10-18 11:37:16.000000000 +0000
|
||||
@@ -42,6 +42,7 @@
|
||||
|
||||
// C headers
|
||||
#include <stdint.h>
|
||||
+#include <time.h>
|
||||
|
||||
#ifdef __cplusplus
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- libs/libmythbase/mythtimer.cpp.orig 2013-09-18 20:06:08.000000000 +0000
|
||||
+++ libs/libmythbase/mythtimer.cpp 2013-10-22 11:03:36.000000000 +0000
|
||||
@@ -19,6 +19,8 @@
|
||||
* Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
|
||||
*/
|
||||
|
||||
+#include <stdint.h>
|
||||
+
|
||||
// MythTV includes
|
||||
#include "mythtimer.h"
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- libs/libmythbase/mythtimezone.cpp.orig 2013-09-18 20:06:08.000000000 +0000
|
||||
+++ libs/libmythbase/mythtimezone.cpp 2013-10-18 16:01:39.000000000 +0000
|
||||
@@ -1,6 +1,7 @@
|
||||
#include "mythtimezone.h"
|
||||
|
||||
#include <stdlib.h> // for malloc, getenv
|
||||
+#include <time.h>
|
||||
|
||||
#include <QDataStream>
|
||||
#include <QTextStream>
|
@ -1,14 +0,0 @@
|
||||
--- libs/libmythtv/recorders/dvbdev/dvbci.cpp.orig 2010-04-26 23:30:52.000000000 +0200
|
||||
+++ libs/libmythtv/recorders/dvbdev/dvbci.cpp 2014-01-22 09:13:22.000000000 -0500
|
||||
@@ -28,7 +28,11 @@
|
||||
#include <errno.h>
|
||||
#include <ctype.h>
|
||||
#include <linux/dvb/ca.h>
|
||||
+#ifndef __FreeBSD__
|
||||
#include <malloc.h>
|
||||
+#else
|
||||
+#include <stdlib.h>
|
||||
+#endif
|
||||
#include <netinet/in.h>
|
||||
#include <poll.h>
|
||||
#include <string.h>
|
@ -10,7 +10,6 @@ bin/mythfrontend
|
||||
bin/mythhdhomerun_config
|
||||
bin/mythjobqueue
|
||||
bin/mythlcdserver
|
||||
bin/mythlogserver
|
||||
bin/mythmediaserver
|
||||
bin/mythmetadatalookup
|
||||
bin/mythpreviewgen
|
||||
@ -432,7 +431,6 @@ include/mythtv/mythwidgets.h
|
||||
include/mythtv/mythwizard.h
|
||||
include/mythtv/netgrabbermanager.h
|
||||
include/mythtv/netutils.h
|
||||
include/mythtv/nzmqt/nzmqt.hpp
|
||||
include/mythtv/oldsettings.h
|
||||
include/mythtv/output.h
|
||||
include/mythtv/playgroup.h
|
||||
@ -490,9 +488,6 @@ include/mythtv/virtualkeyboard_qt.h
|
||||
include/mythtv/visual.h
|
||||
include/mythtv/volumebase.h
|
||||
include/mythtv/xmlparse.h
|
||||
include/mythtv/zeromq/zmq.h
|
||||
include/mythtv/zeromq/zmq.hpp
|
||||
include/mythtv/zeromq/zmq_utils.h
|
||||
%%BINDINGS%%%%SITE_PERL%%/IO/Socket/INET/MythTV.pm
|
||||
%%BINDINGS%%%%SITE_PERL%%/MythTV.pm
|
||||
%%BINDINGS%%%%SITE_PERL%%/MythTV/Channel.pm
|
||||
@ -622,10 +617,6 @@ lib/libmythmetadata-0.27.so
|
||||
lib/libmythmetadata-0.27.so.0
|
||||
lib/libmythmetadata-0.27.so.0.27
|
||||
lib/libmythmetadata-0.27.so.0.27.0
|
||||
lib/libmythnzmqt.so
|
||||
lib/libmythnzmqt.so.0
|
||||
lib/libmythnzmqt.so.0.27
|
||||
lib/libmythnzmqt.so.0.27.0
|
||||
lib/libmythpostproc.so
|
||||
lib/libmythpostproc.so.52
|
||||
lib/libmythpostproc.so.52.2.100
|
||||
@ -659,10 +650,6 @@ lib/libmythupnp-0.27.so
|
||||
lib/libmythupnp-0.27.so.0
|
||||
lib/libmythupnp-0.27.so.0.27
|
||||
lib/libmythupnp-0.27.so.0.27.0
|
||||
lib/libmythzmq.a
|
||||
lib/libmythzmq.so
|
||||
lib/libmythzmq.so.1
|
||||
lib/libmythzmq.so.1.0.1
|
||||
lib/mythtv/filters/libadjust.so
|
||||
lib/mythtv/filters/libbobdeint.so
|
||||
lib/mythtv/filters/libcrop.so
|
||||
@ -679,7 +666,6 @@ lib/mythtv/filters/libpostprocess.so
|
||||
lib/mythtv/filters/libquickdnr.so
|
||||
lib/mythtv/filters/libvflip.so
|
||||
lib/mythtv/filters/libyadif.so
|
||||
libdata/pkgconfig/libmythzmq.pc
|
||||
%%DATADIR%%/CDS_scpd.xml
|
||||
%%DATADIR%%/CMGR_scpd.xml
|
||||
%%DATADIR%%/MFEXML_scpd.xml
|
||||
|
Loading…
Reference in New Issue
Block a user