- fix the plist file

- remove the BROKEN flag
- remove the patch and uses REINPLACE_CMD instead (to handle PREFIX correctly)
- use INSTALL_DATA and INSTALL_SCRIPT instead of generic INSTALL
- install to share/xmltv (no more to share/p5-xmltv)
- bump PORTREVISION

PR:		ports/123016
Submitted by:	Ganael Laplanche <ganael.laplanche@martymac.com>
Approved by:	maintainer timeout (grog; 1 month)
This commit is contained in:
Pav Lucistnik 2008-06-19 00:55:05 +00:00
parent 11ba11eafc
commit 5bc9654e65
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=215218
3 changed files with 10 additions and 29 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= tv_grab_au
PORTVERSION= 0.6.2
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= http://www.onlinetractorparts.com.au/rohbags/xmltvau/
# DISTNAME= ${PORTNAME}-${PORTVERSION}
@ -17,14 +17,15 @@ COMMENT= X 'tv_grab_au' is an XMLTV grabber for Australian TV programmes
RUN_DEPENDS= tv_check:${PORTSDIR}/textproc/p5-xmltv
BROKEN= Incomplete pkg-plist
NO_WRKSUBDIR= yes
NO_BUILD= yes
post-patch:
@${REINPLACE_CMD} 's|/usr/share/xmltv|${PREFIX}/share/xmltv|' ${WRKDIR}/tv_grab_au
do-install:
${INSTALL} ${WRKDIR}/tv_grab_au ${PREFIX}/bin
${MKDIR} ${PREFIX}/share/p5-xmltv/tv_grab_au
${INSTALL} ${WRKDIR}/channel_ids ${PREFIX}/share/p5-xmltv/tv_grab_au/channel_ids
${INSTALL_SCRIPT} ${WRKDIR}/tv_grab_au ${PREFIX}/bin
${MKDIR} ${PREFIX}/share/xmltv/tv_grab_au
${INSTALL_DATA} ${WRKDIR}/channel_ids ${PREFIX}/share/xmltv/tv_grab_au/channel_ids
.include <bsd.port.mk>

View File

@ -1,20 +0,0 @@
--- tv_grab_au~ Tue May 31 15:59:17 2005
+++ tv_grab_au Tue Feb 27 17:05:10 2007
@@ -68,7 +68,7 @@
B<--debug> Output debugging info.
B<--share> Specify alternate directory for channel_ids file, usally found
-in /usr/share/xmltv/tv_grab_au/.
+in /usr/local/share/p5-xmltv/tv_grab_au/.
=head1 SEE ALSO
@@ -218,7 +218,7 @@
# share/ directory for storing region-to-channel mapping files.
# The directory can be overridden with the --share option.
-my $SHARE_DIR='/usr/share/xmltv';
+my $SHARE_DIR='/usr/local/share/p5-xmltv';
$SHARE_DIR = $opt_share if defined $opt_share;
my $OUR_SHARE_DIR = (defined $SHARE_DIR) ? "$SHARE_DIR/tv_grab_au" : '.';
my $channel_ids_file = "$OUR_SHARE_DIR/channel_ids";

View File

@ -1,4 +1,4 @@
bin/tv_grab_au
share/p5-xmltv/tv_grab_au/channel_ids
@dirrm share/p5-xmltv/tv_grab_au
share/xmltv/tv_grab_au/channel_ids
@dirrm share/xmltv/tv_grab_au
@dirrmtry share/xmltv