Although the default remains 8.5, this changes allows compiling against

Tk-8.6 as well. Also set MAKE_JOBS_SAFE to "yes" -- we rely on
bsd.lib.mk, which has been parallel-safe for ever.
This commit is contained in:
Mikhail Teterin 2011-09-19 22:21:56 +00:00
parent 5f0c7d7294
commit 5bc4cc4705
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=282025
3 changed files with 10 additions and 1 deletions

View File

@ -32,6 +32,7 @@ MAKEFILE= ${FILESDIR}/Makefile.bsd
USE_TK= 83+
USE_TK_BUILD= ${USE_TK}
MAKE_ENV+= TCL_VER=${TCL_VER}
MAKE_JOBS_SAFE= yes
# We don't need the bundled libraries:
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude '*/libz/*' \

View File

@ -31,6 +31,7 @@ CFLAGS+= -DNDEBUG -Wall -I. -DUSE_TCL_STUBS -DUSE_TK_STUBS
CFLAGS+= -DVERSION=\"${PORTVERSION}\" -I${LOCALBASE}/include
CFLAGS+= -DHAVE_JPEGLIB_H -DHAVE_TIFF_H -DHAVE_DLFCN_H -DHAVE_IMG_H
CFLAGS+= -DHAVE_INTTYPES_H -DHAVE_STDINT_H -DHAVE_UNISTD_H -DSTDC_HEADERS
CFLAGS+= -DUSE_INTERP_RESULT
all: pkgIndex.tcl

View File

@ -1,5 +1,12 @@
--- imgObj.c 2002-01-15 16:00:08.000000000 -0500
+++ imgObj.c 2011-09-14 01:42:03.000000000 -0400
+++ imgObj.c 2011-09-19 18:18:06.000000000 -0400
@@ -23,5 +23,5 @@
static int initialized = 0;
-static Tcl_ObjType* byteArrayType = 0;
+static const Tcl_ObjType* byteArrayType = 0;
int
@@ -33,5 +33,5 @@
return (initialized = IMG_PERL|IMG_OBJS);
#else