Multiple ports: improve regex compliance (part 2)
This is again a part of the project to stop extraneous escaping of ordinary characters and redefine some ordinary escapes as special behavior. Most of these ports are pushed over to use textproc/gsed because they want to use GNU extensions. Others are fixed to either escape appropriately (e.g. $$ rather than \$ in Makefiles!) or just remove redundant escapes (e.g. backtick in single quotes doesn't need escaped). PR: 229925 MFH: no (invasive risk)
This commit is contained in:
parent
d841eb94b1
commit
5bc1617efc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=543267
@ -95,10 +95,10 @@ post-build:
|
|||||||
.for f in ${SCRIPT_FILES}
|
.for f in ${SCRIPT_FILES}
|
||||||
@${REINPLACE_CMD} -e 's|/usr/share/cassandra|${DATADIR}/bin|' ${BUILD_DIST_DIR}/bin/${f}
|
@${REINPLACE_CMD} -e 's|/usr/share/cassandra|${DATADIR}/bin|' ${BUILD_DIST_DIR}/bin/${f}
|
||||||
.endfor
|
.endfor
|
||||||
@${REINPLACE_CMD} -e 's|\`dirname "\$$\0"\`/..|${DATADIR}|' ${BUILD_DIST_DIR}/bin/cassandra.in.sh
|
@${REINPLACE_CMD} -e 's|`dirname "$$0"`/..|${DATADIR}|' ${BUILD_DIST_DIR}/bin/cassandra.in.sh
|
||||||
@${REINPLACE_CMD} -e 's|\$$\CASSANDRA_HOME/lib/sigar-bin|${JAVAJARDIR}|' ${BUILD_DIST_DIR}/bin/cassandra.in.sh
|
@${REINPLACE_CMD} -e 's|$$CASSANDRA_HOME/lib/sigar-bin|${JAVAJARDIR}|' ${BUILD_DIST_DIR}/bin/cassandra.in.sh
|
||||||
@${REINPLACE_CMD} -e 's|\$$\CASSANDRA_HOME/lib/sigar-bin|${JAVAJARDIR}|' ${BUILD_DIST_DIR}/conf/cassandra-env.sh
|
@${REINPLACE_CMD} -e 's|$$CASSANDRA_HOME/lib/sigar-bin|${JAVAJARDIR}|' ${BUILD_DIST_DIR}/conf/cassandra-env.sh
|
||||||
@${REINPLACE_CMD} -e 's|\$$\CASSANDRA_HOME/conf|${ETCDIR}|' ${BUILD_DIST_DIR}/bin/cassandra.in.sh
|
@${REINPLACE_CMD} -e 's|$$CASSANDRA_HOME/conf|${ETCDIR}|' ${BUILD_DIST_DIR}/bin/cassandra.in.sh
|
||||||
.for f in ${CONFIG_FILES}
|
.for f in ${CONFIG_FILES}
|
||||||
@${MV} ${BUILD_DIST_DIR}/conf/${f} ${BUILD_DIST_DIR}/conf/${f}.sample
|
@${MV} ${BUILD_DIST_DIR}/conf/${f} ${BUILD_DIST_DIR}/conf/${f}.sample
|
||||||
.endfor
|
.endfor
|
||||||
|
@ -74,7 +74,7 @@ post-patch:
|
|||||||
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=238514
|
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=238514
|
||||||
.if ${OPSYS} == FreeBSD && (${OSVERSION} < 1200000 || ${ARCH} == i386)
|
.if ${OPSYS} == FreeBSD && (${OSVERSION} < 1200000 || ${ARCH} == i386)
|
||||||
@${REINPLACE_CMD} \
|
@${REINPLACE_CMD} \
|
||||||
-e 's,\$FLTO_FLAG ,,g' \
|
-e 's,$$FLTO_FLAG ,,g' \
|
||||||
${WRKSRC}/src/jiffy/rebar.config
|
${WRKSRC}/src/jiffy/rebar.config
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
|
@ -17,7 +17,7 @@
|
|||||||
self._print(self._fmt_title % _('Extraction'))
|
self._print(self._fmt_title % _('Extraction'))
|
||||||
if kargs.get('external')!=None:
|
if kargs.get('external')!=None:
|
||||||
self._call_external(**kargs)
|
self._call_external(**kargs)
|
||||||
@@ -518,6 +521,81 @@ class SETUP:
|
@@ -518,6 +521,88 @@ class SETUP:
|
||||||
if iextr_as:
|
if iextr_as:
|
||||||
self.Clean(to_delete=path)
|
self.Clean(to_delete=path)
|
||||||
|
|
||||||
@ -65,6 +65,13 @@
|
|||||||
+ sys.stdout.write(ligne)
|
+ sys.stdout.write(ligne)
|
||||||
+ system=SYSTEM({ 'verbose' : True, 'debug' : False },
|
+ system=SYSTEM({ 'verbose' : True, 'debug' : False },
|
||||||
+ **{'maxcmdlen' : 2**31, 'log' : self})
|
+ **{'maxcmdlen' : 2**31, 'log' : self})
|
||||||
|
+ file2patch = os.path.join(self.workdir, self.content, 'waf.main')
|
||||||
|
+ self._print('FreeBSD patch: remove extraneous escape => modify waf.main')
|
||||||
|
+ for ligne in fileinput.input(file2patch, inplace=1):
|
||||||
|
+ nl = ligne.find("\main$")
|
||||||
|
+ if nl > 0:
|
||||||
|
+ ligne =ligne.replace("\main$", "main$")
|
||||||
|
+ sys.stdout.write(ligne)
|
||||||
+ for f2p in ('waf', 'waf.main', 'waf_variant', 'waf_std', 'waf_mpi', 'bibpyt/Macro/macr_ecre_calc_ops.py'):
|
+ for f2p in ('waf', 'waf.main', 'waf_variant', 'waf_std', 'waf_mpi', 'bibpyt/Macro/macr_ecre_calc_ops.py'):
|
||||||
+ file2patch = os.path.join(self.workdir, self.content, f2p)
|
+ file2patch = os.path.join(self.workdir, self.content, f2p)
|
||||||
+ self._print('FreeBSD patch: /bin/bash => modify ' + file2patch)
|
+ self._print('FreeBSD patch: /bin/bash => modify ' + file2patch)
|
||||||
|
@ -16,7 +16,8 @@ ONLY_FOR_ARCHS= amd64 i386 powerpc64
|
|||||||
BUILD_DEPENDS= zip:archivers/zip \
|
BUILD_DEPENDS= zip:archivers/zip \
|
||||||
autoconf>0:devel/autoconf \
|
autoconf>0:devel/autoconf \
|
||||||
${LOCALBASE}/include/cups/cups.h:print/cups \
|
${LOCALBASE}/include/cups/cups.h:print/cups \
|
||||||
bash:shells/bash
|
bash:shells/bash \
|
||||||
|
gsed:textproc/gsed
|
||||||
LIB_DEPENDS= libasound.so:audio/alsa-lib \
|
LIB_DEPENDS= libasound.so:audio/alsa-lib \
|
||||||
libfontconfig.so:x11-fonts/fontconfig \
|
libfontconfig.so:x11-fonts/fontconfig \
|
||||||
libfreetype.so:print/freetype2 \
|
libfreetype.so:print/freetype2 \
|
||||||
@ -64,7 +65,8 @@ JDK_BUG_URL= https://bugs.freebsd.org/bugzilla/enter_bug.cgi?product=Ports%20%26
|
|||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
CONFIGURE_ENV= CC=${CC} \
|
CONFIGURE_ENV= CC=${CC} \
|
||||||
CXX=${CXX} \
|
CXX=${CXX} \
|
||||||
CPP=${CPP}
|
CPP=${CPP} \
|
||||||
|
ac_cv_path_SED=${LOCALBASE}/bin/gsed
|
||||||
CONFIGURE_ARGS= --with-boot-jdk=${BOOTSTRAPJDKDIR} \
|
CONFIGURE_ARGS= --with-boot-jdk=${BOOTSTRAPJDKDIR} \
|
||||||
--disable-ccache \
|
--disable-ccache \
|
||||||
--disable-javac-server \
|
--disable-javac-server \
|
||||||
|
@ -8,6 +8,8 @@ CATEGORIES= security net-vpn
|
|||||||
MAINTAINER= lifanov@FreeBSD.org
|
MAINTAINER= lifanov@FreeBSD.org
|
||||||
COMMENT= Client for PPP+SSL VPN tunnel services
|
COMMENT= Client for PPP+SSL VPN tunnel services
|
||||||
|
|
||||||
|
BUILD_DEPENDS= gsed:textproc/gsed
|
||||||
|
|
||||||
LICENSE= GPLv3
|
LICENSE= GPLv3
|
||||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||||
|
|
||||||
@ -16,7 +18,8 @@ USE_GITHUB= yes
|
|||||||
GH_ACCOUNT= adrienverge
|
GH_ACCOUNT= adrienverge
|
||||||
|
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
CONFIGURE_ENV= OPENSSL_CFLAGS=${OPENSSLINC} \
|
CONFIGURE_ENV= ac_cv_path_SED=${LOCALBASE}/bin/gsed \
|
||||||
|
OPENSSL_CFLAGS=${OPENSSLINC} \
|
||||||
OPENSSL_LIBS="-lssl -lcrypto"
|
OPENSSL_LIBS="-lssl -lcrypto"
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
@ -12,6 +12,7 @@ COMMENT= Graphical certification authority
|
|||||||
LICENSE= BSD3CLAUSE
|
LICENSE= BSD3CLAUSE
|
||||||
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
|
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
|
||||||
|
|
||||||
|
BUILD_DEPENDS= gsed:textproc/gsed
|
||||||
LIB_DEPENDS= libltdl.so:devel/libltdl
|
LIB_DEPENDS= libltdl.so:devel/libltdl
|
||||||
|
|
||||||
USES= compiler:c++11-lang desktop-file-utils gmake localbase \
|
USES= compiler:c++11-lang desktop-file-utils gmake localbase \
|
||||||
@ -20,6 +21,7 @@ USE_QT= buildtools_build core gui linguist_build sql widgets
|
|||||||
USE_CXXSTD= c++11
|
USE_CXXSTD= c++11
|
||||||
|
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
|
BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
|
||||||
CONFIGURE_ARGS= --with-openssl=${OPENSSLDIR} \
|
CONFIGURE_ARGS= --with-openssl=${OPENSSLDIR} \
|
||||||
--with-qt=${PREFIX} \
|
--with-qt=${PREFIX} \
|
||||||
--with-qt-version=5
|
--with-qt-version=5
|
||||||
|
Loading…
Reference in New Issue
Block a user