Update to Time-Human 1.03 as per the PR.

While I'm here, add a 'test' Makefile target to run
the (trivial) test suite.

PR:		109050
Submitted by:	Li-Wen Hsu <lwhsu@lwhsu.org>
This commit is contained in:
Peter Pentchev 2007-02-16 16:20:09 +00:00
parent 86ba581082
commit 5bb118f306
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=185323
3 changed files with 14 additions and 14 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= Time-Human
PORTVERSION= 1.02
PORTREVISION= 1
PORTVERSION= 1.03
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Time
@ -26,4 +25,7 @@ MAN3= Time::Human.3
EXTRA_PATCHES+= ${PATCHDIR}/Human.pm-5005.patch
.endif
test: build
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (Time-Human-1.02.tar.gz) = ca11066959cb38fb8876e2f2fdeb6863
SHA256 (Time-Human-1.02.tar.gz) = 13db2a89d0e22edf601b640be7ddc31c765d53f00f3ba09b0a477448dafe5e79
SIZE (Time-Human-1.02.tar.gz) = 2771
MD5 (Time-Human-1.03.tar.gz) = 0e869154c54593305cb1366285c8cac5
SHA256 (Time-Human-1.03.tar.gz) = 90e9812b89eb2f5773b3c0872a9b8bfb61fda3c6a4570d1a6610771926d7f976
SIZE (Time-Human-1.03.tar.gz) = 3442

View File

@ -1,8 +1,6 @@
--- Human.pm.orig Thu May 30 14:01:27 2002
+++ Human.pm Tue Jun 29 11:52:35 2004
@@ -1,12 +1,15 @@
+#!/usr/bin/perl -w
+
--- Human.pm.orig Sun Feb 11 22:58:56 2007
+++ Human.pm Sun Feb 11 23:00:27 2007
@@ -1,12 +1,13 @@
package Time::Human;
-require 5.005_62;
@ -19,7 +17,7 @@
# Items to export into callers namespace by default. Note: do not export
# names by default without a very good reason. Use EXPORT_OK instead.
@@ -15,19 +18,19 @@
@@ -15,19 +16,19 @@
# This allows declaration use Time::Human ':all';
# If you do not need this, moving things directly into @EXPORT or @EXPORT_OK
# will save memory.
@ -36,15 +34,15 @@
humanize
);
-our $VERSION = '1.02';
+$VERSION = '1.02';
-our $VERSION = '1.03';
+$VERSION = '1.03';
-our %templates = (
+%templates = (
English => {
numbers => [ qw(one two three four five six seven eight nine ten eleven twelve) ],
@@ -43,9 +46,9 @@
@@ -43,9 +44,9 @@
}
);