Add gaim-otr 1.0.1, allows deniable private conversations using GAIM.
PR: ports/75352 Submitted by: Conor McDermottroe <ports(at)mcdermottroe.com>
This commit is contained in:
parent
e9f5f9e5a4
commit
5b9ca1709b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=131709
@ -108,6 +108,7 @@
|
||||
SUBDIR += fwtk
|
||||
SUBDIR += gag
|
||||
SUBDIR += gaim-encryption
|
||||
SUBDIR += gaim-otr
|
||||
SUBDIR += gcipher
|
||||
SUBDIR += gnome-password-generator
|
||||
SUBDIR += gnome-ssh-askpass
|
||||
|
52
security/gaim-otr/Makefile
Normal file
52
security/gaim-otr/Makefile
Normal file
@ -0,0 +1,52 @@
|
||||
# New ports collection makefile for: Gaim-OTR
|
||||
# Date created: 2004-12-17
|
||||
# Whom: Conor McDermottroe <ports@mcdermottroe.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= otr
|
||||
PORTVERSION= 1.0.1
|
||||
CATEGORIES= security net
|
||||
MASTER_SITES= http://www.cypherpunks.ca/otr/
|
||||
PKGNAMEPREFIX= gaim-
|
||||
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@mcdermottroe.com
|
||||
COMMENT= Allows deniable private conversations using GAIM
|
||||
|
||||
BUILD_DEPENDS= ${X11BASE}/include/gaim/config.h:${PORTSDIR}/net/gaim \
|
||||
pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
RUN_DEPENDS= gaim:${PORTSDIR}/net/gaim
|
||||
LIB_DEPENDS= gpg-error:${PORTSDIR}/security/libgpg-error \
|
||||
gcrypt:${PORTSDIR}/security/libgcrypt
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= glib20 gtk20
|
||||
USE_REINPLACE= yes
|
||||
|
||||
MAN1= otr_toolkit.1
|
||||
MLINKS= otr_toolkit.1 otr_parse.1 \
|
||||
otr_toolkit.1 otr_sesskeys.1 \
|
||||
otr_toolkit.1 otr_mackey.1 \
|
||||
otr_toolkit.1 otr_readforge.1 \
|
||||
otr_toolkit.1 otr_modify.1 \
|
||||
otr_toolkit.1 otr_remac.1
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
|
||||
${WRKSRC}/gaim-otr/Makefile \
|
||||
${WRKSRC}/libotr/Makefile \
|
||||
${WRKSRC}/tools/Makefile
|
||||
${REINPLACE_CMD} -e "s|%%X11BASE%%|${X11BASE}|g" \
|
||||
${WRKSRC}/gaim-otr/Makefile
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/gaim-otr.so ${PREFIX}/lib/gaim
|
||||
${INSTALL_MAN} ${WRKSRC}/tools/otr_toolkit.1 ${PREFIX}/man/man1
|
||||
.for P in otr_parse otr_sesskeys otr_mackey otr_readforge otr_modify otr_remac
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${P} ${PREFIX}/bin
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
2
security/gaim-otr/distinfo
Normal file
2
security/gaim-otr/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (gaim-otr-1.0.1.tar.gz) = efc22af7c4a17448da75419bbaeb80d6
|
||||
SIZE (gaim-otr-1.0.1.tar.gz) = 76536
|
10
security/gaim-otr/files/patch-Makefile
Normal file
10
security/gaim-otr/files/patch-Makefile
Normal file
@ -0,0 +1,10 @@
|
||||
--- Makefile.bak Fri Dec 17 16:19:08 2004
|
||||
+++ Makefile Fri Dec 17 16:19:16 2004
|
||||
@@ -1,4 +1,4 @@
|
||||
all install clean distclean:
|
||||
- make -C libotr $@
|
||||
- make -C gaim-otr $@
|
||||
- make -C tools $@
|
||||
+ gmake -C libotr $@
|
||||
+ gmake -C gaim-otr $@
|
||||
+ gmake -C tools $@
|
22
security/gaim-otr/files/patch-gaim-otr-Makefile
Normal file
22
security/gaim-otr/files/patch-gaim-otr-Makefile
Normal file
@ -0,0 +1,22 @@
|
||||
--- gaim-otr/Makefile.bak Fri Dec 17 17:11:49 2004
|
||||
+++ gaim-otr/Makefile Fri Dec 17 17:12:57 2004
|
||||
@@ -1,5 +1,5 @@
|
||||
# Replace this with the path to the GAIM headers
|
||||
-GAIM_SOURCE ?= /usr/include/gaim
|
||||
+GAIM_SOURCE ?= %%X11BASE%%/include/gaim
|
||||
|
||||
# If you don't have pkg-config, put the appropriate -I entry on the next line
|
||||
GTK_HDRS ?= `pkg-config --cflags glib-2.0 gtk+-2.0`
|
||||
@@ -19,10 +19,10 @@
|
||||
all: $(TARGET)
|
||||
|
||||
$(TARGET): otr-plugin.o ui.o dialogs.o $(LIBOTR_DIR)/libotr.a
|
||||
- $(CC) -g -shared -module -avoid-version $^ -o $@ -lgcrypt
|
||||
+ $(CC) -g -shared -module -avoid-version -L %%LOCALBASE%%/lib $^ -o $@ -lgcrypt
|
||||
|
||||
$(LIBOTR_DIR)/libotr.a: FORCE
|
||||
- make -C $(LIBOTR_DIR) libotr.a
|
||||
+ gmake -C $(LIBOTR_DIR) libotr.a
|
||||
|
||||
install: all
|
||||
install -d $(INSTALLDIR)
|
9
security/gaim-otr/files/patch-libotr-Makefile
Normal file
9
security/gaim-otr/files/patch-libotr-Makefile
Normal file
@ -0,0 +1,9 @@
|
||||
--- libotr/Makefile.bak Fri Dec 17 16:31:14 2004
|
||||
+++ libotr/Makefile Fri Dec 17 16:31:53 2004
|
||||
@@ -1,5 +1,5 @@
|
||||
CC ?= gcc
|
||||
-override CFLAGS += -g -Wall -fPIC
|
||||
+CFLAGS += -g -Wall -fPIC -I %%LOCALBASE%%/include
|
||||
LDFLAGS ?= -lgcrypt -g
|
||||
|
||||
all: libotr.a
|
11
security/gaim-otr/files/patch-libotr-context
Normal file
11
security/gaim-otr/files/patch-libotr-context
Normal file
@ -0,0 +1,11 @@
|
||||
--- libotr/context.h.bak Fri Dec 17 17:14:42 2004
|
||||
+++ libotr/context.h Fri Dec 17 17:14:53 2004
|
||||
@@ -20,7 +20,7 @@
|
||||
#ifndef __CONTEXT_H__
|
||||
#define __CONTEXT_H__
|
||||
|
||||
-#include "gcrypt.h"
|
||||
+#include <gcrypt.h>
|
||||
#include "dh.h"
|
||||
|
||||
typedef enum {
|
11
security/gaim-otr/files/patch-libotr-privkey
Normal file
11
security/gaim-otr/files/patch-libotr-privkey
Normal file
@ -0,0 +1,11 @@
|
||||
--- libotr/privkey.c.bak Fri Dec 17 16:24:41 2004
|
||||
+++ libotr/privkey.c Fri Dec 17 16:24:54 2004
|
||||
@@ -24,7 +24,7 @@
|
||||
#include <sys/stat.h>
|
||||
|
||||
/* libgcrypt headers */
|
||||
-#include "gcrypt.h"
|
||||
+#include <gcrypt.h>
|
||||
|
||||
/* libotr headers */
|
||||
#include "proto.h"
|
44
security/gaim-otr/files/patch-tools-Makefile
Normal file
44
security/gaim-otr/files/patch-tools-Makefile
Normal file
@ -0,0 +1,44 @@
|
||||
--- tools/Makefile.bak Fri Dec 17 17:18:13 2004
|
||||
+++ tools/Makefile Fri Dec 17 17:20:57 2004
|
||||
@@ -9,7 +9,7 @@
|
||||
INSTALLMANDIR = $(DESTDIR)/usr/share/man/man1
|
||||
|
||||
CC ?= gcc
|
||||
-override CFLAGS += -g -Wall -I$(LIBOTR_DIR) -fPIC
|
||||
+override CFLAGS += -g -Wall -I$(LIBOTR_DIR) -I%%LOCALBASE%%/include -L%%LOCALBASE%%/lib -fPIC
|
||||
|
||||
TARGETS = $(TARGET_DIR)/otr_parse \
|
||||
$(TARGET_DIR)/otr_sesskeys \
|
||||
@@ -21,25 +21,25 @@
|
||||
all: $(TARGETS)
|
||||
|
||||
$(TARGET_DIR)/otr_parse: otr_parse.o readotr.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
|
||||
- $(CC) -g $^ -o $@ -lgcrypt
|
||||
+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
|
||||
|
||||
$(TARGET_DIR)/otr_sesskeys: otr_sesskeys.o sesskeys.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
|
||||
- $(CC) -g $^ -o $@ -lgcrypt
|
||||
+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
|
||||
|
||||
$(TARGET_DIR)/otr_mackey: otr_mackey.o sesskeys.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
|
||||
- $(CC) -g $^ -o $@ -lgcrypt
|
||||
+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
|
||||
|
||||
$(TARGET_DIR)/otr_readforge: otr_readforge.o readotr.o sesskeys.o parse.o sha1hmac.o aes.o ctrmode.o $(LIBOTR_DIR)/libotr.a
|
||||
- $(CC) -g $^ -o $@ -lgcrypt
|
||||
+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
|
||||
|
||||
$(TARGET_DIR)/otr_modify: otr_modify.o readotr.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
|
||||
- $(CC) -g $^ -o $@ -lgcrypt
|
||||
+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
|
||||
|
||||
$(TARGET_DIR)/otr_remac: otr_remac.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
|
||||
- $(CC) -g $^ -o $@ -lgcrypt
|
||||
+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
|
||||
|
||||
$(LIBOTR_DIR)/libotr.a: FORCE
|
||||
- make -C $(LIBOTR_DIR) libotr.a
|
||||
+ gmake -C $(LIBOTR_DIR) libotr.a
|
||||
|
||||
install: all
|
||||
install -d $(INSTALLBINDIR)
|
18
security/gaim-otr/pkg-descr
Normal file
18
security/gaim-otr/pkg-descr
Normal file
@ -0,0 +1,18 @@
|
||||
Off-the-Record (OTR) Messaging allows you to have private
|
||||
conversations over instant messaging by providing:
|
||||
|
||||
* Encryption
|
||||
No one else can read your instant messages.
|
||||
* Authentication
|
||||
You are assured the correspondent is who you think it is.
|
||||
* Deniability
|
||||
The messages you send do not have digital signatures that
|
||||
are checkable by a third party. Anyone can forge messages
|
||||
after a conversation to make them look like they came from
|
||||
you. However, during a conversation, your correspondent is
|
||||
assured the messages he sees are authentic and unmodified.
|
||||
* Perfect forward secrecy
|
||||
If you lose control of your private keys, no previous
|
||||
conversation is compromised.
|
||||
|
||||
WWW: http://www.cypherpunks.ca/otr/
|
7
security/gaim-otr/pkg-plist
Normal file
7
security/gaim-otr/pkg-plist
Normal file
@ -0,0 +1,7 @@
|
||||
lib/gaim/gaim-otr.so
|
||||
bin/otr_parse
|
||||
bin/otr_sesskeys
|
||||
bin/otr_mackey
|
||||
bin/otr_readforge
|
||||
bin/otr_modify
|
||||
bin/otr_remac
|
52
security/pidgin-otr/Makefile
Normal file
52
security/pidgin-otr/Makefile
Normal file
@ -0,0 +1,52 @@
|
||||
# New ports collection makefile for: Gaim-OTR
|
||||
# Date created: 2004-12-17
|
||||
# Whom: Conor McDermottroe <ports@mcdermottroe.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= otr
|
||||
PORTVERSION= 1.0.1
|
||||
CATEGORIES= security net
|
||||
MASTER_SITES= http://www.cypherpunks.ca/otr/
|
||||
PKGNAMEPREFIX= gaim-
|
||||
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@mcdermottroe.com
|
||||
COMMENT= Allows deniable private conversations using GAIM
|
||||
|
||||
BUILD_DEPENDS= ${X11BASE}/include/gaim/config.h:${PORTSDIR}/net/gaim \
|
||||
pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
RUN_DEPENDS= gaim:${PORTSDIR}/net/gaim
|
||||
LIB_DEPENDS= gpg-error:${PORTSDIR}/security/libgpg-error \
|
||||
gcrypt:${PORTSDIR}/security/libgcrypt
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= glib20 gtk20
|
||||
USE_REINPLACE= yes
|
||||
|
||||
MAN1= otr_toolkit.1
|
||||
MLINKS= otr_toolkit.1 otr_parse.1 \
|
||||
otr_toolkit.1 otr_sesskeys.1 \
|
||||
otr_toolkit.1 otr_mackey.1 \
|
||||
otr_toolkit.1 otr_readforge.1 \
|
||||
otr_toolkit.1 otr_modify.1 \
|
||||
otr_toolkit.1 otr_remac.1
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
|
||||
${WRKSRC}/gaim-otr/Makefile \
|
||||
${WRKSRC}/libotr/Makefile \
|
||||
${WRKSRC}/tools/Makefile
|
||||
${REINPLACE_CMD} -e "s|%%X11BASE%%|${X11BASE}|g" \
|
||||
${WRKSRC}/gaim-otr/Makefile
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/gaim-otr.so ${PREFIX}/lib/gaim
|
||||
${INSTALL_MAN} ${WRKSRC}/tools/otr_toolkit.1 ${PREFIX}/man/man1
|
||||
.for P in otr_parse otr_sesskeys otr_mackey otr_readforge otr_modify otr_remac
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${P} ${PREFIX}/bin
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
2
security/pidgin-otr/distinfo
Normal file
2
security/pidgin-otr/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (gaim-otr-1.0.1.tar.gz) = efc22af7c4a17448da75419bbaeb80d6
|
||||
SIZE (gaim-otr-1.0.1.tar.gz) = 76536
|
10
security/pidgin-otr/files/patch-Makefile
Normal file
10
security/pidgin-otr/files/patch-Makefile
Normal file
@ -0,0 +1,10 @@
|
||||
--- Makefile.bak Fri Dec 17 16:19:08 2004
|
||||
+++ Makefile Fri Dec 17 16:19:16 2004
|
||||
@@ -1,4 +1,4 @@
|
||||
all install clean distclean:
|
||||
- make -C libotr $@
|
||||
- make -C gaim-otr $@
|
||||
- make -C tools $@
|
||||
+ gmake -C libotr $@
|
||||
+ gmake -C gaim-otr $@
|
||||
+ gmake -C tools $@
|
22
security/pidgin-otr/files/patch-gaim-otr-Makefile
Normal file
22
security/pidgin-otr/files/patch-gaim-otr-Makefile
Normal file
@ -0,0 +1,22 @@
|
||||
--- gaim-otr/Makefile.bak Fri Dec 17 17:11:49 2004
|
||||
+++ gaim-otr/Makefile Fri Dec 17 17:12:57 2004
|
||||
@@ -1,5 +1,5 @@
|
||||
# Replace this with the path to the GAIM headers
|
||||
-GAIM_SOURCE ?= /usr/include/gaim
|
||||
+GAIM_SOURCE ?= %%X11BASE%%/include/gaim
|
||||
|
||||
# If you don't have pkg-config, put the appropriate -I entry on the next line
|
||||
GTK_HDRS ?= `pkg-config --cflags glib-2.0 gtk+-2.0`
|
||||
@@ -19,10 +19,10 @@
|
||||
all: $(TARGET)
|
||||
|
||||
$(TARGET): otr-plugin.o ui.o dialogs.o $(LIBOTR_DIR)/libotr.a
|
||||
- $(CC) -g -shared -module -avoid-version $^ -o $@ -lgcrypt
|
||||
+ $(CC) -g -shared -module -avoid-version -L %%LOCALBASE%%/lib $^ -o $@ -lgcrypt
|
||||
|
||||
$(LIBOTR_DIR)/libotr.a: FORCE
|
||||
- make -C $(LIBOTR_DIR) libotr.a
|
||||
+ gmake -C $(LIBOTR_DIR) libotr.a
|
||||
|
||||
install: all
|
||||
install -d $(INSTALLDIR)
|
9
security/pidgin-otr/files/patch-libotr-Makefile
Normal file
9
security/pidgin-otr/files/patch-libotr-Makefile
Normal file
@ -0,0 +1,9 @@
|
||||
--- libotr/Makefile.bak Fri Dec 17 16:31:14 2004
|
||||
+++ libotr/Makefile Fri Dec 17 16:31:53 2004
|
||||
@@ -1,5 +1,5 @@
|
||||
CC ?= gcc
|
||||
-override CFLAGS += -g -Wall -fPIC
|
||||
+CFLAGS += -g -Wall -fPIC -I %%LOCALBASE%%/include
|
||||
LDFLAGS ?= -lgcrypt -g
|
||||
|
||||
all: libotr.a
|
11
security/pidgin-otr/files/patch-libotr-context
Normal file
11
security/pidgin-otr/files/patch-libotr-context
Normal file
@ -0,0 +1,11 @@
|
||||
--- libotr/context.h.bak Fri Dec 17 17:14:42 2004
|
||||
+++ libotr/context.h Fri Dec 17 17:14:53 2004
|
||||
@@ -20,7 +20,7 @@
|
||||
#ifndef __CONTEXT_H__
|
||||
#define __CONTEXT_H__
|
||||
|
||||
-#include "gcrypt.h"
|
||||
+#include <gcrypt.h>
|
||||
#include "dh.h"
|
||||
|
||||
typedef enum {
|
11
security/pidgin-otr/files/patch-libotr-privkey
Normal file
11
security/pidgin-otr/files/patch-libotr-privkey
Normal file
@ -0,0 +1,11 @@
|
||||
--- libotr/privkey.c.bak Fri Dec 17 16:24:41 2004
|
||||
+++ libotr/privkey.c Fri Dec 17 16:24:54 2004
|
||||
@@ -24,7 +24,7 @@
|
||||
#include <sys/stat.h>
|
||||
|
||||
/* libgcrypt headers */
|
||||
-#include "gcrypt.h"
|
||||
+#include <gcrypt.h>
|
||||
|
||||
/* libotr headers */
|
||||
#include "proto.h"
|
44
security/pidgin-otr/files/patch-tools-Makefile
Normal file
44
security/pidgin-otr/files/patch-tools-Makefile
Normal file
@ -0,0 +1,44 @@
|
||||
--- tools/Makefile.bak Fri Dec 17 17:18:13 2004
|
||||
+++ tools/Makefile Fri Dec 17 17:20:57 2004
|
||||
@@ -9,7 +9,7 @@
|
||||
INSTALLMANDIR = $(DESTDIR)/usr/share/man/man1
|
||||
|
||||
CC ?= gcc
|
||||
-override CFLAGS += -g -Wall -I$(LIBOTR_DIR) -fPIC
|
||||
+override CFLAGS += -g -Wall -I$(LIBOTR_DIR) -I%%LOCALBASE%%/include -L%%LOCALBASE%%/lib -fPIC
|
||||
|
||||
TARGETS = $(TARGET_DIR)/otr_parse \
|
||||
$(TARGET_DIR)/otr_sesskeys \
|
||||
@@ -21,25 +21,25 @@
|
||||
all: $(TARGETS)
|
||||
|
||||
$(TARGET_DIR)/otr_parse: otr_parse.o readotr.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
|
||||
- $(CC) -g $^ -o $@ -lgcrypt
|
||||
+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
|
||||
|
||||
$(TARGET_DIR)/otr_sesskeys: otr_sesskeys.o sesskeys.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
|
||||
- $(CC) -g $^ -o $@ -lgcrypt
|
||||
+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
|
||||
|
||||
$(TARGET_DIR)/otr_mackey: otr_mackey.o sesskeys.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
|
||||
- $(CC) -g $^ -o $@ -lgcrypt
|
||||
+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
|
||||
|
||||
$(TARGET_DIR)/otr_readforge: otr_readforge.o readotr.o sesskeys.o parse.o sha1hmac.o aes.o ctrmode.o $(LIBOTR_DIR)/libotr.a
|
||||
- $(CC) -g $^ -o $@ -lgcrypt
|
||||
+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
|
||||
|
||||
$(TARGET_DIR)/otr_modify: otr_modify.o readotr.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
|
||||
- $(CC) -g $^ -o $@ -lgcrypt
|
||||
+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
|
||||
|
||||
$(TARGET_DIR)/otr_remac: otr_remac.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
|
||||
- $(CC) -g $^ -o $@ -lgcrypt
|
||||
+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
|
||||
|
||||
$(LIBOTR_DIR)/libotr.a: FORCE
|
||||
- make -C $(LIBOTR_DIR) libotr.a
|
||||
+ gmake -C $(LIBOTR_DIR) libotr.a
|
||||
|
||||
install: all
|
||||
install -d $(INSTALLBINDIR)
|
18
security/pidgin-otr/pkg-descr
Normal file
18
security/pidgin-otr/pkg-descr
Normal file
@ -0,0 +1,18 @@
|
||||
Off-the-Record (OTR) Messaging allows you to have private
|
||||
conversations over instant messaging by providing:
|
||||
|
||||
* Encryption
|
||||
No one else can read your instant messages.
|
||||
* Authentication
|
||||
You are assured the correspondent is who you think it is.
|
||||
* Deniability
|
||||
The messages you send do not have digital signatures that
|
||||
are checkable by a third party. Anyone can forge messages
|
||||
after a conversation to make them look like they came from
|
||||
you. However, during a conversation, your correspondent is
|
||||
assured the messages he sees are authentic and unmodified.
|
||||
* Perfect forward secrecy
|
||||
If you lose control of your private keys, no previous
|
||||
conversation is compromised.
|
||||
|
||||
WWW: http://www.cypherpunks.ca/otr/
|
7
security/pidgin-otr/pkg-plist
Normal file
7
security/pidgin-otr/pkg-plist
Normal file
@ -0,0 +1,7 @@
|
||||
lib/gaim/gaim-otr.so
|
||||
bin/otr_parse
|
||||
bin/otr_sesskeys
|
||||
bin/otr_mackey
|
||||
bin/otr_readforge
|
||||
bin/otr_modify
|
||||
bin/otr_remac
|
Loading…
Reference in New Issue
Block a user