Fix build on alpha.

Submitted by:	gallatin
This commit is contained in:
Will Andrews 2002-05-20 06:17:57 +00:00
parent 427b2586a2
commit 5b52f8b8f7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=59512
21 changed files with 371 additions and 0 deletions

View File

@ -59,6 +59,11 @@ post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
@${ECHO} "exit 0" >> ${WRKSRC}/mkpamserv
.if ${MACHINE_ARCH} == "alpha"
pre-configure:
${PERL} -pi -e "s@-O2@-O@g" ${WRKSRC}/admin/acinclude.m4.in
.endif
post-configure:
${PERL} -pi -e "s@444@644@g" ${WRKSRC}/kdesktop/init/Templates/Makefile

View File

@ -0,0 +1,16 @@
--- ksysguard/ksysguardd/FreeBSD/apm.c.orig Sat May 4 16:53:10 2002
+++ ksysguard/ksysguardd/FreeBSD/apm.c Sat May 4 16:53:42 2002
@@ -18,7 +18,7 @@
$Id: apm.c,v 1.2 2001/09/18 14:03:53 tokoe Exp $
*/
-
+#ifdef __i386__
#include <fcntl.h>
#include <machine/apm_bios.h>
#include <stdio.h>
@@ -96,3 +96,4 @@
{
fprintf(CurrentClient, "Remaining battery time\t0\t0\tmin\n");
}
+#endif /* __i386__ */

View File

@ -0,0 +1,32 @@
--- ksysguard/ksysguardd/modules.h.orig Sat May 4 16:49:24 2002
+++ ksysguard/ksysguardd/modules.h Sat May 4 16:52:34 2002
@@ -45,7 +45,9 @@
#include "CPU.h"
#include "Memory.h"
#include "ProcessList.h"
+#ifdef __i386__
#include "apm.h"
+#endif
#include "diskstat.h"
#include "loadavg.h"
#include "logfile.h"
@@ -104,13 +106,19 @@
{ "CpuInfo", initCpuInfo, exitCpuInfo, updateCpuInfo, NULLVVFUNC },
{ "Memory", initMemory, exitMemory, updateMemory, NULLVVFUNC },
{ "ProcessList", initProcessList, exitProcessList, updateProcessList, NULLVVFUNC },
+#ifdef __i386__
{ "Apm", initApm, exitApm, updateApm, NULLVVFUNC },
+#endif
{ "DiskStat", initDiskStat, exitDiskStat, updateDiskStat, checkDiskStat },
{ "LoadAvg", initLoadAvg, exitLoadAvg, updateLoadAvg, NULLVVFUNC },
{ "LogFile", initLogFile, exitLogFile, NULLVVFUNC, NULLVVFUNC },
{ "NetDev", initNetDev, exitNetDev, updateNetDev, checkNetDev },
};
+#ifdef __i386__
#define NUM_MODULES 8
+#else
+#define NUM_MODULES 7
+#endif
#endif /* OSTYPE_FreeBSD */
#ifdef OSTYPE_Solaris

View File

@ -59,6 +59,11 @@ post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
@${ECHO} "exit 0" >> ${WRKSRC}/mkpamserv
.if ${MACHINE_ARCH} == "alpha"
pre-configure:
${PERL} -pi -e "s@-O2@-O@g" ${WRKSRC}/admin/acinclude.m4.in
.endif
post-configure:
${PERL} -pi -e "s@444@644@g" ${WRKSRC}/kdesktop/init/Templates/Makefile

View File

@ -0,0 +1,16 @@
--- ksysguard/ksysguardd/FreeBSD/apm.c.orig Sat May 4 16:53:10 2002
+++ ksysguard/ksysguardd/FreeBSD/apm.c Sat May 4 16:53:42 2002
@@ -18,7 +18,7 @@
$Id: apm.c,v 1.2 2001/09/18 14:03:53 tokoe Exp $
*/
-
+#ifdef __i386__
#include <fcntl.h>
#include <machine/apm_bios.h>
#include <stdio.h>
@@ -96,3 +96,4 @@
{
fprintf(CurrentClient, "Remaining battery time\t0\t0\tmin\n");
}
+#endif /* __i386__ */

View File

@ -0,0 +1,32 @@
--- ksysguard/ksysguardd/modules.h.orig Sat May 4 16:49:24 2002
+++ ksysguard/ksysguardd/modules.h Sat May 4 16:52:34 2002
@@ -45,7 +45,9 @@
#include "CPU.h"
#include "Memory.h"
#include "ProcessList.h"
+#ifdef __i386__
#include "apm.h"
+#endif
#include "diskstat.h"
#include "loadavg.h"
#include "logfile.h"
@@ -104,13 +106,19 @@
{ "CpuInfo", initCpuInfo, exitCpuInfo, updateCpuInfo, NULLVVFUNC },
{ "Memory", initMemory, exitMemory, updateMemory, NULLVVFUNC },
{ "ProcessList", initProcessList, exitProcessList, updateProcessList, NULLVVFUNC },
+#ifdef __i386__
{ "Apm", initApm, exitApm, updateApm, NULLVVFUNC },
+#endif
{ "DiskStat", initDiskStat, exitDiskStat, updateDiskStat, checkDiskStat },
{ "LoadAvg", initLoadAvg, exitLoadAvg, updateLoadAvg, NULLVVFUNC },
{ "LogFile", initLogFile, exitLogFile, NULLVVFUNC, NULLVVFUNC },
{ "NetDev", initNetDev, exitNetDev, updateNetDev, checkNetDev },
};
+#ifdef __i386__
#define NUM_MODULES 8
+#else
+#define NUM_MODULES 7
+#endif
#endif /* OSTYPE_FreeBSD */
#ifdef OSTYPE_Solaris

View File

@ -59,6 +59,11 @@ post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
@${ECHO} "exit 0" >> ${WRKSRC}/mkpamserv
.if ${MACHINE_ARCH} == "alpha"
pre-configure:
${PERL} -pi -e "s@-O2@-O@g" ${WRKSRC}/admin/acinclude.m4.in
.endif
post-configure:
${PERL} -pi -e "s@444@644@g" ${WRKSRC}/kdesktop/init/Templates/Makefile

View File

@ -0,0 +1,16 @@
--- ksysguard/ksysguardd/FreeBSD/apm.c.orig Sat May 4 16:53:10 2002
+++ ksysguard/ksysguardd/FreeBSD/apm.c Sat May 4 16:53:42 2002
@@ -18,7 +18,7 @@
$Id: apm.c,v 1.2 2001/09/18 14:03:53 tokoe Exp $
*/
-
+#ifdef __i386__
#include <fcntl.h>
#include <machine/apm_bios.h>
#include <stdio.h>
@@ -96,3 +96,4 @@
{
fprintf(CurrentClient, "Remaining battery time\t0\t0\tmin\n");
}
+#endif /* __i386__ */

View File

@ -0,0 +1,32 @@
--- ksysguard/ksysguardd/modules.h.orig Sat May 4 16:49:24 2002
+++ ksysguard/ksysguardd/modules.h Sat May 4 16:52:34 2002
@@ -45,7 +45,9 @@
#include "CPU.h"
#include "Memory.h"
#include "ProcessList.h"
+#ifdef __i386__
#include "apm.h"
+#endif
#include "diskstat.h"
#include "loadavg.h"
#include "logfile.h"
@@ -104,13 +106,19 @@
{ "CpuInfo", initCpuInfo, exitCpuInfo, updateCpuInfo, NULLVVFUNC },
{ "Memory", initMemory, exitMemory, updateMemory, NULLVVFUNC },
{ "ProcessList", initProcessList, exitProcessList, updateProcessList, NULLVVFUNC },
+#ifdef __i386__
{ "Apm", initApm, exitApm, updateApm, NULLVVFUNC },
+#endif
{ "DiskStat", initDiskStat, exitDiskStat, updateDiskStat, checkDiskStat },
{ "LoadAvg", initLoadAvg, exitLoadAvg, updateLoadAvg, NULLVVFUNC },
{ "LogFile", initLogFile, exitLogFile, NULLVVFUNC, NULLVVFUNC },
{ "NetDev", initNetDev, exitNetDev, updateNetDev, checkNetDev },
};
+#ifdef __i386__
#define NUM_MODULES 8
+#else
+#define NUM_MODULES 7
+#endif
#endif /* OSTYPE_FreeBSD */
#ifdef OSTYPE_Solaris

View File

@ -59,6 +59,11 @@ post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
@${ECHO} "exit 0" >> ${WRKSRC}/mkpamserv
.if ${MACHINE_ARCH} == "alpha"
pre-configure:
${PERL} -pi -e "s@-O2@-O@g" ${WRKSRC}/admin/acinclude.m4.in
.endif
post-configure:
${PERL} -pi -e "s@444@644@g" ${WRKSRC}/kdesktop/init/Templates/Makefile

View File

@ -0,0 +1,16 @@
--- ksysguard/ksysguardd/FreeBSD/apm.c.orig Sat May 4 16:53:10 2002
+++ ksysguard/ksysguardd/FreeBSD/apm.c Sat May 4 16:53:42 2002
@@ -18,7 +18,7 @@
$Id: apm.c,v 1.2 2001/09/18 14:03:53 tokoe Exp $
*/
-
+#ifdef __i386__
#include <fcntl.h>
#include <machine/apm_bios.h>
#include <stdio.h>
@@ -96,3 +96,4 @@
{
fprintf(CurrentClient, "Remaining battery time\t0\t0\tmin\n");
}
+#endif /* __i386__ */

View File

@ -0,0 +1,32 @@
--- ksysguard/ksysguardd/modules.h.orig Sat May 4 16:49:24 2002
+++ ksysguard/ksysguardd/modules.h Sat May 4 16:52:34 2002
@@ -45,7 +45,9 @@
#include "CPU.h"
#include "Memory.h"
#include "ProcessList.h"
+#ifdef __i386__
#include "apm.h"
+#endif
#include "diskstat.h"
#include "loadavg.h"
#include "logfile.h"
@@ -104,13 +106,19 @@
{ "CpuInfo", initCpuInfo, exitCpuInfo, updateCpuInfo, NULLVVFUNC },
{ "Memory", initMemory, exitMemory, updateMemory, NULLVVFUNC },
{ "ProcessList", initProcessList, exitProcessList, updateProcessList, NULLVVFUNC },
+#ifdef __i386__
{ "Apm", initApm, exitApm, updateApm, NULLVVFUNC },
+#endif
{ "DiskStat", initDiskStat, exitDiskStat, updateDiskStat, checkDiskStat },
{ "LoadAvg", initLoadAvg, exitLoadAvg, updateLoadAvg, NULLVVFUNC },
{ "LogFile", initLogFile, exitLogFile, NULLVVFUNC, NULLVVFUNC },
{ "NetDev", initNetDev, exitNetDev, updateNetDev, checkNetDev },
};
+#ifdef __i386__
#define NUM_MODULES 8
+#else
+#define NUM_MODULES 7
+#endif
#endif /* OSTYPE_FreeBSD */
#ifdef OSTYPE_Solaris

View File

@ -59,6 +59,11 @@ post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
@${ECHO} "exit 0" >> ${WRKSRC}/mkpamserv
.if ${MACHINE_ARCH} == "alpha"
pre-configure:
${PERL} -pi -e "s@-O2@-O@g" ${WRKSRC}/admin/acinclude.m4.in
.endif
post-configure:
${PERL} -pi -e "s@444@644@g" ${WRKSRC}/kdesktop/init/Templates/Makefile

View File

@ -0,0 +1,16 @@
--- ksysguard/ksysguardd/FreeBSD/apm.c.orig Sat May 4 16:53:10 2002
+++ ksysguard/ksysguardd/FreeBSD/apm.c Sat May 4 16:53:42 2002
@@ -18,7 +18,7 @@
$Id: apm.c,v 1.2 2001/09/18 14:03:53 tokoe Exp $
*/
-
+#ifdef __i386__
#include <fcntl.h>
#include <machine/apm_bios.h>
#include <stdio.h>
@@ -96,3 +96,4 @@
{
fprintf(CurrentClient, "Remaining battery time\t0\t0\tmin\n");
}
+#endif /* __i386__ */

View File

@ -0,0 +1,32 @@
--- ksysguard/ksysguardd/modules.h.orig Sat May 4 16:49:24 2002
+++ ksysguard/ksysguardd/modules.h Sat May 4 16:52:34 2002
@@ -45,7 +45,9 @@
#include "CPU.h"
#include "Memory.h"
#include "ProcessList.h"
+#ifdef __i386__
#include "apm.h"
+#endif
#include "diskstat.h"
#include "loadavg.h"
#include "logfile.h"
@@ -104,13 +106,19 @@
{ "CpuInfo", initCpuInfo, exitCpuInfo, updateCpuInfo, NULLVVFUNC },
{ "Memory", initMemory, exitMemory, updateMemory, NULLVVFUNC },
{ "ProcessList", initProcessList, exitProcessList, updateProcessList, NULLVVFUNC },
+#ifdef __i386__
{ "Apm", initApm, exitApm, updateApm, NULLVVFUNC },
+#endif
{ "DiskStat", initDiskStat, exitDiskStat, updateDiskStat, checkDiskStat },
{ "LoadAvg", initLoadAvg, exitLoadAvg, updateLoadAvg, NULLVVFUNC },
{ "LogFile", initLogFile, exitLogFile, NULLVVFUNC, NULLVVFUNC },
{ "NetDev", initNetDev, exitNetDev, updateNetDev, checkNetDev },
};
+#ifdef __i386__
#define NUM_MODULES 8
+#else
+#define NUM_MODULES 7
+#endif
#endif /* OSTYPE_FreeBSD */
#ifdef OSTYPE_Solaris

View File

@ -59,6 +59,11 @@ post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
@${ECHO} "exit 0" >> ${WRKSRC}/mkpamserv
.if ${MACHINE_ARCH} == "alpha"
pre-configure:
${PERL} -pi -e "s@-O2@-O@g" ${WRKSRC}/admin/acinclude.m4.in
.endif
post-configure:
${PERL} -pi -e "s@444@644@g" ${WRKSRC}/kdesktop/init/Templates/Makefile

View File

@ -0,0 +1,16 @@
--- ksysguard/ksysguardd/FreeBSD/apm.c.orig Sat May 4 16:53:10 2002
+++ ksysguard/ksysguardd/FreeBSD/apm.c Sat May 4 16:53:42 2002
@@ -18,7 +18,7 @@
$Id: apm.c,v 1.2 2001/09/18 14:03:53 tokoe Exp $
*/
-
+#ifdef __i386__
#include <fcntl.h>
#include <machine/apm_bios.h>
#include <stdio.h>
@@ -96,3 +96,4 @@
{
fprintf(CurrentClient, "Remaining battery time\t0\t0\tmin\n");
}
+#endif /* __i386__ */

View File

@ -0,0 +1,32 @@
--- ksysguard/ksysguardd/modules.h.orig Sat May 4 16:49:24 2002
+++ ksysguard/ksysguardd/modules.h Sat May 4 16:52:34 2002
@@ -45,7 +45,9 @@
#include "CPU.h"
#include "Memory.h"
#include "ProcessList.h"
+#ifdef __i386__
#include "apm.h"
+#endif
#include "diskstat.h"
#include "loadavg.h"
#include "logfile.h"
@@ -104,13 +106,19 @@
{ "CpuInfo", initCpuInfo, exitCpuInfo, updateCpuInfo, NULLVVFUNC },
{ "Memory", initMemory, exitMemory, updateMemory, NULLVVFUNC },
{ "ProcessList", initProcessList, exitProcessList, updateProcessList, NULLVVFUNC },
+#ifdef __i386__
{ "Apm", initApm, exitApm, updateApm, NULLVVFUNC },
+#endif
{ "DiskStat", initDiskStat, exitDiskStat, updateDiskStat, checkDiskStat },
{ "LoadAvg", initLoadAvg, exitLoadAvg, updateLoadAvg, NULLVVFUNC },
{ "LogFile", initLogFile, exitLogFile, NULLVVFUNC, NULLVVFUNC },
{ "NetDev", initNetDev, exitNetDev, updateNetDev, checkNetDev },
};
+#ifdef __i386__
#define NUM_MODULES 8
+#else
+#define NUM_MODULES 7
+#endif
#endif /* OSTYPE_FreeBSD */
#ifdef OSTYPE_Solaris

View File

@ -59,6 +59,11 @@ post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
@${ECHO} "exit 0" >> ${WRKSRC}/mkpamserv
.if ${MACHINE_ARCH} == "alpha"
pre-configure:
${PERL} -pi -e "s@-O2@-O@g" ${WRKSRC}/admin/acinclude.m4.in
.endif
post-configure:
${PERL} -pi -e "s@444@644@g" ${WRKSRC}/kdesktop/init/Templates/Makefile

View File

@ -0,0 +1,16 @@
--- ksysguard/ksysguardd/FreeBSD/apm.c.orig Sat May 4 16:53:10 2002
+++ ksysguard/ksysguardd/FreeBSD/apm.c Sat May 4 16:53:42 2002
@@ -18,7 +18,7 @@
$Id: apm.c,v 1.2 2001/09/18 14:03:53 tokoe Exp $
*/
-
+#ifdef __i386__
#include <fcntl.h>
#include <machine/apm_bios.h>
#include <stdio.h>
@@ -96,3 +96,4 @@
{
fprintf(CurrentClient, "Remaining battery time\t0\t0\tmin\n");
}
+#endif /* __i386__ */

View File

@ -0,0 +1,32 @@
--- ksysguard/ksysguardd/modules.h.orig Sat May 4 16:49:24 2002
+++ ksysguard/ksysguardd/modules.h Sat May 4 16:52:34 2002
@@ -45,7 +45,9 @@
#include "CPU.h"
#include "Memory.h"
#include "ProcessList.h"
+#ifdef __i386__
#include "apm.h"
+#endif
#include "diskstat.h"
#include "loadavg.h"
#include "logfile.h"
@@ -104,13 +106,19 @@
{ "CpuInfo", initCpuInfo, exitCpuInfo, updateCpuInfo, NULLVVFUNC },
{ "Memory", initMemory, exitMemory, updateMemory, NULLVVFUNC },
{ "ProcessList", initProcessList, exitProcessList, updateProcessList, NULLVVFUNC },
+#ifdef __i386__
{ "Apm", initApm, exitApm, updateApm, NULLVVFUNC },
+#endif
{ "DiskStat", initDiskStat, exitDiskStat, updateDiskStat, checkDiskStat },
{ "LoadAvg", initLoadAvg, exitLoadAvg, updateLoadAvg, NULLVVFUNC },
{ "LogFile", initLogFile, exitLogFile, NULLVVFUNC, NULLVVFUNC },
{ "NetDev", initNetDev, exitNetDev, updateNetDev, checkNetDev },
};
+#ifdef __i386__
#define NUM_MODULES 8
+#else
+#define NUM_MODULES 7
+#endif
#endif /* OSTYPE_FreeBSD */
#ifdef OSTYPE_Solaris