Add a patch to fix the build with recent ruby. It has already been

submitted to the SWIG development team.
This commit is contained in:
Akinori MUSHA 2001-06-09 03:13:36 +00:00
parent accf858209
commit 5b30ecf85d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=43687
6 changed files with 69 additions and 3 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= swig
PORTVERSION= ${VER}a5
PORTREVISION= 5
PORTREVISION= 6
CATEGORIES= devel perl5 python ruby tcl82
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.rge.com/pub/languages/swig/ \

View File

@ -0,0 +1,22 @@
--- configure.orig Sat Sep 23 02:14:04 2000
+++ configure Sat Jun 9 12:08:08 2001
@@ -2684,7 +2684,7 @@
echo $ac_n "checking for Ruby header files""... $ac_c" 1>&6
echo "configure:2686: checking for Ruby header files" >&5
if test -n "$RUBY"; then
- RUBYDIR=`($RUBY -rmkmf -e 'print $archdir') 2>/dev/null`
+ RUBYDIR=`($RUBY -rmkmf -e 'print Config::CONFIG["archdir"] || $archdir') 2>/dev/null`
if test "$RUBYDIR" != ""; then
dirs="$RUBYDIR"
RUBYINCLUDE=none
--- configure.in.orig Sat Sep 23 02:14:03 2000
+++ configure.in Sat Jun 9 11:55:20 2001
@@ -631,7 +631,7 @@
fi
AC_MSG_CHECKING(for Ruby header files)
if test -n "$RUBY"; then
- RUBYDIR=`($RUBY -rmkmf -e 'print $archdir') 2>/dev/null`
+ RUBYDIR=`($RUBY -rmkmf -e 'print Config::CONFIG[["archdir"]] || $archdir') 2>/dev/null`
if test "$RUBYDIR" != ""; then
dirs="$RUBYDIR"
RUBYINCLUDE=none

View File

@ -7,7 +7,7 @@
PORTNAME= swig
PORTVERSION= ${VER}a5
PORTREVISION= 5
PORTREVISION= 6
CATEGORIES= devel perl5 python ruby tcl82
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.rge.com/pub/languages/swig/ \

View File

@ -0,0 +1,22 @@
--- configure.orig Sat Sep 23 02:14:04 2000
+++ configure Sat Jun 9 12:08:08 2001
@@ -2684,7 +2684,7 @@
echo $ac_n "checking for Ruby header files""... $ac_c" 1>&6
echo "configure:2686: checking for Ruby header files" >&5
if test -n "$RUBY"; then
- RUBYDIR=`($RUBY -rmkmf -e 'print $archdir') 2>/dev/null`
+ RUBYDIR=`($RUBY -rmkmf -e 'print Config::CONFIG["archdir"] || $archdir') 2>/dev/null`
if test "$RUBYDIR" != ""; then
dirs="$RUBYDIR"
RUBYINCLUDE=none
--- configure.in.orig Sat Sep 23 02:14:03 2000
+++ configure.in Sat Jun 9 11:55:20 2001
@@ -631,7 +631,7 @@
fi
AC_MSG_CHECKING(for Ruby header files)
if test -n "$RUBY"; then
- RUBYDIR=`($RUBY -rmkmf -e 'print $archdir') 2>/dev/null`
+ RUBYDIR=`($RUBY -rmkmf -e 'print Config::CONFIG[["archdir"]] || $archdir') 2>/dev/null`
if test "$RUBYDIR" != ""; then
dirs="$RUBYDIR"
RUBYINCLUDE=none

View File

@ -7,7 +7,7 @@
PORTNAME= swig
PORTVERSION= ${VER}a5
PORTREVISION= 5
PORTREVISION= 6
CATEGORIES= devel perl5 python ruby tcl82
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.rge.com/pub/languages/swig/ \

View File

@ -0,0 +1,22 @@
--- configure.orig Sat Sep 23 02:14:04 2000
+++ configure Sat Jun 9 12:08:08 2001
@@ -2684,7 +2684,7 @@
echo $ac_n "checking for Ruby header files""... $ac_c" 1>&6
echo "configure:2686: checking for Ruby header files" >&5
if test -n "$RUBY"; then
- RUBYDIR=`($RUBY -rmkmf -e 'print $archdir') 2>/dev/null`
+ RUBYDIR=`($RUBY -rmkmf -e 'print Config::CONFIG["archdir"] || $archdir') 2>/dev/null`
if test "$RUBYDIR" != ""; then
dirs="$RUBYDIR"
RUBYINCLUDE=none
--- configure.in.orig Sat Sep 23 02:14:03 2000
+++ configure.in Sat Jun 9 11:55:20 2001
@@ -631,7 +631,7 @@
fi
AC_MSG_CHECKING(for Ruby header files)
if test -n "$RUBY"; then
- RUBYDIR=`($RUBY -rmkmf -e 'print $archdir') 2>/dev/null`
+ RUBYDIR=`($RUBY -rmkmf -e 'print Config::CONFIG[["archdir"]] || $archdir') 2>/dev/null`
if test "$RUBYDIR" != ""; then
dirs="$RUBYDIR"
RUBYINCLUDE=none