Paraphrased from the PR: fixes MASTER_SITES, respects CC/CFLAGS, doesn't
install GPL COPYING, and adds a WWW line to pkg/DESCR. PR: 19764 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
This commit is contained in:
parent
5044aa7bf3
commit
5b2537ba2e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30348
@ -8,22 +8,26 @@
|
||||
PORTNAME= chpp
|
||||
PORTVERSION= 0.3.5
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= andy
|
||||
MASTER_SITES= http://trick.unix.cslab.tuwien.ac.at/~chpp/files/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --libdir=${PREFIX}/share
|
||||
|
||||
EXAMPLES_DIR= ${PREFIX}/share/examples/chpp
|
||||
DOCS_DIR= ${PREFIX}/share/doc/chpp
|
||||
|
||||
post-install:
|
||||
@ ${MKDIR} ${PREFIX}/share/examples/chpp
|
||||
@ cd ${WRKSRC}/test; tar -cf - * | \
|
||||
( cd ${PREFIX}/share/examples/chpp; tar --unlink -xf - )
|
||||
@ ${MKDIR} ${PREFIX}/share/doc/chpp
|
||||
@${MKDIR} ${EXAMPLES_DIR}
|
||||
${TAR} -C ${WRKSRC}/test -cf - . | \
|
||||
${TAR} -C ${EXAMPLES_DIR} --unlink -xf -
|
||||
@find ${EXAMPLES_DIR} | xargs ${CHOWN} ${SHAREOWN}:${SHAREGRP}
|
||||
@find ${EXAMPLES_DIR} -type f | xargs ${CHMOD} ${SHAREMODE}
|
||||
.if !defined(NOPORTDOCS)
|
||||
.for file in AUTHORS COPYING NEWS README
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/chpp
|
||||
@${MKDIR} ${DOCS_DIR}
|
||||
.for file in AUTHORS NEWS README
|
||||
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCS_DIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
|
24
textproc/chpp/files/patch-ab
Normal file
24
textproc/chpp/files/patch-ab
Normal file
@ -0,0 +1,24 @@
|
||||
--- Makefile.in.orig Tue Feb 9 23:02:50 1999
|
||||
+++ Makefile.in Tue Jul 4 04:03:19 2000
|
||||
@@ -471,10 +471,10 @@
|
||||
|
||||
|
||||
gc/gc.a :
|
||||
- ( cd gc ; make gc.a )
|
||||
+ ( cd gc ; $(MAKE) gc.a )
|
||||
|
||||
dist-hook :
|
||||
- ( cd gc ; make clean )
|
||||
+ ( cd gc ; $(MAKE) clean )
|
||||
cp -dR gc $(distdir)
|
||||
rm -rf `find $(distdir)/gc -name CVS`
|
||||
mkdir $(distdir)/test
|
||||
@@ -484,7 +484,7 @@
|
||||
rm -rf `find $(distdir)/test -name CVS`
|
||||
|
||||
clean-gc :
|
||||
- ( cd gc ; make clean )
|
||||
+ ( cd gc ; $(MAKE) clean )
|
||||
|
||||
clean : clean-gc
|
||||
|
56
textproc/chpp/files/patch-ac
Normal file
56
textproc/chpp/files/patch-ac
Normal file
@ -0,0 +1,56 @@
|
||||
--- gc/Makefile.orig Tue Feb 9 23:03:04 1999
|
||||
+++ gc/Makefile Tue Jul 4 04:04:14 2000
|
||||
@@ -8,15 +8,15 @@
|
||||
# c++ interface to gc.a
|
||||
# cord/de - builds dumb editor based on cords.
|
||||
ABI_FLAG=
|
||||
-CC=cc $(ABI_FLAG)
|
||||
-CXX=CC $(ABI_FLAG)
|
||||
+CC+= $(ABI_FLAG)
|
||||
+CXX+= $(ABI_FLAG)
|
||||
AS=as $(ABI_FLAG)
|
||||
# The above doesn't work with gas, which doesn't run cpp.
|
||||
# Define AS as `gcc -c -x assembler-with-cpp' instead.
|
||||
# Under Irix 6, you will have to specify the ABI for as if you specify
|
||||
# it for the C compiler.
|
||||
|
||||
-CFLAGS= -O -DNO_SIGNALS -DALL_INTERIOR_POINTERS -DNO_EXECUTE_PERMISSION -DSILENT
|
||||
+CFLAGS+= -DNO_SIGNALS -DALL_INTERIOR_POINTERS -DNO_EXECUTE_PERMISSION -DSILENT
|
||||
|
||||
# Setjmp_test may yield overly optimistic results when compiled
|
||||
# without optimization.
|
||||
@@ -98,12 +98,12 @@
|
||||
|
||||
|
||||
|
||||
-LIBGC_CFLAGS= -O -DNO_SIGNALS -DSILENT \
|
||||
+LIBGC_CFLAGS= -DNO_SIGNALS -DSILENT \
|
||||
-DREDIRECT_MALLOC=GC_malloc_uncollectable \
|
||||
-DDONT_ADD_BYTE_AT_END -DALL_INTERIOR_POINTERS
|
||||
# Flags for building libgc.a -- the last two are required.
|
||||
|
||||
-CXXFLAGS= $(CFLAGS)
|
||||
+#CXXFLAGS= $(CFLAGS)
|
||||
AR= ar
|
||||
RANLIB= ranlib
|
||||
|
||||
@@ -168,8 +168,8 @@
|
||||
all: gc.a gctest
|
||||
|
||||
pcr: PCR-Makefile gc_private.h gc_hdrs.h gc.h config.h mach_dep.o $(SRCS)
|
||||
- make -f PCR-Makefile depend
|
||||
- make -f PCR-Makefile
|
||||
+ $(MAKE) -f PCR-Makefile depend
|
||||
+ $(MAKE) -f PCR-Makefile
|
||||
|
||||
$(OBJS) test.o dyn_load.o dyn_load_sunos53.o: $(srcdir)/gc_priv.h $(srcdir)/gc_hdrs.h $(srcdir)/gc.h \
|
||||
$(srcdir)/config.h $(srcdir)/gc_typed.h Makefile
|
||||
@@ -189,7 +189,7 @@
|
||||
# ignore ranlib failure; that usually means it doesn't exist, and isn't needed
|
||||
|
||||
libgc.a:
|
||||
- make CFLAGS="$(LIBGC_CFLAGS)" clean gc.a gcc_support.o
|
||||
+ $(MAKE) CFLAGS="$(LIBGC_CFLAGS)" clean gc.a gcc_support.o
|
||||
mv gc.a libgc.a
|
||||
rm -f on_sparc_sunos5
|
||||
./if_mach SPARC SUNOS5 touch on_sparc_sunos5
|
@ -16,3 +16,5 @@ features:
|
||||
Most importantly, it provides support for complex data structures,
|
||||
namely lists and hashes (associative arrays), which can be nested
|
||||
arbitrarily.
|
||||
|
||||
WWW: http://trick.unix.cslab.tuwien.ac.at/~chpp/
|
||||
|
@ -12,7 +12,6 @@ share/chpp/include/strings.chh
|
||||
share/chpp/include/time.chh
|
||||
share/chpp/include/w3lib.chh
|
||||
share/doc/chpp/AUTHORS
|
||||
share/doc/chpp/COPYING
|
||||
share/doc/chpp/NEWS
|
||||
share/doc/chpp/README
|
||||
share/examples/chpp/regress/dotest
|
||||
@ -89,24 +88,24 @@ share/examples/chpp/website/tricks_l.jpg
|
||||
share/examples/chpp/website/tricks_s.jpg
|
||||
share/examples/chpp/website/tricks_s_g.jpg
|
||||
share/examples/chpp/website/tricks_t.chml
|
||||
@dirrm share/chpp/include
|
||||
@dirrm share/chpp
|
||||
@dirrm share/doc/chpp
|
||||
@dirrm share/examples/chpp/regress/array
|
||||
@dirrm share/examples/chpp/regress/arith
|
||||
@dirrm share/examples/chpp/regress/assoc
|
||||
@dirrm share/examples/chpp/regress/define
|
||||
@dirrm share/examples/chpp/regress/error
|
||||
@dirrm share/examples/chpp/regress/fileops
|
||||
@dirrm share/examples/chpp/regress/hanoi
|
||||
@dirrm share/examples/chpp/website
|
||||
@dirrm share/examples/chpp/tautogen
|
||||
@dirrm share/examples/chpp/regress/stringops
|
||||
@dirrm share/examples/chpp/regress/regex
|
||||
@dirrm share/examples/chpp/regress/metachar
|
||||
@dirrm share/examples/chpp/regress/loops
|
||||
@dirrm share/examples/chpp/regress/include/incdir/incdir2
|
||||
@dirrm share/examples/chpp/regress/include/incdir
|
||||
@dirrm share/examples/chpp/regress/include
|
||||
@dirrm share/examples/chpp/regress/loops
|
||||
@dirrm share/examples/chpp/regress/regex
|
||||
@dirrm share/examples/chpp/regress/metachar
|
||||
@dirrm share/examples/chpp/regress/stringops
|
||||
@dirrm share/examples/chpp/regress/hanoi
|
||||
@dirrm share/examples/chpp/regress/fileops
|
||||
@dirrm share/examples/chpp/regress/error
|
||||
@dirrm share/examples/chpp/regress/define
|
||||
@dirrm share/examples/chpp/regress/assoc
|
||||
@dirrm share/examples/chpp/regress/array
|
||||
@dirrm share/examples/chpp/regress/arith
|
||||
@dirrm share/examples/chpp/regress
|
||||
@dirrm share/examples/chpp/tautogen
|
||||
@dirrm share/examples/chpp/website
|
||||
@dirrm share/examples/chpp
|
||||
@dirrm share/doc/chpp
|
||||
@dirrm share/chpp/include
|
||||
@dirrm share/chpp
|
||||
|
Loading…
Reference in New Issue
Block a user