Initial Import of swish-e
SWISH-Enhanced is a fast, powerful, flexible, and easy to use system for indexing collections of Web pages or other text files. Key features include the ability to limit searches to certain HTML tags (META, TITLE, comments, etc.). The SWISH-E software is free, and includes a package of Perl programs that enable anyone who is authorized to create and maintain their own indexes (AutoSwish). SWISH-E is an enhanced version of SWISH, which was originally written by Kevin Hughes and modified and released with his permission. http://sunsite.berkeley.edu/SWISH-E/ PR: ports/5821 Submitted By: Daniel O'Connor
This commit is contained in:
parent
11a329e5b3
commit
5abcacf74e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=15494
31
www/swish-e/Makefile
Normal file
31
www/swish-e/Makefile
Normal file
@ -0,0 +1,31 @@
|
||||
# New ports collection makefile for: swish-e
|
||||
# Version required: 1.2.4
|
||||
# Date created: 23 Feb 98
|
||||
# Whom: Daniel O'Connor <doconnor@gsoft.com.au>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= swish-efiles.1.2.4
|
||||
PKGNAME= swish-e-1.2.4
|
||||
CATEGORIES= www textproc
|
||||
MASTER_SITES= ftp://sunsite.berkeley.edu/pub/swish-e/
|
||||
|
||||
MAINTAINER= doconnor@gsoft.com.au
|
||||
|
||||
WRKSRC= ${WRKDIR}/src
|
||||
USE_GMAKE= yes
|
||||
|
||||
post-patch:
|
||||
|
||||
${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.pre_sed
|
||||
${SED} -e 's#/vol/moby/moby_a/gnu/sun4_sunos5.1/bin/gcc#${CC}#' \
|
||||
-e 's#\"-g\"#\"${CFLAGS}\"#g' \
|
||||
-e 's#CFLAGS= -O2#CFLAGS = \"${CFLAGS}\"#' \
|
||||
${WRKSRC}/Makefile.pre_sed >> ${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
|
||||
$(INSTALL_PROGRAM) ${WRKSRC}/swish-e ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
1
www/swish-e/distinfo
Normal file
1
www/swish-e/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (swish-efiles.1.2.4.tar.gz) = f6c2ec409aedcbf0b2efee0a40c2e027
|
38
www/swish-e/files/patch-aa
Normal file
38
www/swish-e/files/patch-aa
Normal file
@ -0,0 +1,38 @@
|
||||
--- fs.c.old Fri Nov 27 13:30:13 1998
|
||||
+++ fs.c Fri Nov 27 13:32:19 1998
|
||||
@@ -539,23 +539,28 @@
|
||||
int ishtml(filename)
|
||||
char *filename;
|
||||
{
|
||||
- char *c, suffix[MAXSUFFIXLEN];
|
||||
+ char *c, *d;
|
||||
|
||||
+ d = (char *) strrchr(filename, '/');
|
||||
c = (char *) strrchr(filename, '.');
|
||||
|
||||
+ /* make sure the . is part of the filename */
|
||||
+ if (d != NULL && c < d) {
|
||||
+ return 0;
|
||||
+ }
|
||||
+
|
||||
if (c == NULL)
|
||||
return 0;
|
||||
- strcpy(suffix, c + 1);
|
||||
- if (suffix[0] == '\0')
|
||||
+ if (c++ == '\0')
|
||||
return 0;
|
||||
|
||||
- if (!strncmp(suffix, "htm", 3))
|
||||
+ if (!strncmp(c, "htm", 3))
|
||||
return 1;
|
||||
- else if (!strncmp(suffix, "HTM", 3))
|
||||
+ else if (!strncmp(c, "HTM", 3))
|
||||
return 1;
|
||||
- else if (!strncmp(suffix, "shtml", 5))
|
||||
+ else if (!strncmp(c, "shtml", 5))
|
||||
return 1;
|
||||
- else if (!strncmp(suffix, "SHTML", 5))
|
||||
+ else if (!strncmp(c, "SHTML", 5))
|
||||
return 1;
|
||||
return 0;
|
||||
}
|
1
www/swish-e/pkg-comment
Normal file
1
www/swish-e/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
simple web indexing for humans - enhanced
|
9
www/swish-e/pkg-descr
Normal file
9
www/swish-e/pkg-descr
Normal file
@ -0,0 +1,9 @@
|
||||
SWISH-Enhanced is a fast, powerful, flexible, and easy to use system for
|
||||
indexing collections of Web pages or other text files. Key features include
|
||||
the ability to limit searches to certain HTML tags (META, TITLE, comments,
|
||||
etc.). The SWISH-E software is free, and includes a package of Perl programs
|
||||
that enable anyone who is authorized to create and maintain their own indexes
|
||||
(AutoSwish). SWISH-E is an enhanced version of SWISH, which was originally
|
||||
written by Kevin Hughes and modified and released with his permission.
|
||||
|
||||
http://sunsite.berkeley.edu/SWISH-E/
|
1
www/swish-e/pkg-plist
Normal file
1
www/swish-e/pkg-plist
Normal file
@ -0,0 +1 @@
|
||||
bin/swish-e
|
Loading…
Reference in New Issue
Block a user