- Fix build error on -current.

- Use PLIST_FILES instead of pkg-plist.
This commit is contained in:
MANTANI Nobutaka 2020-07-04 15:37:13 +00:00
parent a6677396ff
commit 5aba6458f6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=541219
3 changed files with 7 additions and 2 deletions

View File

@ -21,6 +21,8 @@ PORTDOCS= README
OPTIONS_DEFINE= DOCS
PLIST_FILES= sbin/ufs_copy
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}

View File

@ -58,11 +58,15 @@
fprintf(stderr, "done\n");
else
fprintf(stderr, "failed\n");
@@ -262,6 +289,7 @@ copy_ufs(const char *src_path, const cha
@@ -262,6 +289,11 @@ copy_ufs(const char *src_path, const char *dst_path)
}
}
bcopy(&src, &dst, sizeof(dst));
+#if (defined(__FreeBSD_version) && __FreeBSD_version >= 1300100)
+ dst.d_si = NULL;
+#else
+ dst.d_sbcsum = NULL;
+#endif
dst.d_name = dst_path;
dst.d_fd = open(dst_path, O_CREAT | O_WRONLY, S_IRUSR | S_IWUSR );
if (dst.d_fd < 0) {

View File

@ -1 +0,0 @@
sbin/ufs_copy