Add tea 0.9.1, a simple GTK+ text editor.

PR:		ports/68995
Submitted by:	Jean-Yves Lefort <jylefort@brutele.be>
This commit is contained in:
Kirill Ponomarev 2004-07-13 16:10:46 +00:00
parent 98ec693f71
commit 5aacd41110
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=113565
7 changed files with 111 additions and 0 deletions

View File

@ -177,6 +177,7 @@
SUBDIR += sted
SUBDIR += tamago
SUBDIR += tamago-emacs20
SUBDIR += tea
SUBDIR += ted
SUBDIR += tetradraw
SUBDIR += texmacs

35
editors/tea/Makefile Normal file
View File

@ -0,0 +1,35 @@
# New ports collection makefile for: TEA
# Date created: 13 Jul 2004
# Whom: Jean-Yves Lefort <jylefort@brutele.be>
#
# $FreeBSD$
#
PORTNAME= tea
PORTVERSION= 0.9.1
CATEGORIES= editors
MASTER_SITES= http://tea.linux.kiev.ua/
DISTNAME= ${PORTNAME}
MAINTAINER= jylefort@brutele.be
COMMENT= A simple GTK+ text editor
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_X_PREFIX= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GCC= 3.3
USE_GNOME= gtk20
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR}/en
${MKDIR} ${DOCSDIR}/ru
${INSTALL_DATA} ${WRKSRC}/doc/EN/index.html ${DOCSDIR}/en
${INSTALL_DATA} ${WRKSRC}/doc/RU/index.html ${DOCSDIR}/ru
.endif
.include <bsd.port.mk>

2
editors/tea/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (tea.tar.bz2) = a88523a562d12a0ece89133c647c3558
SIZE (tea.tar.bz2) = 176078

View File

@ -0,0 +1,34 @@
--- src/callbacks.c.orig Tue Jul 13 17:01:57 2004
+++ src/callbacks.c Tue Jul 13 17:05:25 2004
@@ -24,6 +24,7 @@
#include <gdk/gdk.h>
#include <gdk/gdkkeysyms.h>
+#include <sys/param.h>
#include <errno.h>
#include <sys/stat.h>
#include <glib.h>
@@ -1065,9 +1066,10 @@
if (get_page_fnav ())
{
+ char buf[MAXPATHLEN];
gchar *fn = (gchar*) g_malloc (2048);
- if (realpath ((gchar *) get_current_dir_name (), fn))
+ if (getcwd(buf, sizeof(buf)) && realpath (buf, fn))
set_fam_text (fn);
else
set_fam_text ("/");
@@ -3005,9 +3007,10 @@
if (get_page_fnav ())
{
+ char buf[MAXPATHLEN];
gchar *fn = (gchar*) g_malloc (2048);
- if (realpath ((gchar *) get_current_dir_name (), fn))
+ if (getcwd(buf, sizeof(buf)) && realpath (buf, fn))
set_fam_text (fn);
else
set_fam_text ("/");

View File

@ -0,0 +1,25 @@
--- src/tea_text_document.c.orig Tue Jul 13 17:05:42 2004
+++ src/tea_text_document.c Tue Jul 13 17:11:39 2004
@@ -36,6 +36,7 @@
#include <stdio.h>
#include <strings.h>
#include <unistd.h>
+#include <sys/param.h>
#include "tea_file_nav.h"
#include "tea_text_document.h"
@@ -1289,12 +1290,13 @@
t_note_page* page_create_new_filenav (void)
{
+ char buf[MAXPATHLEN];
t_note_page *page = (t_note_page *) g_malloc (sizeof (t_note_page));
page->hash_filelist = NULL;
gchar *fn = (gchar*) g_malloc (2048);
- if (realpath ((gchar *) get_current_dir_name (), fn))
+ if (getcwd(buf, sizeof(buf)) && realpath (buf, fn))
page->current_path = fn;
page->type = 1;

6
editors/tea/pkg-descr Normal file
View File

@ -0,0 +1,6 @@
TEA is a simple GTK+ text editor.
WWW: http://tea.linux.kiev.ua/
- Jean-Yves Lefort
jylefort@brutele.be

8
editors/tea/pkg-plist Normal file
View File

@ -0,0 +1,8 @@
bin/tea
share/locale/ru/LC_MESSAGES/tea.mo
share/locale/uk/LC_MESSAGES/tea.mo
%%PORTDOCS%%%%DOCSDIR%%/en/index.html
%%PORTDOCS%%%%DOCSDIR%%/ru/index.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%/en
%%PORTDOCS%%@dirrm %%DOCSDIR%%/ru
%%PORTDOCS%%@dirrm %%DOCSDIR%%