New port databases/zabbix34-libzbxpgsql: PostgreSQL monitoring module for zabbix34-agent

This project provides comprehensive monitoring of PostgreSQL servers using a
natively compiled Zabbix agent module, written in C.

The module enables discovery and monitoring of tablespaces, databases,
namespaces, tables, indexes, etc.

WWW: http://cavaliercoder.com/libzbxpgsql/

databases/zabbix32-libzbxpgsql -> databases/zabbix34-libzbxpgsql

PR:		222600
Submitted by:	pg@pakhom.spb.ru
Approved by:	Martin Waschbüsch <martin@waschbuesch.de> (maintainer)
This commit is contained in:
Danilo G. Baio 2017-10-12 14:02:39 +00:00
parent 1d4953a5ce
commit 5a9235f94e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=451879
7 changed files with 74 additions and 0 deletions

View File

@ -1048,6 +1048,7 @@
SUBDIR += zabbix22-libzbxpgsql
SUBDIR += zabbix3-libzbxpgsql
SUBDIR += zabbix32-libzbxpgsql
SUBDIR += zabbix34-libzbxpgsql
SUBDIR += zodb3
.include <bsd.port.subdir.mk>

View File

@ -0,0 +1,44 @@
# Created by: Martin Waschbuesch <martin@waschbuesch.de>
# $FreeBSD$
PORTNAME= libzbxpgsql
PORTVERSION= 1.1.0
DISTVERSIONPREFIX= v
CATEGORIES= databases
PKGNAMEPREFIX= zabbix34-
MAINTAINER= martin@waschbuesch.de
COMMENT= Zabbix agent module for comprehensive monitoring of PostgreSQL servers
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${NONEXISTENT}:net-mgmt/${PKGNAMEPREFIX}agent:patch
RUN_DEPENDS= zabbix_agentd:net-mgmt/${PKGNAMEPREFIX}agent
LIB_DEPENDS= libconfig.so:devel/libconfig
CONFLICTS= zabbix[0-24-9][0-13-9]-libzbxpgsql zabbix[0-9]-libzbxpgsql
USES= autoreconf gmake libtool pgsql
USE_GITHUB= yes
GH_ACCOUNT= cavaliercoder
GNU_CONFIGURE= yes
GET_ZBX_WRKSRC= cd ${.CURDIR:H:H}/net-mgmt/${PKGNAMEPREFIX}agent && make -V WRKSRC
CONFIGURE_ARGS= --with-zabbix=$$(${GET_ZBX_WRKSRC})
USE_LDCONFIG= yes
OPTIONS_DEFINE= EXAMPLES
PORTSCOUT= skipv:latest,gh-pages
do-install:
${INSTALL_LIB} ${WRKSRC}/src/.libs/libzbxpgsql.so ${STAGEDIR}${PREFIX}/lib/libzbxpgsql.so
do-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/templates/*.xml ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1503755196
SHA256 (cavaliercoder-libzbxpgsql-v1.1.0_GH0.tar.gz) = 50acc4364241253a013058daf76c4184cc522104f78005d3c4d5e7e09d77571a
SIZE (cavaliercoder-libzbxpgsql-v1.1.0_GH0.tar.gz) = 61106

View File

@ -0,0 +1,12 @@
--- src/libzbxpgsql.c.orig 2016-06-25 14:18:03 UTC
+++ src/libzbxpgsql.c
@@ -24,6 +24,9 @@
*/
#include "libzbxpgsql.h"
+#include <sys/types.h>
+#include <sys/socket.h>
+#include <netinet/in.h>
// Define custom keys
static ZBX_METRIC keys[] =

View File

@ -0,0 +1,7 @@
This project provides comprehensive monitoring of PostgreSQL servers using a
natively compiled Zabbix agent module, written in C.
The module enables discovery and monitoring of tablespaces, databases,
namespaces, tables, indexes, etc.
WWW: http://cavaliercoder.com/libzbxpgsql/

View File

@ -0,0 +1,3 @@
In order to enable the module, add libzbxpgsql.so to the LoadModule=
line in zabbix_agentd.conf and restart the agent with
service zabbix_agentd restart

View File

@ -0,0 +1,4 @@
lib/libzbxpgsql.so
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Template_PostgreSQL_Server_2.0.xml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Template_PostgreSQL_Server_2.4.xml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Template_PostgreSQL_Server_3.0.xml