Unbreak gcc 4.2 build.

Approved by:	portmgr
This commit is contained in:
Max Khon 2007-11-08 19:03:10 +00:00
parent de28323865
commit 5a6a4c8b8b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=202594
3 changed files with 22 additions and 4 deletions

View File

@ -25,10 +25,6 @@ CONFIGURE_ARGS= --prefix=${PREFIX}
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Does not compile with GCC 4.2
.endif
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
.endif

View File

@ -0,0 +1,11 @@
--- include/compatlayer.h.orig 2007-11-05 15:25:07.000000000 +0600
+++ include/compatlayer.h 2007-11-05 15:25:43.000000000 +0600
@@ -324,7 +324,7 @@
library. GCC implemented it in version 3.0. BC++ implemented some
stuff in versions like BC++ 5.5. So that's a real mess. */
#if __GNUC__>=3
- #if __GNUC_MINOR__>=4
+ #if __GNUC__ >= 4 || __GNUC_MINOR__>=4
// gcc 3.4. It have __gnu_cxx::stdio_filebuf class.
#define CLY_filebuf __gnu_cxx::stdio_filebuf<char>
#define CLY_int_filebuf CLY_filebuf

View File

@ -0,0 +1,11 @@
--- include/tv/inputln.h.orig 2007-11-05 15:06:18.000000000 +0600
+++ include/tv/inputln.h 2007-11-05 15:06:41.000000000 +0600
@@ -196,7 +196,7 @@
{ return name; }
protected:
- TInputLine::TInputLine(StreamableInit) :
+ TInputLine(StreamableInit) :
TInputLineBaseT<char,TDrawBuffer>(streamableInit) {}
public: