Update to 20030520.
Submitted by: maintainer
This commit is contained in:
parent
2799d745c3
commit
5a59d4dda2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=81619
@ -6,17 +6,17 @@
|
||||
#
|
||||
|
||||
PORTNAME= ftp-tls
|
||||
PORTVERSION= 20020906
|
||||
PORTVERSION= 20030520
|
||||
CATEGORIES= ftp security
|
||||
MASTER_SITES= ftp://ftp.runestig.com/pub/ftp-tls/
|
||||
MASTER_SITES= ftp://ftp.zeist.de/pub/distfiles/ \
|
||||
ftp://ftp.runestig.com/pub/ftp-tls/
|
||||
|
||||
MAINTAINER= marius@alchemy.franken.de
|
||||
COMMENT= Ftp client supporting FTP AUTH TLS
|
||||
|
||||
USE_AUTOCONF= YES
|
||||
GNU_CONFIGURE= YES
|
||||
|
||||
USE_OPENSSL= YES
|
||||
#USE_OPENSSL= YES
|
||||
|
||||
MAN1= ftp-tls.1
|
||||
|
||||
@ -26,6 +26,11 @@ MAN1= ftp-tls.1
|
||||
BROKEN= "Not supported on systems prior to FreeBSD 4.0 (missing getaddrinfo())"
|
||||
.endif
|
||||
|
||||
.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
|
||||
|
||||
CONFIGURE_ARGS= --with-openssl-dir=${OPENSSLBASE}
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/ftp ${PREFIX}/bin/ftp-tls
|
||||
@${INSTALL_MAN} ${WRKSRC}/ftp.1.TLS ${PREFIX}/man/man1/ftp-tls.1
|
||||
|
@ -1 +1 @@
|
||||
MD5 (ftp-tls-20020906.tar.gz) = 8823a6f9388add4e3fcd4459422d57d8
|
||||
MD5 (ftp-tls-20030520.tar.gz) = c8224fd6640b2160bd1d2ca8ad0a65fe
|
||||
|
@ -1,9 +0,0 @@
|
||||
--- config.h.in.orig Fri Oct 25 14:59:53 2002
|
||||
+++ config.h.in Fri Oct 25 15:02:02 2002
|
||||
@@ -338,3 +338,6 @@
|
||||
|
||||
/* Define to `unsigned' if <sys/types.h> does not define. */
|
||||
#undef size_t
|
||||
+
|
||||
+/* Define if libedit has the NetBSD enhancements. */
|
||||
+#undef ENHANCED_LIBEDIT
|
@ -1,57 +0,0 @@
|
||||
--- configure.in.orig Thu Oct 24 21:28:06 2002
|
||||
+++ configure.in Fri Oct 25 15:03:04 2002
|
||||
@@ -56,6 +56,7 @@
|
||||
AC_CHECK_LIB(nsl, inet_addr)
|
||||
dnl Replace `main' with a function in -lsocks5:
|
||||
dnl AC_CHECK_LIB(socks5, main)
|
||||
+AC_SEARCH_LIBS(el_init, edit, have_libedit=yes, have_libedit=no)
|
||||
|
||||
# Checks for header files.
|
||||
AC_HEADER_DIRENT
|
||||
@@ -302,11 +303,11 @@
|
||||
AC_CHECK_LIB(krb5, krb5_init_context, ,
|
||||
AC_MSG_ERROR(Could not find Kerberos 5 library needed. Try again using --with-krb5-dir=DIR))
|
||||
fi
|
||||
- # look for OpenSSL libraries, also in the legacy (strange) place "/usr/local/ssl"
|
||||
+ # look for OpenSSL libraries
|
||||
AC_CHECK_LIB(crypto, X509_STORE_load_locations, , found_openssl=no)
|
||||
if test "$found_openssl" = no; then
|
||||
- CPPFLAGS="$CPPFLAGS -I/usr/local/ssl/include"
|
||||
- LDFLAGS="$LDFLAGS -L/usr/local/ssl/lib"
|
||||
+ CPPFLAGS="$CPPFLAGS -I$OPENSSLINC"
|
||||
+ LDFLAGS="$LDFLAGS -L$OPENSSLLIB"
|
||||
# remove the cached result of the previous AC_CHECK_LIB()
|
||||
unset ac_cv_lib_crypto_X509_STORE_load_locations
|
||||
AC_CHECK_LIB(crypto, X509_STORE_load_locations, ,
|
||||
@@ -336,10 +337,27 @@
|
||||
if test "$enable_small" = yes; then
|
||||
AC_DEFINE(SMALL)
|
||||
else
|
||||
- LIBS="-ledit -L./libedit $LIBS"
|
||||
- CPPFLAGS="$CPPFLAGS -I./libedit"
|
||||
- LIBEDITTARGET=libedit-all
|
||||
- MANEDITRC=editrc.5
|
||||
+ AC_MSG_CHECKING([for libedit])
|
||||
+ if test $have_libedit = no; then
|
||||
+ AC_MSG_RESULT([no, using my own])
|
||||
+ LIBS="./libedit/libedit.a $LIBS"
|
||||
+ CPPFLAGS="$CPPFLAGS -I./libedit"
|
||||
+ LIBEDITTARGET=libedit-all
|
||||
+ MANEDITRC=editrc.5
|
||||
+ else
|
||||
+ AC_MSG_RESULT([yes])
|
||||
+ LIBEDITTARGET=
|
||||
+
|
||||
+ AC_MSG_CHECKING([for NetBSD enhancements in libedit])
|
||||
+ AC_TRY_COMPILE([#include <histedit.h>], [int X = EL_RPROMPT],
|
||||
+ have_enhanced_libedit=yes)
|
||||
+ if test "$have_enhanced_libedit" = yes; then
|
||||
+ AC_MSG_RESULT([yes])
|
||||
+ AC_DEFINE(ENHANCED_LIBEDIT)
|
||||
+ else
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ fi
|
||||
+ fi
|
||||
fi
|
||||
AC_SUBST(LIBEDITTARGET)
|
||||
AC_SUBST(MANEDITRC)
|
@ -1,24 +0,0 @@
|
||||
--- main.c.orig Fri Oct 25 14:15:16 2002
|
||||
+++ main.c Fri Oct 25 15:05:09 2002
|
||||
@@ -518,6 +518,9 @@
|
||||
#ifndef SMALL
|
||||
} else {
|
||||
const char *buf;
|
||||
+#ifdef ENHANCED_LIBEDIT
|
||||
+ HistEvent ev;
|
||||
+#endif
|
||||
cursor_pos = NULL;
|
||||
|
||||
if ((buf = el_gets(el, &num)) == NULL || num == 0)
|
||||
@@ -532,7 +535,11 @@
|
||||
}
|
||||
memcpy(line, buf, (size_t)num);
|
||||
line[num] = '\0';
|
||||
+#ifndef ENHANCED_LIBEDIT
|
||||
history(hist, H_ENTER, buf);
|
||||
+#else
|
||||
+ history(hist, &ev, H_ENTER, buf);
|
||||
+#endif
|
||||
}
|
||||
#endif /* !SMALL */
|
||||
|
@ -1,22 +0,0 @@
|
||||
--- util.c.orig Fri Oct 25 14:17:24 2002
|
||||
+++ util.c Fri Oct 25 15:07:39 2002
|
||||
@@ -1013,9 +1013,19 @@
|
||||
controlediting()
|
||||
{
|
||||
if (editing && el == NULL && hist == NULL) {
|
||||
+#ifdef ENHANCED_LIBEDIT
|
||||
+ HistEvent ev;
|
||||
+
|
||||
+ el = el_init(progname, stdin, ttyout, stderr); /* init editline */
|
||||
+#else
|
||||
el = el_init(progname, stdin, ttyout); /* init editline */
|
||||
+#endif
|
||||
hist = history_init(); /* init the builtin history */
|
||||
+#ifndef ENHANCED_LIBEDIT
|
||||
history(hist, H_EVENT, 100); /* remember 100 events */
|
||||
+#else
|
||||
+ history(hist, &ev, H_SETSIZE, 100); /* remember 100 events */
|
||||
+#endif
|
||||
el_set(el, EL_HIST, history, hist); /* use history */
|
||||
|
||||
el_set(el, EL_EDITOR, "emacs"); /* default editor is emacs */
|
Loading…
Reference in New Issue
Block a user