Unbreak build by fixing varargs problem on gcc3.3.

PR:		ports/62391
Submitted by:	Hiroki Sato <hrs@freebsd.org>
Maintainer timeout:	4 weeks
This commit is contained in:
Mark Linimon 2004-03-04 05:09:28 +00:00
parent 3a9e4d5d50
commit 5a5697333d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=102873
5 changed files with 92 additions and 48 deletions

View File

@ -21,10 +21,4 @@ MANLANG= ja
MAN1= prn.1 cprn.1 cmt.1 psconv.1
MAN5= cmtdefs.5
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502000
BROKEN= "Does not compile"
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,41 +0,0 @@
*** prn.c.orig Thu May 26 11:37:45 1994
--- prn.c Mon Jun 9 12:29:28 1997
***************
*** 34,41 ****
#include <sys/stat.h>
#include "euc.h"
#define KCCPATH "/usr/local/bin/kcc"
! #if defined (__bsdi__)
#define LPRPATH "/usr/bin/lpr"
#else
#define LPRPATH "/usr/ucb/lpr"
--- 34,46 ----
#include <sys/stat.h>
#include "euc.h"
+ #if !defined KCCPATH
#define KCCPATH "/usr/local/bin/kcc"
! #endif
! #if (defined(__unix__) || defined(unix)) && !defined(USG)
! #include <sys/param.h>
! #endif
! #if defined (__bsdi__) || (defined(BSD) && (BSD >= 199103))
#define LPRPATH "/usr/bin/lpr"
#else
#define LPRPATH "/usr/ucb/lpr"
***************
*** 48,55 ****
--- 53,64 ----
#else
+ #if !defined CMTPATH
#define CMTPATH "/usr/local/bin/cmt"
+ #endif
+ #if !defined PSPATH
#define PSPATH "/usr/local/bin/psconv"
+ #endif
#endif

View File

@ -0,0 +1,23 @@
--- cmt.c.orig Mon Apr 25 16:26:57 1994
+++ cmt.c Fri Feb 6 00:18:46 2004
@@ -352,16 +352,15 @@
error(format, arg1, arg2, ...)
char *format;
---------------------------------------------------------------------*/
-#include <varargs.h>
+#include <stdarg.h>
-void error(va_alist)
- va_dcl
+void error(char *a, ...)
{
va_list args;
- va_start(args);
+ va_start(args, a);
fprintf(stderr, "%s: ", progname);
- vfprintf(stderr, va_arg(args, char *), args);
+ vfprintf(stderr, a, args);
putc('\n', stderr);
va_end(args);
exit(1);

View File

@ -0,0 +1,8 @@
--- cmt.h.orig Fri Feb 6 00:13:05 2004
+++ cmt.h Fri Feb 6 00:13:18 2004
@@ -32,4 +32,4 @@
/*
* Error handling function.
*/
-extern void error();
+extern void error(char *, ...);

View File

@ -0,0 +1,60 @@
--- prn.c.orig Thu May 26 11:37:45 1994
+++ prn.c Fri Feb 6 00:18:11 2004
@@ -34,8 +34,13 @@
#include <sys/stat.h>
#include "euc.h"
+#if !defined KCCPATH
#define KCCPATH "/usr/local/bin/kcc"
-#if defined (__bsdi__)
+#endif
+#if (defined(__unix__) || defined(unix)) && !defined(USG)
+#include <sys/param.h>
+#endif
+#if defined (__bsdi__) || (defined(BSD) && (BSD >= 199103))
#define LPRPATH "/usr/bin/lpr"
#else
#define LPRPATH "/usr/ucb/lpr"
@@ -48,8 +53,12 @@
#else
+#if !defined CMTPATH
#define CMTPATH "/usr/local/bin/cmt"
+#endif
+#if !defined PSPATH
#define PSPATH "/usr/local/bin/psconv"
+#endif
#endif
@@ -96,7 +105,7 @@
static char *filename; /* name of the file being processed */
static char *modtime; /* the last modification time */
-static void error();
+static void error(char *, ...);
static char *basename();
static bool formatopt();
static bool rangeopt();
@@ -498,16 +507,15 @@
error(format, arg1, arg2, ...)
char *format;
---------------------------------------------------------------------*/
-#include <varargs.h>
+#include <stdarg.h>
-static void error(va_alist)
- va_dcl
+static void error(char *a, ...)
{
va_list args;
- va_start(args);
+ va_start(args, a);
fprintf(stderr, "%s: ", progname);
- vfprintf(stderr, va_arg(args, char *), args);
+ vfprintf(stderr, a, args);
putc('\n', stderr);
va_end(args);
exit(1);