- Update to 6.7.1

Submitted by:	jp@suppintr.io
Approved by:	elastic@ (feld)
This commit is contained in:
Ryan Steinmetz 2019-05-07 14:35:56 +00:00
parent 282ef0f93b
commit 5a0516d9d7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=500964
10 changed files with 1188 additions and 50 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= beats
PORTVERSION= 6.6.0
PORTREVISION= 0
PORTVERSION= 6.7.1
DISTVERSIONPREFIX=v
CATEGORIES= sysutils
@ -12,53 +11,51 @@ COMMENT= Collect logs locally and send to remote logstash
LICENSE= APACHE20
USES= gmake go
USE_GITHUB= yes
GH_ACCOUNT= elastic
USES= gmake go
GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
USE_RC_SUBR= ${GO_TARGETS}
GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
FIND_ARGS= "! ( -regex .*/*\.(go|in|log) ) ! -path *test* ! -path *vendor*"
MAKE_ENV+= GOBUILD_FLAGS=""
OPTIONS_DEFAULT=FILEBEAT HEARTBEAT METRICBEAT
OPTIONS_DEFINE= FILEBEAT HEARTBEAT METRICBEAT PACKETBEAT
OPTIONS_SUB= yes
OPTIONS_MULTI= BEATS
OPTIONS_MULTI_BEATS=${OPTIONS_DEFAULT}
FILEBEAT_DESC= Filebeat
FILEBEAT_VARS= GO_TARGETS+=filebeat
PACKETBEAT_DESC=Packetbeat
PACKETBEAT_VARS=GO_TARGETS+=packetbeat
PACKETBEAT_BROKEN= An underlying library is currently broken under FreeBSD
METRICBEAT_DESC=Metricbeat
METRICBEAT_VARS=GO_TARGETS+=metricbeat
HEARTBEAT_DESC= Heartbeat
HEARTBEAT_VARS=GO_TARGETS+=heartbeat
MAKE_ENV+= GOBUILD_FLAGS=""
HEARTBEAT_VARS= GO_TARGETS+=heartbeat
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPACKETBEAT}
BROKEN= An underlying library is currently broken under FreeBSD
.endif
do-build:
@for GO_TARGET in ${GO_TARGETS}; do \
cd ${GO_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GO_ENV} ${GMAKE} -C $${GO_TARGET} ;\
done
.for GO_TARGET in ${GO_TARGETS}
@(cd ${GO_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GO_ENV} ${GMAKE} -C ${GO_TARGET})
.endfor
do-install:
for GO_TARGET in ${GO_TARGETS}; do \
${INSTALL_PROGRAM} ${GO_WRKSRC}/$${GO_TARGET}/$${GO_TARGET} \
${STAGEDIR}${PREFIX}/sbin ;\
${INSTALL_DATA} ${WRKSRC}/$${GO_TARGET}/$${GO_TARGET}.yml \
${STAGEDIR}${PREFIX}/etc/$${GO_TARGET}.yml.sample ;\
${MKDIR} ${STAGEDIR}/var/db/beats/$${GO_TARGET} ;\
done
.for GO_TARGET in ${GO_TARGETS}
${INSTALL_PROGRAM} ${GO_WRKSRC}/${GO_TARGET}/${GO_TARGET} \
${STAGEDIR}${PREFIX}/sbin
${INSTALL_DATA} ${WRKSRC}/${GO_TARGET}/${GO_TARGET}.yml \
${STAGEDIR}${PREFIX}/etc/${GO_TARGET}.yml.sample
${MKDIR} ${STAGEDIR}/var/db/beats/${GO_TARGET}
.endfor
.for BEATMOD in filebeat metricbeat
${MKDIR} ${STAGEDIR}${ETCDIR}/${BEATMOD}.modules.d ${STAGEDIR}${DATADIR}/${BEATMOD}/module
(cd ${WRKSRC}/${BEATMOD}/module && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/${BEATMOD}/module ${FIND_ARGS})
(cd ${WRKSRC}/${BEATMOD}/modules.d && ${COPYTREE_SHARE} . ${STAGEDIR}${ETCDIR}/${BEATMOD}.modules.d)
.endfor
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1550092172
SHA256 (elastic-beats-v6.6.0_GH0.tar.gz) = 0e55beab8945ba4c8035afcd22ae263d2c955dfc47e420d5231780ab53391342
SIZE (elastic-beats-v6.6.0_GH0.tar.gz) = 29109311
TIMESTAMP = 1555453757
SHA256 (elastic-beats-v6.7.1_GH0.tar.gz) = a7834293870d73d734110975daed5660022df868bf01815e873d7c1e1bc761cc
SIZE (elastic-beats-v6.7.1_GH0.tar.gz) = 33042733

View File

@ -1,4 +1,4 @@
--- filebeat/filebeat.yml.orig 2017-02-09 15:20:52 UTC
--- filebeat/filebeat.yml.orig 2017-02-09 15:20:52 UTC
+++ filebeat/filebeat.yml
@@ -112,3 +112,5 @@ output.elasticsearch:
# To enable all selectors use ["*"]. Examples of other selectors are "beat",

View File

@ -1,4 +1,4 @@
--- heartbeat/heartbeat.yml.orig 2017-02-20 22:45:44 UTC
--- heartbeat/heartbeat.yml.orig 2017-02-20 22:45:44 UTC
+++ heartbeat/heartbeat.yml
@@ -77,3 +77,5 @@ output.elasticsearch:
# To enable all selectors use ["*"]. Examples of other selectors are "beat",

View File

@ -1,5 +1,5 @@
--- libbeat/scripts/Makefile.orig 2018-02-01 16:56:52.000000000 +0100
+++ libbeat/scripts/Makefile 2018-02-07 12:53:00.911420000 +0100
--- libbeat/scripts/Makefile.orig 2018-02-01 16:56:52.000000000 +0100
+++ libbeat/scripts/Makefile 2018-02-07 12:53:00.911420000 +0100
@@ -27,7 +27,7 @@
GOFILES_NOVENDOR = $(shell find . -type f -name '*.go' -not -path "*/vendor/*")
GOFILES_ALL = $(GOFILES) $(shell find $(ES_BEATS) -type f -name '*.go')

View File

@ -1,4 +1,4 @@
--- metricbeat/metricbeat.yml.orig 2017-02-20 22:45:44 UTC
--- metricbeat/metricbeat.yml.orig 2017-02-20 22:45:44 UTC
+++ metricbeat/metricbeat.yml
@@ -103,3 +103,5 @@ output.elasticsearch:
# To enable all selectors use ["*"]. Examples of other selectors are "beat",

View File

@ -1,8 +1,8 @@
--- packetbeat/packetbeat.yml.orig 2017-02-09 16:20:52.000000000 +0100
+++ packetbeat/packetbeat.yml 2017-02-21 02:04:13.919394000 +0100
--- packetbeat/packetbeat.yml.orig 2017-02-09 16:20:52.000000000 +0100
+++ packetbeat/packetbeat.yml 2017-02-21 02:04:13.919394000 +0100
@@ -10,8 +10,10 @@
#============================== Network device ================================
# Select the network interface to sniff the data. On Linux, you can use the
-# "any" keyword to sniff on all connected interfaces.
-packetbeat.interfaces.device: any
@ -10,9 +10,9 @@
+# and the beats programmers did not bother to implement it, so you must set this
+# to your preferred device
+packetbeat.interfaces.device: em0
#================================== Flows =====================================
@@ -147,3 +149,5 @@
# To enable all selectors use ["*"]. Examples of other selectors are "beat",
# "publish", "service".

View File

@ -7,5 +7,5 @@
- return syscall.Mknod(path, mode, dev)
+ return syscall.Mknod(path, mode, uint64(dev))
}
// Mkdev is used to build the value of linux devices (in /dev/) which specifies major

View File

@ -1,10 +0,0 @@
--- vendor/github.com/elastic/gosigar/sigar_freebsd.go.orig 2018-08-05 17:40:01 UTC
+++ vendor/github.com/elastic/gosigar/sigar_freebsd.go
@@ -4,6 +4,7 @@ package gosigar
import (
"io/ioutil"
+ "runtime"
"strconv"
"strings"
"unsafe"

File diff suppressed because it is too large Load Diff