add perltidy
Indents and reformats Perl scripts to make them easier to read
This commit is contained in:
parent
b00f825c35
commit
5a04170825
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39029
@ -114,6 +114,7 @@
|
||||
SUBDIR += p5-dTemplate
|
||||
SUBDIR += par
|
||||
SUBDIR += perl2html
|
||||
SUBDIR += perltidy
|
||||
SUBDIR += pspell
|
||||
SUBDIR += pspell-ispell
|
||||
SUBDIR += py-HyperText
|
||||
|
35
textproc/perltidy/Makefile
Normal file
35
textproc/perltidy/Makefile
Normal file
@ -0,0 +1,35 @@
|
||||
# ex:ts=8
|
||||
# New ports collection makefile for: perltidy
|
||||
# Date created: Mar 4, 2001
|
||||
# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= perltidy
|
||||
PORTVERSION= 20010304
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ijliao@FreeBSD.org
|
||||
|
||||
USE_PERL5= yes
|
||||
NO_BUILD= yes
|
||||
|
||||
MAN1= perltidy.1
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g ; \
|
||||
s|%%MANPREFIX%%|${MANPREFIX}|g" ${WRKSRC}/Makefile
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/perltidy
|
||||
.for ext in html pod txt
|
||||
${CP} ${WRKSRC}/docs/*.${ext} ${PREFIX}/share/doc/perltidy/
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
textproc/perltidy/distinfo
Normal file
1
textproc/perltidy/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (perltidy-20010304.tgz) = 047e74dfba19bbd44c2792e7625e34ac
|
20
textproc/perltidy/files/patch-Makefile
Normal file
20
textproc/perltidy/files/patch-Makefile
Normal file
@ -0,0 +1,20 @@
|
||||
--- Makefile.orig Sun Mar 4 19:47:45 2001
|
||||
+++ Makefile Sun Mar 4 19:49:36 2001
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
# Step 1: edit BINDIR to reflect where you want to put perltidy
|
||||
# This is fairly standard:
|
||||
-BINDIR = /usr/local/bin
|
||||
+BINDIR = %%PREFIX%%/bin
|
||||
|
||||
# Step 2: edit MANDIR to reflect where you want to put the man page, perltidy.1
|
||||
# or comment out MANDIR to skip installing a man page.
|
||||
@@ -10,7 +10,7 @@
|
||||
# Hint: if directory usr/local/man/man1 does not exist,
|
||||
# you might find the man path by entering the command
|
||||
# perl '-V:install.*' and looking for the value of 'installman1dir'
|
||||
-MANDIR = /usr/local/man/man1
|
||||
+MANDIR = %%MANPREFIX%%/man/man1
|
||||
|
||||
# Step 3: Then become superuser (if necessary) and issue the command
|
||||
# make install
|
1
textproc/perltidy/pkg-comment
Normal file
1
textproc/perltidy/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Indents and reformats Perl scripts to make them easier to read
|
5
textproc/perltidy/pkg-descr
Normal file
5
textproc/perltidy/pkg-descr
Normal file
@ -0,0 +1,5 @@
|
||||
Perltidy reads a Perl script and writes an indented, reformatted
|
||||
script. The default formatting closely follows the recommendations
|
||||
in perlstyle(1).
|
||||
|
||||
WWW: http://perltidy.sourceforge.net/
|
8
textproc/perltidy/pkg-plist
Normal file
8
textproc/perltidy/pkg-plist
Normal file
@ -0,0 +1,8 @@
|
||||
bin/perltidy
|
||||
%%PORTDOCS%%share/doc/perltidy/perltidy.html
|
||||
%%PORTDOCS%%share/doc/perltidy/perltidy.pod
|
||||
%%PORTDOCS%%share/doc/perltidy/perltidy.txt
|
||||
%%PORTDOCS%%share/doc/perltidy/tutorial.html
|
||||
%%PORTDOCS%%share/doc/perltidy/tutorial.pod
|
||||
%%PORTDOCS%%share/doc/perltidy/tutorial.txt
|
||||
%%PORTDOCS%%@dirrm share/doc/perltidy
|
Loading…
Reference in New Issue
Block a user