- Update to 0.7.0.1

Obtained from:	FreeBSD Haskell
This commit is contained in:
Gabor Pali 2012-02-13 05:50:36 +00:00
parent 75be60638b
commit 59fa7e2754
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=291248
9 changed files with 52 additions and 62 deletions

View File

@ -6,18 +6,18 @@
#
PORTNAME= heist
PORTVERSION= 0.5.2.1
PORTVERSION= 0.7.0.1
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= An xhtml templating system
COMMENT= An (x)html templating system
LICENSE= BSD
CABAL_SETUP= Setup.hs
USE_CABAL= attoparsec>=0.8.1 attoparsec-text>=0.8 blaze-builder>=0.2 \
directory-tree MonadCatchIO-transformers>=0.2.1 mtl>=2 \
text>=0.10 transformers xmlhtml>=0.1
USE_CABAL= attoparsec>=0.10 blaze-builder>=0.2 directory-tree \
MonadCatchIO-transformers>=0.2.1 mtl>=2.0 text>=0.10 \
transformers xmlhtml>=0.1
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (cabal/heist-0.5.2.1.tar.gz) = a14287d1624f0de57640a2f9ca5a474b3d9b2a110d9fb87fe4b561b1adf0e685
SIZE (cabal/heist-0.5.2.1.tar.gz) = 34546
SHA256 (cabal/heist-0.7.0.1.tar.gz) = 51155789d481a7673a6c5e3912259fc0d7672840841fe121472c83786ad313c2
SIZE (cabal/heist-0.7.0.1.tar.gz) = 36375

View File

@ -6,7 +6,7 @@
#
PORTNAME= snap-core
PORTVERSION= 0.5.2
PORTVERSION= 0.7.0.1
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
@ -15,11 +15,15 @@ COMMENT= Snap: A Haskell Web Framework (Core)
LICENSE= BSD
CABAL_SETUP= Setup.hs
USE_CABAL= attoparsec>=0.8.0.2 attoparsec-enumerator>=0.2.0.3 \
blaze-builder>=0.2.1.4 bytestring-nums case-insensitive \
deepseq>=1.1 dlist>=0.5 enumerator>=0.4.13.1 \
MonadCatchIO-transformers>=0.2.1 mtl>=2 text>=0.11 \
transformers>=0.2 unix-compat>=0.2 vector>=0.6 zlib
USE_CABAL= attoparsec>=0.10 attoparsec-enumerator>=0.3 \
base16-bytestring blaze-builder>=0.2.1.4 \
blaze-builder-enumerator>=0.2 bytestring-nums \
case-insensitive>=0.3 deepseq>=1.1 dlist>=0.5 \
enumerator>=0.4.13.1 HUnit>=1.2 \
MonadCatchIO-transformers>=0.2.1 mtl>=2.0 \
mwc-random>=0.10 regex-posix text>=0.11 transformers>=0.2 \
unix-compat>=0.2 unordered-containers>=0.1.4.3 vector>=0.6 \
zlib-enum>=0.2.1
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (cabal/snap-core-0.5.2.tar.gz) = 14d234b4706e5e993e1e5c4178ede3e8ccafa070daf96eb826bc0681e17b52f2
SIZE (cabal/snap-core-0.5.2.tar.gz) = 74409
SHA256 (cabal/snap-core-0.7.0.1.tar.gz) = e9b2a4924ed80031d1e0b9a5d7e3a1b5dd831eaf5990819040e453c5991f1c04
SIZE (cabal/snap-core-0.7.0.1.tar.gz) = 84601

View File

@ -1,11 +0,0 @@
--- ./snap-core.cabal.orig 2011-06-23 17:08:48.000000000 +0200
+++ ./snap-core.cabal 2011-07-18 15:34:06.000000000 +0200
@@ -133,7 +133,7 @@
blaze-builder >= 0.2.1.4 && <0.4,
bytestring,
bytestring-nums,
- case-insensitive >= 0.2 && < 0.3,
+ case-insensitive >= 0.2,
containers,
deepseq >= 1.1 && <1.2,
directory,

View File

@ -1,4 +1,21 @@
Snap is a simple and fast web development framework and server written in
Haskell.
Snap is a simple and fast web development framework and server written
in Haskell. This library contains the core definitions and types for
the Snap framework, including:
WWW: http://snapframework.com/
1. Primitive types and functions for HTTP (requests, responses, cookies,
post/query parameters, etc).
2. Type aliases and helper functions for Iteratee I/O.
3. A monad for programming web handlers called "Snap", inspired by happstack's,
which allows:
- Stateful access to the HTTP request and response objects.
- Monadic failure (i.e. MonadPlus/Alternative instances) for declining to
handle requests and chaining handlers together.
- Early termination of the computation if you know early what you want to
return and want to prevent further monadic processing.
WWW: http://snapframework.com/

View File

@ -6,7 +6,7 @@
#
PORTNAME= snap-server
PORTVERSION= 0.5.2
PORTVERSION= 0.7.0.1
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
@ -15,16 +15,16 @@ COMMENT= A fast, iteratee-based, epoll-enabled web server for the Snap Framework
LICENSE= BSD
CABAL_SETUP= Setup.hs
USE_CABAL= attoparsec>=0.8.1 attoparsec-enumerator>=0.2.0.1 binary>=0.5 \
USE_CABAL= attoparsec>=0.10 attoparsec-enumerator>=0.3 binary>=0.5 \
blaze-builder>=0.2.1.4 blaze-builder-enumerator>=0.2 \
bytestring-nums case-insensitive>=0.2 directory-tree \
bytestring-nums case-insensitive>=0.3 directory-tree>=0.10 \
enumerator>=0.4.13.1 MonadCatchIO-transformers>=0.2.1 mtl>=2 \
murmur-hash>=0.1 network>=2.3 PSQueue>=1.1 snap-core>=0.5.2 \
text>=0.11 transformers unix-compat>=0.2 utf8-string \
vector>=0.7 vector-algorithms>=0.4
murmur-hash>=0.1 network>=2.3 PSQueue>=1.1 snap-core>=0.7 \
text>=0.11 transformers>=0.2 unix-compat>=0.2 vector>=0.7 \
vector-algorithms>=0.4
OPTIONS= LIBEV "Use libev" off \
GNUTLS "Enable https support using the libgnutls library" off
OPENSSL "Enable HTTPS support using the HsOpenSSL library" off
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
@ -36,11 +36,11 @@ USE_CABAL+= hlibev
CONFIGURE_ARGS+= --flags="-libev"
.endif
.if defined(WITH_GNUTLS)
CONFIGURE_ARGS+= --flags="gnutls"
LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls
.if defined(WITH_OPENSSL)
CONFIGURE_ARGS+= --flags="openssl"
USE_CABAL+= HsOpenSSL
.else
CONFIGURE_ARGS+= --flags="-gnutls"
CONFIGURE_ARGS+= --flags="-openssl"
.endif
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"

View File

@ -1,2 +1,2 @@
SHA256 (cabal/snap-server-0.5.2.tar.gz) = 2e06bfdf6d0d19f18f4f0666feb691c003ee1faa52cb72a73e055728571ab142
SIZE (cabal/snap-server-0.5.2.tar.gz) = 59328
SHA256 (cabal/snap-server-0.7.0.1.tar.gz) = e398abb4579512bef4d064622b6f7421aae88f07028402984ebc5956537b3291
SIZE (cabal/snap-server-0.7.0.1.tar.gz) = 60559

View File

@ -1,20 +0,0 @@
--- ./snap-server.cabal.orig 2011-07-20 22:05:26.000000000 +0200
+++ ./snap-server.cabal 2011-08-13 10:58:29.000000000 +0200
@@ -108,7 +108,7 @@
blaze-builder-enumerator >= 0.2.0 && <0.3,
bytestring,
bytestring-nums,
- case-insensitive >= 0.2 && < 0.3,
+ case-insensitive >= 0.2,
containers,
directory-tree,
enumerator >= 0.4.13.1 && <0.5,
@@ -125,7 +125,7 @@
transformers,
unix-compat == 0.2.*,
vector >= 0.7 && <0.8,
- vector-algorithms >= 0.4 && <0.5,
+ vector-algorithms >= 0.4,
PSQueue >= 1.1 && <1.2
if flag(portable) || os(windows)