- Add staging support
- Convert to USES=tar:bzip2, new options framework - Use @sample for configuration files
This commit is contained in:
parent
a80d61a390
commit
59bdab0024
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=354437
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= lynx
|
||||
DISTVERSION= ${VERSION}.${MINOR_VERSION:S/.//}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= japanese www ipv6
|
||||
MASTER_SITES= http://lynx.isc.org/current/ \
|
||||
http://ftp2.uk.freebsd.org/sites/lynx.isc.org/current/
|
||||
@ -18,64 +19,42 @@ MINOR_VERSION= dev.3
|
||||
CONFLICTS= lynx-2.* ja-lynx-2.8.7.*
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}${VERSION:S/./-/g}
|
||||
USE_BZIP2= yes
|
||||
USES= tar:bzip2
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+=--with-screen=ncurses --with-zlib --libdir="${L_LIB}" \
|
||||
--enable-nsl-fork --enable-ipv6 \
|
||||
--enable-cjk --enable-internal-links \
|
||||
--with-bzlib
|
||||
|
||||
.if !defined(WITHOUT_JAPANESE_UTF8)
|
||||
USES+= iconv
|
||||
CONFIGURE_ARGS+=${ICONV_CONFIGURE_ARG} \
|
||||
--enable-japanese-utf8
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-japanese-utf8
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_EXPERIMENTAL_OPTS)
|
||||
# experimental optional configure args
|
||||
CONFIGURE_ARGS+=--enable-addrlist-page \
|
||||
--enable-charset-choice
|
||||
.endif
|
||||
|
||||
.if defined(WITH_COLOR_STYLE)
|
||||
CONFIGURE_ARGS+=--enable-color-style
|
||||
PLIST_SUB+= WITH_COLOR_STYLE=""
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-color-style
|
||||
PLIST_SUB+= WITH_COLOR_STYLE="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_DEFAULT_COLORS)
|
||||
CONFIGURE_ARGS+=--enable-default-colors
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-default-colors
|
||||
.endif
|
||||
|
||||
MAKE_ARGS= helpdir=${L_HELP} docdir=${DOCSDIR}
|
||||
MAKEFILE= makefile
|
||||
MAN1= lynx.1
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
INSTALL_TARGET= install-full
|
||||
.else
|
||||
INSTALL_TARGET= install install-help
|
||||
.endif
|
||||
|
||||
L_LIB= ${PREFIX}/etc
|
||||
L_HELP= ${PREFIX}/share/lynx_help
|
||||
|
||||
NO_STAGE= yes
|
||||
OPTIONS_DEFINE= COLOR_STYLE DEFAULT_COLORS DOCS EXPERIMENTAL_OPTS JAPANESE_UTF8
|
||||
OPTIONS_DEFAULT=EXPERIMENTAL_OPTS JAPANESE_UTF8
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
COLOR_STYLE_DESC= Color style (ncurses/ncurses)
|
||||
COLOR_STYLE_CONFIGURE_ENABLE= color-style
|
||||
|
||||
DEFAULT_COLORS_DESC= Default colors (ncurses/slang)
|
||||
DEFAULT_COLORS_CONFIGURE_ENABLE=default-colors
|
||||
|
||||
EXPERIMENTAL_OPTS_DESC= Experimental options
|
||||
EXPERIMENTAL_OPTS_CONFIGURE_ON= --enable-addrlist-page \
|
||||
--enable-charset-choice
|
||||
|
||||
JAPANESE_UTF8_DESC= Experimental Japanese UTF-8 logic
|
||||
JAPANESE_UTF8_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG} \
|
||||
--enable-japanese-utf8
|
||||
JAPANESE_UTF8_CONFIGURE_OFF= --disable-japanese-utf8
|
||||
JAPANESE_UTF8_USES= iconv
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-lssl -lcrypto|-L${OPENSSLLIB} &|g' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
|
||||
.endif
|
||||
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${L_HELP}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,46 +0,0 @@
|
||||
--- makefile.in.orig 2007-05-18 07:53:22.000000000 +0900
|
||||
+++ makefile.in 2008-06-29 16:30:48.000000000 +0900
|
||||
@@ -365,14 +365,9 @@
|
||||
if test "$(COMPRESS_PROG)" != "" ; then \
|
||||
(cd $(HELPDIR) && $(COMPRESS_PROG) $$files ) \
|
||||
fi'
|
||||
- @echo Updating $(sysconfdir)/lynx.cfg
|
||||
- @ECHO_CC@$(SHELL) -c \
|
||||
- 'if test -f $(SYSCONFDIR)/lynx.cfg ; then \
|
||||
- mv $(SYSCONFDIR)/lynx.cfg $(SYSCONFDIR)/lynx.tmp ; \
|
||||
- else \
|
||||
- cp $(srcdir)/lynx.cfg $(SYSCONFDIR)/lynx.tmp ; \
|
||||
- fi'
|
||||
- @echo Updating $(sysconfdir)/lynx.cfg to point to installed help-files
|
||||
+ @echo Updating $(sysconfdir)/lynx.cfg.default
|
||||
+ cp $(srcdir)/lynx.cfg $(SYSCONFDIR)/lynx.tmp ;
|
||||
+ @echo Updating $(sysconfdir)/lynx.cfg.default to point to installed help-files
|
||||
@ECHO_CC@sed -e '/^HELPFILE:http/s!^!#!' \
|
||||
-e '/^#HELPFILE:file/s!#!!' \
|
||||
$(SYSCONFDIR)/lynx.tmp | \
|
||||
@@ -380,9 +375,9 @@
|
||||
$(SHELL) $(scripts_dir)/cfg_path.sh lynx_doc $(helpdir) | \
|
||||
sed -e '/^HELPFILE:file/s!$$!$(COMPRESS_EXT)!' \
|
||||
-e '/^HELPFILE:file/s!$(COMPRESS_EXT)$(COMPRESS_EXT)$$!$(COMPRESS_EXT)!' \
|
||||
- >$(SYSCONFDIR)/lynx.cfg
|
||||
- chmod 644 $(SYSCONFDIR)/lynx.cfg
|
||||
+ >$(SYSCONFDIR)/lynx.cfg.default
|
||||
-rm -f $(SYSCONFDIR)/lynx.tmp
|
||||
+ -[ ! -f $(SYSCONFDIR)/lynx.cfg ] && $(INSTALL_DATA) $(SYSCONFDIR)/lynx.cfg.default $(SYSCONFDIR)/lynx.cfg
|
||||
|
||||
LYHelp.h : help_files.sed LYHelp.hin
|
||||
@echo Creating $@
|
||||
@@ -404,10 +399,11 @@
|
||||
$(SHELL) -c 'SHELL=$(SHELL) $(SHELL) $(scripts_dir)/cfg_defs.sh $(srcdir)'
|
||||
|
||||
install-cfg : $(SYSCONFDIR)
|
||||
- @$(SHELL) $(scripts_dir)/install-cfg.sh "$(INSTALL_DATA)" $(srcdir)/lynx.cfg $(SYSCONFDIR)/lynx.cfg
|
||||
+ @$(SHELL) $(scripts_dir)/install-cfg.sh "$(INSTALL_DATA)" $(srcdir)/lynx.cfg $(SYSCONFDIR)/lynx.cfg.default
|
||||
|
||||
install-lss : $(SYSCONFDIR)
|
||||
- @$(SHELL) $(scripts_dir)/install-lss.sh "$(INSTALL_DATA)" $(srcdir)/samples/lynx.lss $(SYSCONFDIR)/lynx.lss
|
||||
+ @$(SHELL) $(scripts_dir)/install-lss.sh "$(INSTALL_DATA)" $(srcdir)/samples/lynx.lss $(SYSCONFDIR)/lynx.lss.default
|
||||
+ -[ ! -f $(SYSCONFDIR)/lynx.lss ] && $(INSTALL_DATA) $(SYSCONFDIR)/lynx.lss.default $(SYSCONFDIR)/lynx.lss
|
||||
|
||||
uninstall ::
|
||||
@MSG_DIR_MAKE@ cd po && $(MAKE_RECUR) uninstall
|
34
japanese/lynx-current/files/patch-makefile.in
Normal file
34
japanese/lynx-current/files/patch-makefile.in
Normal file
@ -0,0 +1,34 @@
|
||||
--- makefile.in.orig 2014-05-18 17:40:49.321601176 +0200
|
||||
+++ makefile.in 2014-05-18 17:42:33.446626842 +0200
|
||||
@@ -320,7 +320,7 @@
|
||||
fi'
|
||||
$(SHELL) -c 'for name in COPYING COPYHEADER; do \
|
||||
cd $(HELPDIR) && rm -f $$name ;\
|
||||
- cd $(HELPDIR) && ( $(LN_S) $(DOCDIR)/$$name . || cp $(DOCDIR)/$$name . );\
|
||||
+ cd $(HELPDIR) && ( $(LN_S) $(docdir)/$$name . || cp $(DOCDIR)/$$name . );\
|
||||
done'
|
||||
-$(SHELL) -c 'case `id|sed -e "s/(.*//"` in uid=0) chown -R root $(DOCDIR);; esac'
|
||||
|
||||
@@ -399,8 +399,8 @@
|
||||
$(SHELL) $(scripts_dir)/cfg_path.sh lynx_doc $(helpdir) | \
|
||||
sed -e '/^HELPFILE:file/s!$$!$(COMPRESS_EXT)!' \
|
||||
-e '/^HELPFILE:file/s!$(COMPRESS_EXT)$(COMPRESS_EXT)$$!$(COMPRESS_EXT)!' \
|
||||
- >$(SYSCONFDIR)/lynx.cfg
|
||||
- chmod 644 $(SYSCONFDIR)/lynx.cfg
|
||||
+ >$(SYSCONFDIR)/lynx.cfg.sample
|
||||
+ chmod 644 $(SYSCONFDIR)/lynx.cfg.sample
|
||||
-rm -f $(SYSCONFDIR)/lynx.tmp
|
||||
|
||||
LYHelp.h : help_files.sed $(srcdir)/LYHelp.hin
|
||||
@@ -423,10 +423,9 @@
|
||||
$(SHELL) -c 'SHELL=$(SHELL) $(SHELL) $(scripts_dir)/cfg_defs.sh $(srcdir)'
|
||||
|
||||
install-cfg : $(SYSCONFDIR)
|
||||
- @$(SHELL) $(scripts_dir)/install-cfg.sh "$(INSTALL_DATA)" $(srcdir)/lynx.cfg $(SYSCONFDIR)/lynx.cfg
|
||||
|
||||
install-lss : $(SYSCONFDIR)
|
||||
- @$(SHELL) $(scripts_dir)/install-lss.sh "$(INSTALL_DATA)" $(srcdir)/samples/lynx.lss $(SYSCONFDIR)/lynx.lss
|
||||
+ @$(SHELL) $(scripts_dir)/install-lss.sh "$(INSTALL_DATA)" $(srcdir)/samples/lynx.lss $(SYSCONFDIR)/lynx.lss.sample
|
||||
|
||||
uninstall ::
|
||||
@MSG_DIR_MAKE@ cd $(PO_DIR) && $(MAKE_RECUR) uninstall
|
@ -1,10 +1,7 @@
|
||||
bin/lynx
|
||||
@unexec if [ -f %D/etc/lynx.cfg ] && cmp -s %D/etc/lynx.cfg %D/etc/lynx.cfg.default; then rm -f %D/etc/lynx.cfg; fi
|
||||
etc/lynx.cfg.default
|
||||
@exec if [ ! -f %D/etc/lynx.cfg ] ; then cp -p %D/%F %B/lynx.cfg; fi
|
||||
%%WITH_COLOR_STYLE%%@unexec if [ -f %D/etc/lynx.lss ] && cmp -s %D/etc/lynx.lss %D/etc/lynx.lss.default; then rm -f %D/etc/lynx.lss; fi
|
||||
%%WITH_COLOR_STYLE%%etc/lynx.lss.default
|
||||
%%WITH_COLOR_STYLE%%@exec if [ ! -f %D/etc/lynx.lss ] ; then cp -p %D/%F %B/lynx.lss; fi
|
||||
@sample etc/lynx.cfg.sample
|
||||
%%COLOR_STYLE%%@sample etc/lynx.lss.sample
|
||||
man/man1/lynx.1.gz
|
||||
@exec mkdir -p %D/share/lynx_help
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYHEADER
|
||||
|
Loading…
Reference in New Issue
Block a user