audio/tap-plugins-lv2: Removed unused SIMD flags.
Also, moved patches under files/ PR: 223614 Submitted by: Jan Beich <jbeich@FreeBSD.org> Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13051
This commit is contained in:
parent
61282a01c6
commit
59b2f640d6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=454028
@ -7,7 +7,7 @@ PORTREVISION= 1
|
||||
CATEGORIES= audio
|
||||
PKGNAMESUFFIX= -lv2
|
||||
|
||||
MAINTAINER= yuri@rawbw.com
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= LV2 port for the TAP (Tom's Audio Processing) plugins
|
||||
|
||||
LICENSE= GPLv2
|
||||
@ -21,11 +21,7 @@ GH_ACCOUNT= moddevices
|
||||
GH_PROJECT= tap-lv2
|
||||
GH_TAGNAME= de26a3c
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's| -O3||; s| -Wl,-O1||; s| -fstrength-reduce||; s| -Wl,--strip-all||' \
|
||||
${WRKSRC}/Makefile.mk
|
||||
@${REINPLACE_CMD} -e 's|^inline$$||' \
|
||||
${WRKSRC}/dynamics/tap_dynamics.c
|
||||
MAKE_ENV+= NOOPT=true
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} \
|
||||
|
13
audio/tap-plugins-lv2/files/patch-Makefile.mk
Normal file
13
audio/tap-plugins-lv2/files/patch-Makefile.mk
Normal file
@ -0,0 +1,13 @@
|
||||
--- Makefile.mk.orig 2016-01-25 10:55:48 UTC
|
||||
+++ Makefile.mk
|
||||
@@ -3,8 +3,8 @@
|
||||
CC ?= gcc
|
||||
|
||||
# flags
|
||||
-CFLAGS += -O3 -funroll-loops -ffast-math -fomit-frame-pointer -fstrength-reduce -Wall -Werror -fPIC -DPIC -I../utils
|
||||
-LDFLAGS += -shared -Wl,-O1 -Wl,--as-needed -Wl,--no-undefined -Wl,--strip-all -lm -lrt
|
||||
+CFLAGS += -funroll-loops -ffast-math -fomit-frame-pointer -Wall -Werror -fPIC -DPIC -I../utils
|
||||
+LDFLAGS += -shared -Wl,--as-needed -Wl,--no-undefined -lm -lrt
|
||||
|
||||
ifneq ($(NOOPT),true)
|
||||
CFLAGS += -mtune=generic -msse -msse2 -mfpmath=sse
|
11
audio/tap-plugins-lv2/files/patch-dynamics_tap__dynamics.c
Normal file
11
audio/tap-plugins-lv2/files/patch-dynamics_tap__dynamics.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- dynamics/tap_dynamics.c.orig 2016-01-25 10:55:48 UTC
|
||||
+++ dynamics/tap_dynamics.c
|
||||
@@ -267,7 +267,7 @@ rms_env_process(rms_env *r, const rms_t
|
||||
|
||||
|
||||
|
||||
-inline
|
||||
+
|
||||
float
|
||||
get_table_gain(int mode, float level) {
|
||||
|
Loading…
Reference in New Issue
Block a user